"Roon Database & Settings" not ready

Core Machine (Operating system/System info/Roon build number)

Version 1.0 (build 219) stable

Description Of Issue

On the Web GUI i get “Roon Database & Settings not ready”

Hi @Simon_Burns,

You did not specify what Roon is running on, however, from a previous post it looks like :

ROCK running on Dell Optiplex 3060. i5 8th Gen.

Is this correct?

Apologies, yes that’s correct.

1 Like

Hi @Simon_Burns,

Did this issue occur after doing something in particular?
Did a reboot of the Core sort this issue out?

You should be aware that this is not a supported ROCK platform, the only ones we officially support are the ones located on this list.

Hi Norris,

yes it’s a (relatively) new install. I only noticed it earlier as I realised I was on a DHCP not Static IP.

I’m not actually seeing any lack of functionality, just checking if there’s a known issue / easy fix.

I was looking at getting a ROCK supported platform, but am hoping to get the most of some unused kit before spending any money!



Hi @Simon_Burns,

Since you are running ROCK on unsupported hardware, it’s hard to say if this is a known issue, it could be environmental due to the hardware in use.

All other hardware except for the one listed in the guide is not supported, and we won’t be able to troubleshoot this when running on unsupported gear.

Hi Noris,

totally understand.

Out of interest, what, if any reduced functionality might I expect to see, with this showing as “not ready”?


Can you post a screen shot of the web GUI please

See below

There is no DNS server in the IP config. Did you get the same error when you used DHCP? Does DHCP provide DNS servers? Try to put in for DNS and see if that changes anything.

If I copy across the DNS server from DHCP settings, I lose internet radio and can’t login to Tidal. Saw another post with similar issues and the fix recommended was using (Google’s).

Will give a go and report back. or (Cloudflare) should give the same result. If that doesn’t work I’d check that DNS requests are returned to your network. A Windows or Linux PC cmd->nslookup will help diagnose this. I guess on MacOS too, but I don’t use that.

That screenshot of the Web Admin page does not contain a section for the Roon Server software, which is very strange, and probably why the Roon Database is complaining it is not ready…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.