Roon does not properly show MQA logo

I lately noticed that roon does not properly identify the MQA logo on all albums or tracks.
But if you press the signal path button, MQA is indicated.

The workaround is to delete the album and paste it again.
Now the MQA logo will show.

My DAC does decode and renders it as MQA and lights the green or blue lights.

This is odd


How can a 16-bit source even be MQA? I thought that proper MQA is always 24-bit, the additional 8-bits being used/needed for the additional information that makes up MQA?

1 Like

It’s all explained here if you are interested.


Thanks for sharing, much appreciated.

The first image appears to be a mobile device, whereas the other is not. Is that correct? If so, have you enabled Show MQA badge in the settings for all control devices?

both from roon desktop (Windows 10)

As you can see, 3 MQA albums are not properly identified - this is just an example from one artist

On one of the examples, please share a screenshot of the Album page Versions tab. Thanks.

I bought it from the Tidal store - it IS mqa. Just not identified as such

Another example:

These albums are local versions, so the TIDAL badge won’t be displayed: the MQA badge comes from TIDAL data too (we know this because this can be incorrect at times*.) Likewise, track analysis doesn’t use the MQA core decoder–its purpose is to determine the dynamic range and track waveform–and won’t, therefore, see the MQA information contained within the file.

You’ll see the file’s MQA credentials during playback because this is processed by the MQA core decoder. This behaviour is to be expected.

Similarly, Qobuz, releases from 2L do not display MQA information until played.

1 Like

That’s incorrect Martin. If you have local MQA content, it should display with the MQA logo.

1 Like

Addendum: I think (but I can’t be 100%) that MQA logo display relies on the correct file tag being present, rather than analysis of the actual audio content.

If this is the case, then I’m not seeing this on my downloaded MQA releases either.

Edit: That’s because I turned the badge off! :laughing:

With the last update Roon may take a long time to analyze files. I had a similar situation with a local mqa file which I added to the roon library. It showed up as 24bit 48khz Flac but signal path and the inicator on the DAC showed MQA 96kHz.

When I checked settings->library I saw over 100 files in the queue which needed to be analyzed. Please note the MQA badge is only shown after the analysis has been completed. I checked again after some hours and then all was synchronized and the badge showed.

This is probably also the case in your situation. I do not go into the discussion why roon is actually so slow in analyzing newly added files.