Roon Does Not Recognize My New Pi

I just built a Pi3 with the HiFiBerry DAC+ Pro. I loaded the HiFiBerry Roon image (1.2.2) and I am not seeing the Pi under networked audio devices. The Pi runs fine on my wired network. Can ssh into it from my Mac and Roon server (I5 NUC). This is not the first device I have used with Roon. I am successfully running 2 Squeezebox Touch units and an Odroid C2 with no issues. Have rebooted the server and manually stopped and started Roon several times…no luck.


Is Roon Bridge installed and running on the Pi?

Oops… guess that does not come as part of the image

It should – in the form of a slightly different RoonReady version. Is the DAC+ Pro seen at? What does ‘aplay -l’ say?

The Hifiberry image should work ‘out of the box’ but is customized, making it hard to troubleshoot. Alternatively – you could flash DietPi to a card and config the DAC+ Pro / install RoonBridge from the menu after boot.

aplay: device_list:268: no soundcards found…

There’s your problem. Try disassembling / reseating the Dac board.

Is the correct overlay loaded from /boot/config.txt?


Thanks, may need a little help. Here are the overlays i config.txt

Enable audio (loads snd_bcm2835)


I built the unit in the steel hifiberry case. the cover holds the dac and mates when you join it with the base. I believe it has to be seated because it closed nicely

This is weird: the Hifiberry image should automatically detect the correct board. Do you really have the DAC+ Pro – or the Digi+ board?

If it is the first: change it to


And reboot.

I know the case (have it myself) and agree it’s hard to do anything wrong with it. Still, it won’t hurt to check. :wink:

If all else fails, you may want to try the DietPi route. It has a few advantages (optimised setup, loggin to RAM instead of SD) and is way easier to troubleshoot. More info here (long thread alert):

That did it. Question: Why two entries?

It looks like you installed RoonBridge manually.

You should not do that on the HifiBerry image, as it already contains all you need (that’s the RoonReady one).

The Pi did not show because the wrong overlay was loaded (should not have happened, but alas).

To uninstall RoonBridge:

sudo rm -fr /var/roon
sudo rm -fr /opt/RoonBridge

sudo systemctl disable roonbridge.service


Thanks Rene, all is sounding wonderful on my headphone rig. I just can not get over the value of these little ARM setups. Running with my MRU linear supply I had purchased for my Squeezebox Touch. Thanks again.


Glad you’re up and running. And yes – the little buggers punch way above their weight. :slight_smile: