Roon does not see Oppo 205 via WiFi on QNAP Core

Core Machine (Operating system/System info/Roon build number)
QNAP Latest OS and Roon updates.
iPad Roon client.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Hardwired 10 G network, Asus AX Router, Netgear 10GbE switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Oppo 203 hardwired, Oppo 205 wireless 5GHz

Description Of Issue
Roon does not find my Oppo 205 on my wireless network. It does find my Oppo 203 on the wired network. The 205 shows up when I do network discovery, and the Oppo connection test works fine.

Have you tried rebooting your router?

Hi @David_Moor,

I too would suggest a reboot of your devices - the Core, Networking Gear and Oppo 205 as well.
If that does not help - is there any change in behavior if you try temporarily plugging your Oppo 205 via Ethernet?

Well this is interesting. Rebooted router, NAS, and Oppo. No change.

I also have 2 HomePods next to the Oppo. They aren’t seen either. 2 HomePods in the living room are seen. All of the HomePods are on the same 5 Ghz network and are running 13.4.8. So one set is seen and one set isn’t, even though on the same network.

The 4th generation 5G Apple TV next to the Oppo isn’t seen. The wired 4K Apple TV downstairs is seen.

This used to work. Router didn’t change, but there have been HomePod and Roon updates. QNAP Roon is 1.7 build 571.

Hi @David_Moor,

This behavior sounds fairly strange. Do you by any chance have a PC you can try to temporarily host the Roon Core on? You can use these instructions to do so:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

I also have Roon on a Mac. Had the same problem until I disabled little snitch. The devices appeared.

Screen Shot 2020-08-14 at 12.11.54 AM|690x72

What is the 192.168.147.100?

Switched back to the QNAP and the devices aren’t there. Both the Mac and QNAP are connected to the same 10 Gbe switch. Disconnected the thunderbolt port but no change.

This implies that there is some QNAP setting that is preventing discovery. Just don’t know what it is.

Hi @David_Moor,

I would check your router to see what that is, possibly it’s the Roon Server itself.

Little Snitch is known to cause issues with Roon, so I would make sure you have the proper exceptions in place.

Can you access your QNAP logs by using these instructions and post a set?

I’m flagging our QNAP package creator (@crieke) to see if he can provide further guidance, since this issue appears to be QNAP-specific.

Have you tried connecting the oppo 205 by wire as @noris suggested?

As far as I know, HomePods are also exclusively connected eith a WiFi connection. So I am wondering if this is somehow related to your WiFi connection.

Hopefully I got the QNAP log files right …

1 Like

Hi @David_Moor,

It looks like the QNAP is indeed finding the Oppo, but a networking issue is preventing connection:

08/13 19:33:03 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] => ConnectionFailed
08/13 19:33:03 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] client connection failed. Retrying in 500ms
08/13 19:33:04 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] connecting (attempt 2)
08/13 19:33:04 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] => Connecting
08/13 19:33:11 Info: [stats] 4243mb Virtual, 912mb Physical, 411mb Managed, 0 Handles, 68 Threads
08/13 19:33:14 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] => ConnectionFailed
08/13 19:33:14 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] client connection failed. Retrying in 750ms
08/13 19:33:14 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] connecting (attempt 3)
08/13 19:33:14 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] => Connecting
08/13 19:33:24 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] => ConnectionFailed
08/13 19:33:24 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] client connection failed. Retrying in 1125ms
08/13 19:33:25 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] connecting (attempt 4)
08/13 19:33:25 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] => Connecting
08/13 19:33:26 Info: [stats] 4243mb Virtual, 912mb Physical, 414mb Managed, 0 Handles, 65 Threads
08/13 19:33:29 Warn: [raat_ll/client] [OPPO UDP-205 @ 10.0.0.103:42576] failed to connect No route to host
08/13 19:33:29 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] => ConnectionFailed
08/13 19:33:29 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] client connection failed. Retrying in 1687ms
08/13 19:33:30 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] connecting (attempt 5)
08/13 19:33:30 Trace: [raat] [OPPO UDP-205 @ 10.0.0.103:42576] => Connecting
08/13 19:33:32 Warn: [raat_ll/client] [OPPO UDP-205 @ 10.0.0.103:42576] failed to connect No route to host

I would try to reinstall the Roon app on the QNAP or connect it by Ethernet cable.

I reinstalled Roon on the QNAP and the devices in the bedroom (Oppo, AppleTV, HomePods) appeared. The Oppo and Apple TV disappeared after some minutes. The HomePods, which didn’t show earlier, now are there.

Can’t connect via Ethernet since no wired connection available in that location.