Roon doesn't recognize Jriver22 [Solved]

I was messing around with upsamlpling. I tried Hqplayer then Jriver 20. I liked what I heard out Jriver. So I upgraded to version 22, because people have been happy with the new SoX resampling. My problem is that Roon doesn’t recognize Jriver 22. Only the past versions 19 and 20 which are no longer on my computer. What gives? I’ve tried re-scanning but nothing happens. Oh yeah, I’ve rebooted it a million times hoping something will take. Any suggestions

I figured it out. Had to engage WDM on Jriver first. After doing this Roon showed Jriver22 available as a zone. This allows anything on the computer to be fed thru Jriver, ie. websites, YouTube, whatever you want. In my case Roon. Then I can use any of Jriver’s available plugins.

Are you getting any glitches when using JRiver WDM? I could never get mine to work glitch-free.

1 Like

No, unfortunately. I did get those glitches occasionally during a listening session, so I gave up on that. I did enjoy the sound better then using HQ-player, just a personal preference. I was hoping I could use theater view and mimilyrics with it for a better visual experience. That didn’t work either. All other plugins worked. I liked being able to adjust the eq with room correction.

I did not know of this capability, between Roon and Jriver. Is it possible to make Jriver 22 available as a zone on a Mac?


I’m using a PC, so I’m not sure how the Mac set up works. It’s been awhile since I tried it but Jriver shows up in Roon as a network source. I choose that and and set Jriver to accept WDM. Then everything from Roon went through Jriver. I could use all Jrivers DSP options then. Now that Roon has there own dsp I don’t Care as much.