Roon Extension: Alarm Clock v0.9.1 (current)

Hi @Jan_Koudijs. Hoping I might be able to ask for your help with a problem with the Alarm Clock extension. I have a problem similar to some described above, where the radio is often playing, but at 0, 1 or 2 volume (I have it set to fade up to 14). Sometimes though it doesn’t play at all, and the extension crashes.
I wanted to be able to present logs with this request for technical assistance, but unfortunately I don’t seem to be able to get these either. When I follow your logging instructions, I don’t see any option to ‘collect logs’, I just see ‘enabled’ or ‘disabled’ options (it’s currently ‘enabled’). I can’t seem to change this, either - it just hangs indefinitely at ‘Saving…’ if I do so.
The Roon core is a QNAP server, it’s always been super stable and effective, and the extension used to work perfectly when I used it in a different zone. Since switching the zone however, it’s rarely worked at all, sometimes with the low-volume problem, sometimes by crashing. Can you possibly help?
Many thanks!

The shuffle behavior is intended functionality of the Alarm Clock extension. I choose to always shuffle a playlist because I assumed the selected playlist to be pretty static and wanted to avoid waking up every day with the same song, but your use case is clearly different.

I previously described my thought process here:

There I also described that album selection is not provided because it would be a terrible experience when dealing with thousands of albums.

Back to the shuffling of playlists, the Roon API provides the functionality to play a playlist in order but that requires an update of the extension. I might include this in the next release, but no ETA.

What version of the Extension Manager are you running?

Thanks for replying. I’m on 0.11.9, and the alarm clock is on 0.9.0.

Edit: I’ve spotted that you have a later version out, and obviously it couldn’t be updated to automatically. I’ve being trying for the last few hours to install it on my QNAP with no success. Currently I can’t work out how to sort the environment variables correctly, and (I think consequently) I don’t have the ‘Docket socket’, so installation fails. Happy to look at this if it’s the best solution - is there something obvious I should be entering into environment variables? Thanks again.

Yes, I saw this thing before but I somehow missed that shuffling is on purpose. How about simple switch in the alarm settings for ordered or shuffled queuing when the alarm goes off?

That would be awesome <3

Anything on this though?

Thank you so much for clearing that up and all the work you already poured into this!

That’s indeed the old version, for which logging works different. Collecting logs is described in this post. You restart the Alarm clock with logging and when the issue occured you download the logs by clicking the Extension Manager link in the Extensions list.

Not all QNAP models have the Docker feature, you have to check if your model supports Container Station.

The idea is to have a “Playlist” and “Playlist (shuffle)” option in the Source dropdown. Genre will always shuffle as that is the only option provided by the Roon API.

I have no plans to implement this.

Hi Jan,

Have you given any more thought to providing an alarm that stops all zones? I would like to do this before my daily backup.

Thanks for your work!!

Thanks very much for your reply.

I’ve tried that log collection method for 0.11.9 but unfortunately the link times out. It seems to be trying to reach an IP that as far as I’m aware is not on my network ( so I guess that that is why?

Regarding Docker, the existing Extension Manager is running on Docker in the Container station - that’s no problem - it’s just configuring it to work from your instructions that I’m struggling with. Docker environment variables are set via a dialogue box as follows:

What’s hard to work out is what the variable name is and what the variable value is from your Docker instructions. Forgive me - the only time I’ve ever used Docker is for REM so I’m not good at it!

Your instructions say:

However, I can’t use commands during setup I think, I only have this dialogue box to set these, and I am sure it’s likely to be why the installation can’t find the Docker socket. Is there anything you can clarify regarding how to define these variables please? Happy to move to the REM thread if that helps.

Many thanks!

The best way (IMO) to install the Roon Extension Manager on QNAP is described in:

You have to run that command (stat -c '%g' /var/run/docker.sock) in a console. If you have SSH enabled, you can use an SSH console session for that purpose.

1 Like

Thank you very much - that worked well! Unfortunately I still cannot access logs as the connection to the 10.x.x.x address times out - I will try again once the system has had time to make some relevant logs.

Thanks very much for your help.

I’ve been using the Alarm Clock extension for a couple of months now. Stability needs some work. I’ll get it all running fine, and then it will skip a morning, only to work again the next day. A few weeks ago, the durned thing went off at 4:30 in the morning… my alarm is at 7:30. This morning, it went off at 7… a half hour early.

I’ve got a 2nd alarm, no big deal, but waking up earlier than I intended is not much fun.

Any advise? Or should I just quit using it…

That’s an option I would like to see implemented too. :slight_smile:

Happy to confirm that the reliability issues are fixed now that I’ve upgraded to the new version of the Extension Manager.
However there’s still an issue with logs. The IP address is wrong - it defaults to a 10.x.x.x when my Roon server and extensions are at a 192.x.x.x. If I replace the IP address from the Extension Manager with the IP of my Roon server, it works fine. I’m not sure why the Extenson Manager has this wrong IP address, and I’m happy with my workaround, but I wanted to flag this. It may be unique to QNAP of course.

Not sure where to post this issue, but the alarm clock is not showing up in the extension list anymore, after a week’s use only.

The 1.1.2 DietPi Roon extension manager runs on a Rpi 4B 2G. It’s connected to the same switch my Nucleus is on.

The alarm clock worked fine for a week, but I needed to change the day, time and zone settings last night. That’s when it disapeared from the extension list, whatever the remote I use.

Well, it sorts of blinks quicly twice or more times and disapears for good every time it is reinstalled. I’m getting nowhere. I’d be greatful for any help. Many thanks in advance.

Is the Extension Manager still in the list? If so it will be useful if you collect the log files as described here.

Yes indeed! The logs are downloaded. Where would you please like me to share those logs, dear Jan?

Perhaps I should have hit the Reply button for you to be notified. Apologies and thanks for your help.

I was notified and have sent you a private message via this forum. Anything in your notifications?

1 Like

Turns out that an activated alarm without an output configured caused a restart loop. I released an update to fix this behavior. If you update the Alarm Clock to version 0.9.1 via the Extension Manager then it should re-appear and you can finalize the alarm setup.

1 Like