Roon Extension: Deep Harmony - rich feature set for Logitech Harmony


(Adam Goodfellow) #129

In general, if you already have a volume control integration that is better than can be achieved via a harmony remote, then you should stick with your existing control. This is why there is an option to omit controls you don’t need.

If I understand what you are saying however, then are you are saying that Harmony cannot control the Atom (Ignoring my Roon extension for now) - ie Logitech have not provided a profile for it perhaps via wifi?

If the answer is that Harmony cannot directly control the atom, then a future option I had already in mind was to allow Harmony remote volume and mute to directly control Roon (rather then the current other way around where Roon controls a device via Harmony). This would then allow volume and mute buttons on Harmony to control devices that are already controlled by Roon (ie USB DACs, or any device that already has a more specific direct volume control extension available, for eg Yamaha and Denon AVRs).


(simon arnold) #130

Yep Harmony cant control it at all as it does not do Zigbee (at least not in uk without the addon, and then its not guaranteed to work).So yes being able to control Roons volume would work for me as it works like a DAC’s would I guess as its the devices volume.


(Larry Post) #131

@Adam_Goodfellow

Adam, I’m still running 1.0 for now. Is there a way to prevent the Harmony actions from executing? Sometimes I like to have my ‘TV’ on muted, and play my 2 channel…currently when I play anything in Roon it stops any video playing on my ‘TV’.

I really only want the transport controls in Harmony to work with Roon as they do now perfectly. I don’t need the activity and/or zone control connection.

Thank you


(Adam Goodfellow) #132

V2 gives quite a bit more flexibility of transport vs roon integration controls and may suit you better in that you can choose to have transport control and volume control, but not source switching. Of course for transport control then Harmony still needs the roku emulator device mapped on to the remote, for at least the transport controls.


(Larry Post) #133

Thanks, I’ll upgrade soon


(Adam Goodfellow) #134

Deep Harmony v2.1.0 Released

This should be available for auto-update within the extension within the next hour or so for V2 users. (V1 users who wish to update will need to re-install and re-setup.)
image
When you see this, open settings and expand the Tools section.
From the update now dropdown, selct the new version and click Save.
The update will download and install and the extension will restart. This should take no more than about 30 seconds.
image
(The above assumes running in docker or with run.sh or run.bat. If otherwise, then the extension will most likely just exit and you will need to restart it manually).

New Features

  • Volume control of other extensions and direct devices (DACs with volume control) from Harmony remote (will need some button customization to add new volume and mute commands).
  • Support for separate buttons on Harmony remote for seek and skip (will need some button customization to use)
  • From within the volume up/down buttons in Roon - can now control zones via an option that are not the current activity (depending on how your AV/Hifi equipment is organised).
  • New options section in settings for choosing above options

Fixes

  • With multiple activities that have volume and/or source controls, Roon can sometimes loose track of which control belongs with which zone (usually following a restart of Roon or the extension). This had to be fixed in the Roon SDK, so using a private build pending PR reviews.

Improvements

  • Tweaks to existing dual function seek/skip
  • Tracking of Harmony hub IP address changes following reboots of Harmony hubs and/or router. Sometime the extension would not detect the IP change and thus not be able to reconnect to a hub.

Issues

  • Harmony does not auto repeat all buttons - there is nothing I can do about this directly, though posts to Logitech forums may get a response. Of particular note it does not auto-repeat the roku volume buttons despite that it does so for many other devices.

Download points:

ReadMe

Docker:

https://store.docker.com/community/images/khazul/roon-extension-deep-harmony

  • v2.1.0.243-linux-amd64
  • v2.1.0.243-linux-arm

Console Apps


(Le Fur Arnaud) #135

Thank you for separate seek and skip implementation.
Now just have to wait for roon to allow extension installation in ROCK and i’ll power off my old iMac.


(simon arnold) #136

Great Stuff with the update. I can now use the harmony to control the Atoms volume. Now to get another hub for system 2.


#137

Im running Roon on a Nucleus, but have a QNAP nas for my music store. I can run Deep Harmony on the QNAP and have the Core on the NUC see it? That’d be great.


(Larry Post) #138

Yes. I run Linux core and have deep harmony docker running on another Linux box, no problem.


(simon arnold) #139

That’s how I have it running.


(Jeffrey Robbins) #140

Are folks using Alexa to voice control the Harmony Hub for this extension? JCR


(simon arnold) #141

I could but hate the bloody thing.


#143

Hi, was wondering if someone can help me…I have the extension installed and Roon sees it. I have settings set to the right harmonyhub and the right activity. I am using remote ID 1. Is that all I need to do? I can not control pause/skip etc with my remote. I have a harmony one remote, do I need to also program these keys in the harmony app? What device would I add in order to do so? Thanks!


(simon arnold) #144

Did you read the full instructions on how to configure it? Read the instructions here


(simon arnold) #146

@Adam_Goodfellow this appears to have stopped working with the new Roon core update this week. I can no longer see the Allow Source Control n my endpoints. Not sure if its the extension or the latest Roon server.


(Adam Goodfellow) #147

Hi, Simon, what platform is your core running on?
Also sent you PM for logs.


(Adam Goodfellow) #148

Is anyone else having issues with controls? If so what platform are you running the core on? Might be also useful to know if anyone else not having any issues.

I have build 354 on my QNAP NAS and have no problems.


(simon arnold) #149

Core running on ROCK. I think this is related to the latest update as it was fine until then. Other extensions also seem to be a bit flakey and crash a lot. Others have also had issues with different extensions and not one of my sources now shows the Allow Source Control option. I will send logs when I am back home tonight.


(Adam Goodfellow) #150

Odd - then you will be running the same Linux x64 build as me. The only difference is mine is wrapped as a QPKG for easy install on my NAS.

What are you running the extension on? Have you tried restarting the extension? It is possible that mine is OK because I often have to stop my release install of the extension to switch over to using a dev version.