Roon Extension: Deep Harmony - rich feature set for Logitech Harmony

Hi there,
Did anybody had any success running the extension on Docker installed on Photon OS ?
I tried it yesterday, but Roon software don’t see it on network.
Note : it works with same procedure installed on Ubuntu Server, but I’d like to use a lighter distribution.
Note 2 : I do my tests using ESXi virtual machines

Maybe some network rules to add on the Photon OS server ?
Ping and tcp port 9080 are responding from my Roon Core server.

Any ideas ? Thanks :wink:

Ok, after some researchs and network tcpdumps, I found out that Photon OS is pretty secure and blocks all input network flows.
Here are the mandatory specific rules to make the extension work via a linux iptables firewall.

# discover and communicate with Roon Core
iptables -A INPUT -p udp --sport 9003 -j ACCEPT
iptables -A INPUT -p tcp --sport 9330 -j ACCEPT
# discover Harmony Hub on local network
iptables -A INPUT -p tcp --dport 50000 -j ACCEPT
# remote favourites flow
iptables -A INPUT -p tcp --dport 8061 -j ACCEPT

Plus, it looks like netcat is used for remote favourites and must be installed.

I’ve started having issues with Deep Harmony over the last week or so. I don’t know the cause, but I’d observe that in the same timeframe by Roon Core has updated to build 918.

The behaviour is that:

  • All playback halts for zones configured with external source controls (because it can’t talk to Harmony)
  • Roon still shows the extension as active
  • Clicking on the Deep Harmony link opens up the website and shows my shortcuts to remotes
  • Clicking on the Roon Extension Settings link shows an empty extension
  • Restarting the docker container does not help
  • Restarting the Roon Core fixes it, for a period

Hi, could you restart the core so that it is working, take a note the date/time, then when it starts to fail, also take a note of the date/time, then please extract the logs using the web ui via clicking on the Deep Harmony link. I will PM you my email address.

Thanks Adam, I’ve had to restart core for another reason recently so will monitor and keep you posted.

1 Like

Happened again, sent you the logs.

This is continuing to happen regularly. As mentioned previously, the only change between working perfectly and now consistently breaking is upgrading to build 918 so I’m leaning towards it breaking the extension. (I’ve noticed another unrelated bug in build 918).

Hi, I have looked over the logs and can see connectivity issues with Harmony hub where it appears you are (for eg) trying to change volume, and after accepting several volume change commands, harmony hub stops responding.

Typically I have been able to correlate this to wifi issues, but cannot say 100% this is the initial cause given that I have been seeing increasing issues with other aspects of harmony over recent months (for eg, loosing track of my samsung smartthings and phillips hue hubs until I access lights etc from the harmony app), so I cannot say for certain what I going on with harmony these days.

Personally I have not experienced any issues with keeping connected with Roon core on my own system nor being unable to recover from the hub becoming apparently unresponsive temporarily.

Also how is your diet pi connected to your network? Wifi or ethernet? While the extension is quite fault tolerant of intermittent network connectivity with harmony (as I have always found Harmony to be a little flakey), Roon’s own network protocol very quickly kills the pairing in the case of a connectivity issue of more than a second or so, but will normally keep trying to re-establish the pairing. I can see a number of occasions in your logs where connectivity to Roon has been lost for a few seconds and it has re-paired.

I suggest that just while we try to resolve this, you change the log level in the extension to ‘all’. Open the extension settings, expand ‘Tools’ and change Log Level drop down to ‘All’. This will let me see additional network traffic detail including Roon’s internal keep alive pinging.

When this happens again, perhaps you could try restarting the extension directly via its web api: -
Open the extension web UI by clicking on the settings link, then replace the word ‘console’ in the url with ‘reboot’ and press return. You will see the extension momentarily disappear from Roon extension setting list and reappear as it restarts.The Web UI will go blank.

Thanks Adam,

I’ve enabled the detailed logging as you’ve suggested. Providing a few more details on my environment below and will then revert with more info once it fails again.

My 2x Harmony Hubs are on Wifi (obviously… I’m not aware of a way to LAN them?)
My Deep Harmony Extension is running in docker on the same host as my Roon Core.
My Roon Core is running on DietPi x64 (running on a GA-J1900N-D3V (rev. 1.x) Overview | Motherboard - GIGABYTE Global mini-PC) using the onboard ethernet. I used to run ROCK on this (unsupported) but I found the networking a little flakey with streams sometimes pausing, so I switched to DietPi and it’s been reliable since then (well… until this issue I guess).

I’ve found that restarting Core will always fix the issue (not the whole box, just the RoonServer service), but I’ve not tried restarting the extension so that’s something I’ll test next time.

The only other thing I can think of that might be relevant is that I’ve been importing more CD rips lately and had increased the background analysis to 4-cores to speed this up. I’ve dropped it to 3-cores to see if that has any impact on Deep Harmony (perhaps Docker wasn’t getting access to enough resources?).

This could be onto something… since setting it to 3-cores I haven’t noticed any more drops. Will continue to monitor.

I have two Harmony Hubs. One (ID 1 in this extension’s settings) is used with an Allo USBridge running latest RoPieee in my living room. The other hub (ID 2) is used with my macbook in my bedroom. For some reason this extension has stopped working in my living room but still works fine in my bedroom. I’ve tried resetting all config and setting it all back up but only the bedroom zone ends up working. What would make it do this? Something in one of the roon 9xx builds?

When you say ‘stopped working’ I assume that means control integration is no longer functioning - is this both ways? Remote no longer controlling Roon and Roon no longer controlling volume/activity select?

When you tried to set up this hub again, was it discovered? Were you able to associate an activity etc but then found the control integration not working after setup?

Yes.

Yes.

Yes.

I’ve also started having issues with Deep Harmony since yesterday. First issue was that I could not play any songs on the audio device linked to Deep Harmony. When I pressed play on a song it just hangs. If i disabled Deep Harmony it worked again. I am at the point now that Deep Harmony will work for play/pause etc. but i can no longer control the volume on the amp. I have tried fresh install of DH on a synology docker container and DietPi and the results are the same. Been working fine for the last year before this. Running the latest version of Roon Core on Windows NUC.

This was fixed for me with the latest Roon update

After removing the device from Harmony (via the iOS app) and re-adding it it is now working. My hub recently died and was replaced with another. For whatever reason this is the only device that needed removing/re-adding.

Hi,

I’d like to be able to have playlists shuffle automatically when they are triggered using one of the favourite buttons. The queue is always reset to not shuffle when I start a playlist in this way.

I have harmony set up to play a specific playlist (using a favourites button) when I launch an activity, but there is no way of adding a step to toggle shuffle as this is set via the Roon Control (Roku) device using ‘Input HDMI 1’ which an input setting which can’t be added as a step in the start sequence for my activity.

As far as I can see there is no way of having all playlists shuffle automatically in Roon (or the queue to always use shuffle), so I can’t see a way of automating this.

Would it be possible to use another button in the Roku device for shuffle, so that this is available to the startup sequence? Or is there another way of achieving what I would like to do?

Thanks,

Nick

2.6.7+387 (Synology Docker), Roon 2.0 b.1128

Hi. Thank you for great extension. Roon 2.0, enable source count causes a problem with playing songs. Simply, playback does not work Disabling the source control, restores playback to work. Volume control works fine.

Regards, T.

With source control enabled, then Roon will wait until the source is ready before commencing playback.

I would guess that the source is not reporting as ready which points to an issue with the harmony side of the configuration settings and/or the harmony hub not reporting back its status.

I suggest carefully checking that the harmony activity and associated zone settings are correct.

There is no current mechanism to do this (shuffle on/off with a playlist) within Deep Harmony.

It may be possible to set up a multi-command macro in Harmony itself.