Roon Extension: Deep Harmony - rich feature set for Logitech Harmony


(Al) #81

No, I don’t have any internet radio service setup.


(Adam Goodfellow) #82

OK - Thanks


(Adam Goodfellow) #83

You should see a status message indicating an update to v2.0.1+228 is available. Go to tools section in settings, find the entry that says update now, select the version from the dropdown and click save.

After about 15 seconds or (depending on your internet speed), the extension in the settings>extension view should disappear then re-appear running the new version.

If you don’t see update available - have another look in 15 minutes or so as the update check is only once per hour.


(Brett Kerbel) #84

I added a playlist and configuration is available now. I will grab the 2,0,1 update and try to configure tonight. Thanks so much for your work on this!!!


(Brett Kerbel) #85

Ok - Couldn’t wait for tonight - extension is configured and working. Awesome job Adam - this extension makes Roon even more perfect. I can’t thank you enough for providing this to the community, and I will happily donate.

1 quirk that I think I noticed, but can’t quite figure out the pattern. If I transfer audio from 1 zone to another in roon, I think the volume control reverts back to as if the extension isn’t there. But if I manually select the zone and play I think it recovers. This isn’t an important feature for me, but I wanted to see what happened with zone transfer. In my case both zone’s are in the same room. One zone is ROCK>Ultrarendu>DAC. The other is ROCK>PC Bridge>DAC. Transfer zones seemed to change the activity properly to select the alternate input on the DAC at least the first time, but then seemed to maybe get confused.

Thanks again!!!


(Adam Goodfellow) #86

I am puzzled.

I just tried zone transfers back and forth between my Airplay AVR zone and Main HiFi zone and it seems to go OK with all Harmony activity switching happening and the correct source and volume controls present after the transfer and functioning as expected.

Screen shot of my settings in case that helps:


(Brett Kerbel) #87

Ill play a bit more later today and Let you know if I can reproduce something meaningful.


(Paul Weedon) #88

Adam

So far so good. I to can now use the settings in Roon with v228. I can also associate the extension with the zone in Roon as per the instructions. However in trying to set up the harmony remote, a scan for wifi devices doesn’t bring find a the roku device, its jut says nothing found.

Everything is on the same subnet and as everything up to this point appears to work, I assume the extension has found the harmony hub. I’m not entirely clear as to why the harmony hub should find a wifi device was it is the only thing, apart form phones etc, which connects via wifi. The Roon server is wired.

What am I dong wrong? Log sent via email.


(Adam Goodfellow) #89

I assume you have selected an ID under Use remote control as illustrated in the above screen shot - ie selected Yes - ID 1 etc?

I suggest open settings, expand tools and copy the URL next to LogURLs into your browser and email me the logs zip file that should download - ill PM you my email address. From that I should be able to see what Harmony appears to be doing during its device discovery.


(Paul Weedon) #90

Adam
here are the settings in Roon

I will email the log file.

Paul


(Adam Goodfellow) #91

There is an update to 2.0.2 which stops windows from changing unix shell scripts into garbage and simplifies log level settings.

I suggest update to that version, however that wont directly change that harmony cant find the remote, but it will hopefully let me see the logging detail I need. Due to the build issue I fixed, I am wondering if run.sh complained when you tried to run it and so you ran the extension executable directly which would result in very little logging as the log you sent had nothing of use in them.

As I can see you are running this on OSX, then I also wonder if you have anti virus software and if that may be interfering? I run ESET on my mac (and windows) and it has no ill effect on the extension on either windows or OSX.

That said, I would have expected it to probably also interfere with Harmony discovery as well, but you never know.

The account I use on my mac is an admin account, maybe that makes a difference (will try a non-admin on my mac later).


(Adam Goodfellow) #92

I have just seen a quirk where the wrong control is being told to switch which may be what you are seeing. Investigating…


(Paul Weedon) #93

@Adam_Goodfellow

Yes I am running things from a 2018 MacBook Pro. I only have 1 account setup which has to be an admin account and I don’t have any antivirus software.

I did try running the script using a ssh session onto the nuc where the server resides in a terminal window from the Mac, but it comes back with an error

xxx@yyy:~$ cd roon-extension-deep-harmony-v2/
xxx@yyy:~/roon-extension-deep-harmony-v2$ ./run.sh
-bash: ./run.sh: /bin/sh^M: bad interpreter: No such file or directory

So I just run the executable at the moment.

I will try version 2.0.2 and let you know.


(Adam Goodfellow) #94

This is the exact problem that the 2.0.2 update fixes.
The headache of editing on windows - whenever it gets a chance it like to turn everything back into CRLF which of course Unix based OS hate.


(Paul Weedon) #95

Ok being, bit dense here where can 2.0.2 be found, the git hub page only has build 223 on. The auto update doesn’t run as I can’t run the script.


(Adam Goodfellow) #96

You should be able to find it at:

The 2.0.2 osx zip is at
https://github.com/Khazul/roon-extension-deep-harmony-release/releases/download/v2.0.2%2B237/roon-extension-deep-harmony-v2.0.2.237-macos-x64.zip


(Paul Weedon) #97

@Adam_Goodfellow

Downloaded the latest version, redid the settings in Roon for the extension and for the audio zone I want to control and all seems well in Roon.

Went to my phone to add a harmony device and scan for wifi still refuses to pickup any new devices. I’ll email over the logs.

Paul


(Le Fur Arnaud) #98

Hi @Adam_Goodfellow,

Could you provide an arm7 debian 7 console app version.
I’m trying to install it on my seagate personal cloud NAS which runs Debian 7.5 and i get the following error :

./roon-extension-deep-harmony: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version GLIBCXX_3.4.18' not found (required by ./roon-extension-deep-harmony) ./roon-extension-deep-harmony: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: versionGLIBCXX_3.4.20’ not found (required by ./roon-extension-deep-harmony)
./roon-extension-deep-harmony: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.16’ not found (required by ./roon-extension-deep-harmony)
roon-extension-deep-harmony terminated with exit code 1. Restarting…

Thanks.


(Brett Kerbel) #99

I couldn’t reproduce the issue with the controls disappearing last night. However, I did come across another small anomaly that I don’t think has any real world validity, but i will share just in case. I have 1 Hub, with two Roon zones. One zone for UltraRendu, call it Zone A, and another Zone for PC Bridge, call it Zone B.

Scenario:

  • Zone A is active in Harmony Hub and playing a track .
  • Switch focus to Zone B and start playing a track. Output is still from Zone A is still active in Harmony.Hub. So Roon is streaming the Zone B track to PC Bridge which is sending it to an unselected input on my DAC.
  • Transfer audio from Zone B to Zone A.
  • Zone A is now selected in Roon and is active in harmony, but track is stopped
  • Need to hit Play button to continue playing track - expected behavior was that the track from Zone B would transfer to A and continue playing.

The real world scenario that may be related to this is if you are transfering from a zone in a room without a HUB to a zone with the HUB.


(Adam Goodfellow) #100

What do you get if you type:

strings /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 | grep GLIBCXX

and

ldd --version

I am guessing probably GLIBC 2.13?

This extension is compiled via a toolchain that uses the chrome v8 javascript compiler (running on Rasbian on an R-PI3B+ that serves as a build machine) so I am not sure that it can be built with a significantly earlier GLIBC. I had to update to pretty much latest everything to make use of it.

It might be worth seeing if GLIB2.24 or docker can be installed on that NAS easily and safely with docker perhaps being the ideal depending on how much memory that NAS has.