Roon Extension Manager 1.x (currently at v1.1.2)

Thank you. I tried it on my Windows machine instead of the Mac, and the installation went ahead. Technically I guess it worked, but I’m running ROCK on a NUC, and none of the versions of Roon I run have extensions available to install. I guess it would work if I ran it on the VM. I was wondering how that would make things change on other installations. It didn’t. :frowning: . Thank you for the suggestion.

1 Like

I haven’t needed to use extension manager for a considerable period so need to remove E.M. version 0.11.9 from my core (Win 11, 64 pro) are there any instructions for safe removal?

You can find instructions here.

Thanks for your help, :pray:t4:

1 Like

Having researched more about automated CD ripping, I’m abandoning the idea of using the CD ripping extension. It would only be helpful for releases that aren’t readily available to stream, and those are unlikely to be matched with metadata. It also looks like Roon never adds metadata to files, but saves it in the database - fits with the “we don’t change your file” philosophy. Even things like the Bluesound Vault only add date and time of rip if it can’t find the metadata. I’ve now had hours - probably days - using the amazing, MusicBrainz Picard, software to organise my ripped library from 2 decades ago. If you have lots of collections, and more niche titles in your library, that’s the best way to go for a happily tagged outcome. I appreciate that the extensions exist. You’re all very clever.

1 Like

4 posts were split to a new topic: Issue with Roon API and Roon 2.0

Hi @Jan_Koudijs,
would you please be so kind taking a look here: Roon Extension: Deep Harmony - rich feature set for Logitech Harmony - Tinkering - Roon Labs Community

Same Extension-Manager release same Repository, different entries in category menu ???

Thanks DrCWO

HI @Jan_Koudijs,
Would it be possible to add another Roon-extension in your Roon Extension Manager?
I would like to see the Roon-extension-rotel by @Boris_Schaedler added in your app. (see: Roon Extension: Rotel Volume/Source Control). That would be for me a huge benefit. Then one RPI should become free.
Thank you so much, Frank.

1 Like

I got pretty far without having to need to ask for guidance, I have docker running both Roon and the extension service also. I can install packages but once installed they dont appear in the extension panel for me to edit settings. The log reports installed and started. Any guidance would be super appreciated. thank you in advance for all the hard work that goers into this awesome ecosystem.


Description=docker for roon core

ExecStartPre=-/usr/bin/docker stop roon
ExecStartPre=-/usr/bin/docker rm roon
ExecStart=/usr/bin/docker run \
            --name roon \
            --network ipnet70 \
            --ip \
            --dns \
            -e TZ="America/Los_Angeles" \
            -v /var/lib/roon-data/app:/app \
            -v /var/lib/roon-data/data:/data \
            -v /mnt/Music:/music \
            -v /var/lib/roon-data/backups:/backup \

ExecStop=/usr/bin/docker stop roon



Description=docker for roon extension manager

ExecStartPre=-/usr/bin/docker stop roon-ext
ExecStartPre=-/usr/bin/docker rm roon-ext
ExecStart=/usr/bin/docker run \
            --name roon-ext \
            --hostname roon-ext \
            --network ipnet70 \
            --ip \
            --dns \
            --group-add 976 \
            -e “TZ=America/Los_Angeles” \
            -v /var/lib/roonext-data:/home/node/.rem/ \
            -v /var/run/docker.sock:/var/run/docker.sock \

ExecStop=/usr/bin/docker stop roon-ext


Log of restart and install on my pastebin

And an image of Roon here

thanks for any guidance

I’m wondering if this is caused by a difference in network configuration between the Extension Manager and Roon core and the installed extensions. The containers created by the Extension Manager use network host while your service files specify a network configuration which might differ from host making them not discoverable.

It might be worth a try to see what happens if you also use network host for the Extension Manager and Roon core.

Sounds plausible, thank you, I would have to reconfiguration some core infra to enable 172.17/16 routing. My infra has been built around macvlan based containers to enable isolatation of containers and traffic.
I’m travelling this week for work but I’ll look into how to route 172.17/16 traffic to verify.

Hi Jan, time has been limited to test, Im only back home for 24 hours but I spun up the RHEOS container directly in the 192.168.70.x/24 subnet and everything functioned correctly. I think you’re right on the network identification. Is it viable to add support for macvlan docker setups to the extension manager? I’ve seen another program that supports both host and macvlan setup by passing in some environment variable, when I can find it again I can share the code with you if that would help?

Synolgy DS920+ Docker installed extension manager without problem but got lots of same error in log as:

CONTINUE 1 Changed {"message":"Extension Repository loaded (v1.0.15)","is_error":false}

is this normal?

This is normal behavior. The status message gets repeated to very the connection to the Roon core.

I’m stuck. I have installed the latest dietpi on a virtual machine. I have the extension manager installed and shows it is running. What next? I open the roon app and look at extensions and I see nothing. I double checked that there is no firewall at play. I can ssh to the dietpi instance from any computer in the house. How do I get my rock to see the extension manager?

I have noticed this behaviour too when I updated DietPi with all available updates/upgrades. I reverted to an old backup (vm backup of DietPi) and everything is working again.

@Anthony_Lester and @Dennis_Mutsaers:

Can you check if the docker container effectively running roon-extension-manager is up?
Do you see it after running sudo docker ps?

If that’s not the case can you check the service status via sudo systemctl status roon-extension-manager?

You might find that the service has been stopped due tu to many restarts.
If this is the case, can you check for any reference to apparmor in the service logs?

I’ve encoutered the same issue recently during an update of docker-ce packages (and I’m also running dietpi in a x86_64 VM). It seems that roon-extension-manager, which basically is a docker container that manages other docker containers (the actual extensions) needs, in recent versions of docker-ce, the package apparmor to be installed.

At least for me, manually installing this package via sudo apt install apparmor fixed everything. But please take time to validate that this is also the root cause of your issue buy checking the logs before installing this additional dependency.

1 Like

that was totally it. thanks for the help. I am up and running

1 Like

Same problem (and fix here). Thanks!

1 Like

Hi @Anthony_Lester, @Dennis_Mutsaers, @nihil,

Thanks for the issue report and sharing a workaround.
I can reproduce the issue in a x86_64 VM. It is apparently a Docker issue.
At DietPi they are also aware, you can read about it here.