Roon Extension: Roon Web Controller v1.1.1


(Jan Koudijs) #62

I expect this is related to the transport API change.


(Mike Plugge) #63

Could very well be - I haven’t had time to look at the updated API yet.

I have seen since the update is when playback is started with the library, the now playing screen does not show any info - including the track time.

But a page refresh addresses that…


(Torsten Schiemenz) #64

Hi, many thanks for adding this!!! Works like a sharm!!!


(Michael Kulig) #65

Hi,

I‘m new to this topic and have installed the latest Roon Web Controller. Roon Core is running on my qnap and the endpoint is a ropieee Touch.

Wich IP address do i have to enter to get to the webcontroll?

IP Address of qnap:8080 is getting me to the configuration of the NAS


(Mike Plugge) #66

Where did you install web controller?

If is on the qnap and port 8080 is already taken, then web controller will not start. But I didn’t think you could run node js on a qnap…

If it is on a different system, then it is on the IP of that system. Note that you may have to open firewall ports on the system you installed it to.


(Tony Reimann) #67

A little off topic but it would be nice if the port was user configurable at install time. 8080 is a little too common.


(Mike Plugge) #68

It already is user configurable.

See details here: https://github.com/pluggemi/roon-web-controller/blob/master/README.md#optional-local-configuration-file


(Tony Reimann) #69

Thanks. That will teach me to RTFM won’t it? :grinning:


(Geoff Coupe) #70

Mike, if I look at the instructions to configure the web port, it says:

(Optional) Local configuration file

Simply copy config/local.conf.EXAMPLE to config/local.conf and edit config/local.conf as needed.
config/local.conf is not tracked by git, so it will not be clobbered with updates
config/local.conf.EXAMPLE is tracked by git and will be updated in the future as new options are available

Content of config/local.conf.EXAMPLE

// Copy this file to “local.json” and change the port as desired.
{
“server”: {
“port”: “1234”
}
}

Do you mean the file config/local.json.EXAMPLE ? There is no file called config/local.conf/EXAMPLE that I can see… Also, I don’t see a file called config/local.json - there’s only a file called config/default.json - is this what the file should be called? Thanks.


(Mike Plugge) #71

The README has been updated. local.conf and local.conf.EXAMPLE are not the correct names.

The file you would edit is local.json.

It does not exist by default. This is intentional so that git does not clobber local changes. Simply copy the file called local.json.EXAMPLE to the new file called local.json.

Do not change or rename the file default.json. Changes will be clobbered by the next git pull. Removing it will prevent web controller from starting.


Linux Roon Control GUI Please
(Charles Snider) #72

Little off-topic, but I get an error when doing npm install
npm ERR! git clone git@github.com:github:roonlabs
Permission Denied (public key)
fatal could not read remote directory


(Torsten Schiemenz) #73

Hi Mike, finally I got myself a very fast QNAP T453DX which runs Roon like a sharm. Now I am trying to get the Docker of Roon-Extension-Manager running. Therefore I changed the QNAPs Port from 8080 to 8888. The I pulled the Docker image and it runs. Appears in Roon and I can select my beloved Web-Interface. That also runs fine BUT it is registered at 127.0.0.1 :frowning: When I now try to excess it from another computer I thought it would be [NAS-IP]:8080 but that does NOT work :frowning:
Instead I get a message saying: Cannot GET /redirect.html…

Does anyone have an idea what I might have forgotton??
Kind regards, Torsten


(Torsten Schiemenz) #74

Got the answer - accidentally… Does not work in Chrome :frowning: firefox works…