Roon Extension: Roon Web Controller v1.2.0


(Mike Plugge) #62

Very odd - Chrome is my main browser…

Try refreshing the page with CTRL-R

Failing that, clear you cookies and try again. This page uses a cookie to store state information. At the moment, that cookie expires after 7 days. That will likely change to something much longer in the future.


#63

OK Mike, seems an issue with the cookie. What is the cookie name, for convenience i would prefer not to clear all my cookies.

Edit:
OK, i did it. Cookie name is the node host server name (IP). I clear the cookie and “now playing” is back.


(Wim) #64

Roon Web Controller is broken on my system.
In Settings/Extensions the Roon Extension Manager PAIR button shows up periodically, then disappears again.
If I click on PAIR and then on SETTINGS I cannot select any extensions.

I’ve seen that Node.js has been updated to v8.5.0. Could that be the issue? Or is LTS v6.11.3 used?

Anyone experiencing the same issue?


(Jan Koudijs) #65

Looks like the extension repository hasn’t been loaded. Is there an error reported in the Extensions overview?

Can you provide me the log file of the Extension Manager? It is located here:

%appdata%\RoonExtensions\roon-extension-manager.log

Are there multiple cores running in your system?

The Windows installer installs an LTS version, 6.11.1 to be precise. This should be fine.


(Mike Plugge) #66

@volpone - to clear just the cookies for the Web Controller in Chrome:

  1. go to the Web Controller page with Chrome
  2. open the Developer Tools (see https://developer.chrome.com/devtools to show you how, I hit F12 on Linux, and I think that works on Windows, just not sure on Mac OS)
  3. click the “Application” tab
  4. expand “Cookies”
  5. right-click on the URL for your copy of Web Controller, and click “Clear”

That will clear the cookie just for Web Controller but leave the rest of your cookies alone.

ERM - just noticed that you updated your post and you are good now. Glad that it worked for you! But I will leave these instructions just in case someone else needs them.


(Mike Plugge) #67

@Jan_Koudijs - seems to be a lot of issues if there are multiple Roon Cores on the network…

Any thoughts on what is going on with that?


(Wim) #68

There is only one core, running an an HP MicroServer Gen 6 running Windows 10 Pro 64bit.
RoonExtensions are installed on the same server.
Here is the logfile.


Roon Extension Manager v0.8.1
#69

@Mike_Plugge,
It’s OK and easy to solve it by clearing, but the cookie issue is quite recurrent on my setup.
However, thank you for your work.


(Mike Plugge) #70

Not sure why you are seeing cookie issues…

Though one thing you can do is extend the age of the cookie.

In the file (INSTALL DIR)/public/js/nowplaying.js, lines 481-483 sets the expiration time for the cookie.

The line currently looks like this:
Cookies.set(name, value, { expires: 7 });

The “7” is the number of days that the cookie remains valid. If you change that to 365, you will get a year. The next minor release will likely include that change.


(Christoph Bach) #71

Hi Mike! I have the same problem with no more state changes after a transfer zone by api command.
Are there any news about this bug?
Kind regards, Chris


(Mike Plugge) #72

It is a known bug. The fix should be included in the next stable release of the Roon server. But there is no ETA on the release date.


(Jan Koudijs) #73

Hi @Mike_Plugge, @ben,

I just updated to build 269 and I can confirm that the transfer issue is now fixed!


(Mike Plugge) #74

Great news!

I haven’t had a chance to update yet so I will check it again tonight.

Thanks Jan


(Mike Plugge) #75

Yup - looks good here, too!

Thanks @ben and thanks @Jan_Koudijs for reporting it in the first place.


#76

Last night my Pi based endpoint stopped working so I imaged a card with DietPi, installed X server and Chromium and the extension. It runs fantastically well on the 7” Pi touchscreen (using the side by side view in my case). It’s absolutrly brilliant. Thanks @Mike_Plugge


(simon arnold) #77

Just using this in Chromium on dietpi for a now playting screen and control, The cover view does not seen to work properly on the pi as the background art is not defcocused like it is when using web browser on a full PC. Is there anything I can do to fix this or is it a limitation of Chromium on the Pi?

Installing a different version of Chromium sorted this. thanks @mpd for all your help setting this up.


(Mike Plugge) #78

Looks like I was beat to the punch. Glad it is sorted. But I am curious, which version of Chromium was causing problems?

The defocused look is created using the CSS filter feature - specifically the opacity and blur features. That feature is fully supported in Chromium/Chrome version 53 and newer.

https://caniuse.com/#feat=css-filters


#79

DietPi installs v52.0.2743.116 if you install from their menus.


(Mike Plugge) #80

Oy! That is over a year and a half old! CSS Grid is out of the question, too, then. Definitely explains the problem though…

I guess I am spoiled with my Arch Linux ARM distro. It always has the latest packages, but it is a bit more involved to get up and running and to maintain it…
https://archlinuxarm.org/platforms/armv7/broadcom/raspberry-pi-2


#81

Hi,
I had the same problem as described by @simon_arnold, but can’t update my webbrowser due to dependency problems (using osmc).

So I added a line to the site.css file of your extension in the #coverBackground section using -webkit- prefix:

-webkit-filter: opacity(.2) blur(1px);

Played a bit around with the values to fit my needs. It has not the same effect as your code line but is working for me so far.