Roon Extension: Roon Web Controller v1.2.0


(David Orgel) #42

Not necessarily the solution, but I think you want the IP address of the device on which the extensions are installed — that could be different from your core. For example, in my setup I have the Core running on a Mac mini, but the extensions are installed on an iMac (1) that’s ergonomically easier to mess around with and (2) doesn’t violate my principle of keeping as much extraneous software as possible off the Core machine.


(John B) #43

Thanks but the extensions are installed on my core machine which is the IP address I’m using.

.sjb


(Jan Koudijs) #44

Looks like you have to open port 8080 in the Windows firewall to access the web controller from another device.

I used these settings:
Protocol: TCP
Port: 8080
Profile: Private

Instructions:


(John B) #45

Excellent, that works, many thanks.

Now the old iPad will come in useful again.

.sjb


(Geoff Coupe) #46

Just realised that I can use this plug-in to give me a Roon Remote on my Windows Phone - it’s brilliant! @Mike_Plugge - where can I donate?


(Mike Plugge) #47

While I appreciate the offer, for a variety of legal/employment agreement reasons, I cannot accept payment for any code that I write on my own time.

I am glad you find it useful though!


(Mike Plugge) #48

I just wish I had more free time to actually be able to look into the two open bugs…

  • Firefox CSS issue
  • disappearing zones after zone transfer

Hopefully time will free up in September once I finish a major thing at work…


(Mike Plugge) #49

Thanks @Jan_Koudijs - I haven’t used windows in years so I would not have known where to start…


(Jan Koudijs) #50

Have Windows running in a VM for a couple of weeks now. Appeared to be a necessity for extension installer developments.


(Fernando Fuentes) #51

@Mike_Plugge just wondering if you saw my bug report a few post above?
Still hunting me :frowning:

TIA!


(Mike Plugge) #52

I did see it. The only way I was able to reproduce it was by simulating a very flaky network. And even then, the network performance was so bad that music playback was affected.

My only suggestion for you would be to make sure the network between your extension and your Roon core is rock solid. WiFi can be flaky if - like me - you have quite a few other WiFi access points in range.


(Fernando Fuentes) #53

@Mike_Plugge no wifi in my home. Not for my roon endpoints at least.
The web app is running on the same server as the roon core which I have no issues with and is 10GigE Ethernet.

Ill keep looking to what the issue is. This does not manifest on my home only. At work and my Vacation home too.


(Mike Plugge) #54

I am not sure what to say then. The only way I was able to duplicate this was with bad network connectivity. Have you tried a clean install of the web controller or updating all of your node modules? (grasping at straws here…)


(Fernando Fuentes) #55

That’s what I am shooting for right now :slight_smile:

Great minds think a like :stuck_out_tongue:


(Ben) #56

Roon build 262 should have a fix for the disappearing zones after zone transfer problem here. We were sending a single message with same zones being both added and removed, which caused a bug in several extensions.


(Mike Plugge) #57

Thanks for your help on this one @ben! You did a lot of the work to find that weird message, so I am definitely grateful.

@Jan_Koudijs FYI - looks like the 262 release of Roon will address the zone transfer issue you identified.


(Jan Koudijs) #58

I updated to build 262 and it gives some improvement but it is not solved.

After the transfer it is reported that there is nothing playing. If I then select the zone name the zone remains listed (it disappeared previously). By selecting the zone to which playback transferred also that zone reports that there is nothing playing. Also after transferring playback back to the initial zone this state remains, no control possible for the two zones that were part of the transfer.


(Mike Plugge) #59

Interesting - I am seeing the same thing. Refreshing the browser appears to restore control, but it is still acting sluggish and unresponsive. Restarting the Roon core did not improve things.

But now I am seeing a different bug.

@ben - I am seeing the correction in the message for the transfer (no more adds/deletes for the same zone).

But did the frequency of “zones_changed” messages change?

Previously, on a zone that was playing, a “zones_changed” message would come in every second (because of the change in track location) for normal playback, and immediately when there was a zone state change (for example switching from playing to paused, track change, etc.)

With the 262 build, I am not seeing that anymore. The “zones_changed” messages appear to be coming in roughly every 5 seconds, and they are not coming in on zone state changes (play/pause, track changes). The way the Web Controller app is written, it relies on those “zones_changed” messages to update the UI - including changing the status of the control buttons, the text for the track position, and the other text around the page. Everything seems to work, but with the messages coming in every 5 seconds or so, the application is not seeing those immediate changes and is not at all responsive.

Any thoughts?

EDIT: The previously mentioned behavior only happens following a transfer zone. If I restart the both the Roon Server and the Web Controller Node application, but do not transfer a zone, the messages come in normally and the app works correctly.

But after a transfer zone, the messages only trickle in as described above until the next Roon Server restart.


(Mike Plugge) #60

FYI - Steps to reproduce have been provided, the issue has been duplicated, and an internal Roonlabs bug has been created.

ETA is not known at this time, but I have the fullest confidence that it will be addressed.


#61

Hi all,
Im using web controller 1.2 since some weeks and i like it very much. Congrats !
Unfortunately since few days i’ve got a black screen on the “now playing” page (see screenshot) with Google Chrome (last version 61.0.3163.79)

Firefox, Safari, and Fluid (app) are OK
ROON server version 1.3 build 262.

Any idea ?
Thank’s.