Roon Extension: Settings Issues

I was testing my settings, which I now got to work, but when I deleted the selected zone for various reasons, I couldn’t change the setting again, as seen at @Jan_Koudijs I think you’re the most likely to have a solution for this. I have tried restarting Roon and looking through AppData/Local/Roon for any extension caches however I haven’t found anything.

The settings of which extension did you open here? Can you provide a screenshot of the Settings→Extensions dialog?

I tried to reproduce this with the Alarm Clock extension, but with a previously selected zone that no longer exists I was still able to make the switch to another zone. This is the code for the extension, I have built it and ATM you need to run from your JavaScript IDE since I haven’t configured an installer for a service.

Note, I fixed it now, I had misconfigured how settings are rendered and when you changed it it was recursively changing it back.

Ah, this is about your own developed extension. I was confused by the mentioning of the Extension Manager in the title (I edited the title, hope you don’t mind).

Glad you were able to fix it.

Sorry I had a feeling it could be to do with the manager since I was using it’s GUI for the settings.