Roon Extensions all missing on DietPi

Hi - all my extensions on DietPi are no longer appearing in Roon Settings/Extensions (e.g. Deep Harmony, Web Controller, etc.) … all I see is this:

Under Authorizations I do see them all listed:


Sorry if I’m missing something stupid here to do. I did do a shutdown of DietPi and restarted, but that did not change anything. Thanks in advance for any help!

From another post I ran the following commands on RPi and it looks like my RPi is out of space:

The thing is, I have no idea how/why I am out of space as I’m just using it for Roon extensions. Not sure what to do to reclaim space back on it:

sounds like you need a bigger SD card or your Pi not enough memory

You might consider validating your disk usage, something like ‘df -H’. Then, figure out what is filling up your disk (are you using ram for logging, or writing that to disk?), using something like ‘du -sh’ in the directory of interest.

Good luck.

1 Like

maybe filling up with logs

Do you have logging enabled for one of the extensions?

You can get a listing of the log files with:

ls -l .RoonExtensions/lib/log

If they take up lots of space, you can remove them with:

rm .RoonExtensions/lib/log/*.log

You can then also disable logging via the Global Settings of the Extension Manager, which should be fine if the extensions used to be running without issues.


Hey guys - sorry…life got in the way. I have a 32gb card in it and only have extensions installed, so maybe it is logs.

@Nathan_Wilkes I tried command ‘df -H’ and get this returned which shows 100% usage:


I don’t know how to use ‘du -sh’ or how to change directories (sorry - this is an extreme weakness for me in dealing with Pis).

@Jan_Koudijs I tried your suggested commands but not sure it’s telling me anything or if I’m doing it right:


I then did the remove command, and now it shows:


But then I do this and it doesn’t seem to make a difference on getting any space back:


Sorry for being so clueless here …

The command to do this is “cd” then the path. Start here:

cd /

And then look for what is taking up all the space.

A basic Linux tutorial might be useful to you?

The log file occupied almost half of your sd-card.

Does this change after a reboot?

Thanks guys - a reboot didn’t change the space available. I’ll keep hammering at it. The difficulty for me is not having a display I think … trying to use the terminal for this is what is challenging. I’ll keep at it and hopefully figure it out.

Hi… well I never did resolve my space issue so it’s still sitting on the table unused as a decoration (lol) … BUT I did get a Synology NAS recently (which I love) and recently learned about Docker. So I just installed the Roon Extension Manager as my first Docker on Synology and am hoping I did it right. It seems to be working okay with what I did, and even survives a reboot of the Synology. Here is how I have it setup in Synology so that I can use both Roon Extension Manager and Deep Harmony extensions (which I’ve been living without both for months and really missed it):

  1. Created 2 separate containers (theappgineer and khazul):

  1. Container details:




  1. I installed Deep Harmony separately because I didn’t see it in roon extension manager.
  2. For both extensions I did not set a Volume at all (which is really confusing to me). Is a Volume mount needed for either extension? I don’t know where all the files reside for both containers on my Synology (so I can’t do a backup, etc. if that’s important). Just curious if it’s really needed or if I can just leave it the way it is.

Thanks for any help/insight!