Roon fails again

I haven’t seen a problem with Tidal, but I haven’t looked at how my Roon is updating, if I have the latest version or if I would have seen the problem versions. I have been using Tidal extensively for the past month or two. I love it. I was going to move to Qobuz, but even MQA music from Tidal is running nicely.

I have everything on Mac Mini’s. One Mac Mini with wired connection near my cable modem and NAS for Core, and one Mac Mini running wireless for the Bridge/Player. If I could eliminate the wireless connection, I would, but it’s running really well right now. I’m really wanting to try DSP for room correction. That’s just unbelievable what’s possible for so little scratch using Roon.


Yes, agreed. But I have a 10GBe fibre network at home, heavily tuned, and Roon search is still broken. You could have the best network in the world and, with this particular problem, it wouldn’t matter a jot.

Yeah I guess.

By contrast though I do not have a 10GBe fibre network. I have a wifi mesh for most of my devices (Roon core and file server aside) and a 20mbps internet connection. I really don’t see any performance issues with Roon.

1 Like

It’s weird isn’t it. That’s the most confusing thing about this issue: not everyone experiences it. Do you use Tidal?

My manifestation is exactly the same as the OP. Search works okay for the first few times, then gets slower and slower until it’s taking up to a minute to return results. It’s worse if you search for many things in a short space of time.

Leave it for a while and it speeds up again.

I get a good deal of static from the family about it.

Hi Jamie
I have the same experience as you do. It really hasn’t anything to do with your own network infrastructure.
Stop searching for a while ( along while that is, does help.
I reboot my server and all is fine again.
I am guessing (I am not a technician) that there is a limited ‘memory’ space reserved for searches in Roon Server, and that searches apparently are ‘cached’ in that memory space. I am confident that Roon caches searches, as if you close Roon on a search page, Roon will re-open at that specific page again.
As soon as that space is filling up, Roon Server needs to reclaim free space, but it is doing this in a non-optimal way, (not clean the whole search ‘memory’ space at once.
Restarting Roon Server obviously will make all search memory available again.

Again, this is all guessing, but it would be great if Roon support could shine some light on this.


Although not exactly your point, I’ve always suspected that Roon has memory leaks (which, in general, are pretty hard to find).

This may be just another place on the list.

Your lucky then as its affected a lot of people. If you have a local library and no Tidal or Qobuz then you’ll not witness it. It’s the cloud backend for the streaming stuff that’s the issue. I have a solid network and when Roon decides to go it goes and when it does I am not the only one at that point as others post about at at the same time.

Anyway Ryan has had issues with his Nucleus as well so it might the route of his issue.

I have a local library and TIDAL. Sometimes search takes a bit longer than others but not so much that it is an issue.

Anything over 5secs is too long. At its worst it was about a min, this has been reduced with some updates Roon side but still crops up from time to time and can be anywhere between 10 and 30secs. It’s still a wip as it’s not consistent and all other apps are way faster at returning. They know they have a problem and have been working on it. It’s been a lot better the last week or so.

Brian gave us a report on the ongoing efforts to improve the performance of search…

Yes but if every other streaming service I have always works just fine then it’s Roon that has the problem. I mean don’t say it does airplay if it doesn’t. I also have it hard wired to a DCS Rossini DAC and that works fine but I do also experience the slow search and sudden decline in computing speed it seems. I can airplay right to the Rossini DAC and it has never dropped ever once not a single time. I like the sound of Roon via ethernet to the DAC, it’s way better but I do have a lot of other endpoints and at this point I have completely given up trying to use Roon as a player to anything other than the ethernet feed to my Rossini. I have to go to either Tidal or Spotify for times when I want to play to my other systems. We can be on the patio and get perfect wifi and stream to the patio system no problem from any guests phone or whatever but I can’t give them my laptop and show them what a cool thing is Roon because it fails every time I’ve tried. It mostly works but will a lot of times slow way down intermittently if we are on the main rig to the Rossini DAC via ethernet. So to say I have network issues seems totally wrong since it works with all other programs and streams great via Tidal or whatever, apple music you name it. Since installing the Amplifi mesh network my wireless has been amazing I can be a couple hundred feet from he house and still get a signal.

Well, sorry I’m so late to the party and tooting my horn. But, yeah that sounds like a software bug. Maybe I missed some of your prior problem description. I’d still give Roon a chance to fix it. You might not get far with support if they don’t acknowledge the bug, but I’m optimistic that the software guys will find the bug and fix it. Just make sure you update with the latest release as soon as it’s out.

I dont blame you for being frustrated, but so much of the roon software is top class engineering, and all software has bugs. They’ll fix it.


This is a common problem for all Roon users. And if you say it doesn’t happens to you I suspect you are not being honest. Sure the internet is a not a guaranteed pipe for latency and bandwidth. But Roon has built an application that is subject to its instability. They continued this with their server in the sky. This is on Roons lap. It’s easy to point fingers at the networks. But when you search and at times it just does not work you have to restort to restarting Roon on the iPad or figure its a sign to just read your current book.

Btw, I don’t ever show Roon to friends it will let you down.
But given these shortcomings most still agree it’s the best solution by far for audiophiles.

1 Like

I have an older NUC feeding a hard wired Naim Atom, a wifi Pi in the kitchen, a wifi Pi in the office, a chromecast out in the detached garage, an android phone linked to a bluetooth speaker for the garden, a sonos in the bedroom, a wireless PC with optical out to an older naim.
Clients are a windows laptop, an ipad, an android phone.
All work bar occasional search hiccups which are getting better and I’ve had the NUC hang a couple of times but other than that it all works.
Am I going to then expect everyone’s experience to be the same as mine or accuse those who are having problems as not being honest. I think not.


Please show your workings.


When I have friends over to listen to music and hand them Roon they get a look like a kid in a candy store.
The system is stable and distributed through the house and out into a detached workshop via ethernet. It ties together a Bluesound Pulse and Devialet Phantom. Happily, Roon unifies the ‘front end’ of both of these systems so I don’t need to use either BlueOS or Spark anymore. Just one human GUI for all the endpoints.
I somewhat empathize with people who have a less satisfactory experience. Roon demands a lot from its environment to run properly. Glitches that would be unnoticeable in lite applications can be problems with Roon, and to that degree its an issue with how the software functions.

1 Like

I can say that Roon never fails for me. At least with the version I am currently running.

True in the past I had it fail with previous versions. That is why when a new version comes out, I do not immediately upgrade because downgrading is a pain to revert back.

I am still running Roon on 1.5 (build 354) stable (64 bit) and it is rock solid. It does not allow Quboz but I do not subscribe to that service.

I believe that there should be a way to downgrade to a previous version of Roon as so for folks who are having issues with a particular release. Making it difficult to downgrade to previous version is just plain silly and I believe it hurts Roon in the long run because of these constant issues. There are way to many different platforms to depend on only for one version at a time for the masses.

If a stable release has already been developed, ie v1.5, then why not allow for download of a previous build.


1 Like

I’m running my core on a Linux Mint Core i7 silent mini PC from Ebay. Files are on a Qnap NAS via Cat 5e to the core. I have a dac attached to the core via usb to my main system, a wireless Pi for my headphones and a wireless Pi in the bedroom feeding active JBL monitors.

Both Pi have IQAudio dac hats and run DietPi. I also have a Linux Mint laptop running Roon via Wine with Roonbridge to feed in-ear phones, and an Android tablet with a Bluetooth speaker for the garden. RAAT is rock solid on the whole system both wired and wireless.

The only issues I have are occasional slow searches and occasional slow connectivity to Tidal. I complained on here about the first release of 1.6 but I’m happy with the revisions.

Prior to this I ran JRiver for years and Spotify. I would never go back to flaky DLNA. Spotify connect worked well enough though.

All in all, I’m happy with Roon.

I wonder if the people who aren’t reporting search problems here are the ones who are only using local libraries.

If I switch off Tidal on my setup, search returns in under a second, every time. With Tidal on, search slows down (which I can understand to maybe a second or so) but then if you search for many things in a short space of time, it starts to take 10 seconds, then 20, then a minute.

Leave it for a while and go back to it, and it takes about a second or two again.

I’m going over old ground because Roon have taken ownership of this problem and have said they’re working on it, so it’s a known issue and is certainly not a figment of anyone’s imagination, or being caused by their local hardware. People who don’t see it are likely not using Tidal/Qobuz or are searching less frequently.

Most of my searches are for stuff I don’t have, so out to Tidal. Sometimes it’s a bit slow but much better than just after 1.6 release.
Admittedly sometimes the results of searching are rubbish but the mechanism works fine.