Roon for Windows10 (Constantly) Hangs on initial Roon loading

I keep having a problem with the Roon software for Windows10 where I’ll double click to launch it and it will work fine for a few days, then all of a sudden a couple days later it hangs up while launching and will not run. I always force quit the program and double click to restart a few more times with no luck. My only way so far to fix this is to uninstall the Roon software and then reinstall a fresh copy and then Roon starts up… then I have to go back through and redo all my settings or reload my saved Roon settings. A BIG hassle. Anyone else having this problem with the Windows10 version of Roon software? My pc is a two year old Dell loaded out like a gaming system ( 32GB RAM, Intel i7 8700, 3.2GHz CPU). I’m also using a 4 month old (brand new) Nucleus.

Hello @Mark_Wheeler, and thanks for your report! Can you send me a screenshot of Roon in the task manager next time you force close it? Also, have you tried installing the 32-bit version and checking for GPU updates?

Had a similar problem last year

I have had what might be the same problem with a Windows 10 machine, it often occurs when Windows upgrades itself. I believe there is an issue with a particular Intel Graphics driver that upsets Roon. I can invariably fix the issue by going into Control Panel > System and Security > System > Advanced System Settings > Performance Settings > then pick either “Let Windows choose … “ or “ Adjust for best performance” such that you are flipping from whatever it is to the other one. Then OK your way out and reboot and Roon should be fine. You can flip the setting back and Roon stays OK. Fingers crossed this has worked for me since I first had Roon, but the original white screen was heart stopping.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.