Roon ignoring TCMP compilation flag

I have just noticed that roon is ignoring the “compilation” flag in my files. I am setting TCMP to “1” but I can see that it is not being picked up in unidentified albums.

It has gone unnoticed because with identified albums I assume roon is picking up a compilation flag from its metadata suppliers rather than from my files.

Should I be setting a different compilation flag?

PS: I can of course manually set the compilation flag from “Edit Album” from within roon but that’s an extra editing step I would prefer not to do when I have already set the flag in my files.

This is the only way I’m aware of. As you can notice in the edit window there’s only Prefer Roon? or Edit for Compilation in contrary to let’s say Title where’s Prefer Roon or File? or Edit. That means that Roon does not consider file tags for Compilation.