Roon is not finding and importing any of my music files

I am a new Roon user and want to test Roon. I use Roon Server on a Synology NAS and Auralic Aries as a endpoint. I configured successfully a Watched folder, but it doesn’t find any music files. The same with a Organized folder. Any ideas for solving the problem?

Don’t use an organized folder. Roon does not recommend this anymore. Even more so as this is just a trial for you.

@crieke is the expert for all things Linux NAS related. It seems it can be a bit tricky setting up watched folders correctly. Hopefully he can help you out there. I’ve flagged him as this is not posted in the synology section and he might miss it.

I just used a Organized folder because the Watched folder doesn’t work. Probably I will give Roon Server on Windows a try…

Hi - did you force Roon to re-scan the folder, instead of just waiting for the music to be found?

Also - are you sure that the music files are in a format that Roon can handle ? I mention that because I recently accidentally created some 44.1 kHz / 8 bit files, and couldn’t figure out why Roon could not see them. Duh!

HI Josef,
Can you post a screenshot of the added folder or just tell us the path that you added in the storage settings?

smb://logical name of nas/music folder
No error, shows connected. Force rescan needs just a few seconds, without any results.

My Diskstation works flawlessy with different media server and endpoints, so it has nothing to do with my network settings.

And all my music files are flac files… (CD resolution, 16bit44.1kHz)…

The music is on the same Synology?
Then you need to configure your music “watched folder” as a local folder.

Make sure to click on the “Add local folder” button before entering the path.

If you just have one volume in your Synology your path will most likely look like this:

/volume1/music folder

If you have more than one volume in your synology you should check on which volume your music folder is located. You can do this in the shared folder settings of the DSM. In the example it states “Volume 2”. (Be aware that there is no space when you enter the path in Roon). So in this example the path would be “/volume2/music”.

Thank you very much. Local folder does it!

Is it a known bug in Roon, that a NAS network folder can’t be used as a Watched or Organized folder?

No, it’s not a bug. You stated that you were running Roon Server on your NAS, where your music is also held; therefore it’s a local folder…

1 Like

The description in the Roon Knowledge Base doesn’t explain that. I did it exactly as described there. It would be a good idea to place a hint there.

I’m not sure where you were looking, because the installation guide states that local folders should be used. Perhaps you could post a link to the page that you used, so that it can be corrected.

I agree that the initial page in the KB is somewhat ambiguous, because it says:

Normally, if your music files are on the NAS’s drive, you would access them with smb://host/share or \host\share syntax. However, since the files are local on the NAS, which is where your Roon Server is running too, you can use the local paths for better performance. See the install guide below on how to pick the right local path.

I think the second sentence should be reworded to state “you should use the local paths…”.

However, in Chris’ installation guide, he quite clearly states:

Roon Server is running on your NAS now, and your music files are probably living on your NAS too. Instead of using a network protocol like SMB or AFP, the best solution is to have Roon Server directly speak to the files already living on your NAS. This has the benefit of being faster and automatically picking up changes changes to your library.

Can somebody help me with QNAP NAS?
I have 2 discs in the NAS and I was able to add one music folder in the Roon which is installed on another PC in local network. The problem is I can’t add the second music folder which is on second drive volume 2
My working path is: \\\Multimedia - this is on my DataVol1 - disc 1
not working path is: \\\media - this is on my DataVol2 - disc 2
I managed to use both directories in Minimserver installed in NAS.
Any clues are appreciated
Best regards

Sometimes, one mistyped letter can cause smb shares to not work. Are you sure your path is completely correct?
I have seen quite often an issue with upper-/lowercase spelling. Is the “media” share on your 2nd drive written fully lowercase and the working “Multimedia” share with an uppercase “M”?

Thanks for prompt reply . Yes, both are correct “media” is on 2nd drive and “Multimedia” is on the 1st drive.
In MinimServer the contentDir is: /share/media and /share/Multimedia and they both work great .
And I am able play the content from minimserver on Lumin and Aries.

Have you checked the user privileges/permissions in the QTS control panel? is smb enabled for that share and is the user allowed to enter that share?
minimserver probably does not require it as it is accessing the share locally.

Can you access the “media” share by entering


in windows explorer (and login with the same credentials, that are used in Roon)?

You are right I can access to \\\Multimedia and can’t to \\\media in chrome
I am looking for how to change the user privileges/permissions in the QTS control panel.
There is so many options .
Thank you @crieke I managed to fix it. I don’t know what was exactly wrong. I have done some changes : I switched off home folder (DataVol1) and I switched on aggregation folders.
I don’t know what helped :slight_smile: