Roon is not watching for new files in real time

Make your NAS reporting a maximum supported SMB version < 3.0.

I can set my XigmaNAS to protocol SMB2. Do you believe that may resolve this issue?

Real-time watching for file changes is a feature of SMB ≥ v3.0 (on Windows). See also:

For short: It will disable the (non-working) real-time watching.

So, you meant run SMB greater than 3, not less than (as in your OP)?

I have it set so that the minimum protocol is SMB3 - this does not resolve the issue.

I’ve never set an NFS share up, but it looks challenging to me. Is this the only option? SMB / Linux / Real-time watching is broken?

Unfortunately this is “normal” behavior: Linux does not always report changes. This has been commented upon by Roon in a number of threads. I think I’ve had my library update once on its own. When you make changes to your library, just Force Re-Scan in Roon under the Storage settings.

XigmaNAS already has an NFS server; you’ll need to enable this through the webGUI. I assume this will create the share and configure the export.

On your Ubuntu machine you’ll need the NFS client. Something like this …

sudo apt update && sudo apt install nfs-common

You’ll then need to create a mount point and mount on the client.

sudo mkdir /nfs/music
sudo mount nas_ip:/nas_folder_path /nfs/music

You can check that the folder is mounted using df -h. Once it’s working add the mount point to your fstab, e.g.:

192.168.1.10:/mnt/music /nfs/music nfs auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0

1 Like

No, I meant what I wrote. If real-time watching isn’t working, then don’t allow SMB v3 on your file server.

Hi @ar9,

Has there been any change since setting the SMB to SMBv2 on your server? Linux-based Roon Servers are a bit more unreliable when reported file changes, please see the following link threads for further information:

Hi Noris.

I just finished implementing what @Martin_Webster suggested, using nfs. Took me a while to get it all sorted, but my folder is mounted.

Any way, unfortunately, my Ubuntu box still is not scanning files in real-time. Such a shame because this took me about 2 hours to learn and setup properly.

It’s a big hindrance for me, since I prefer to quickly edit my album’s details, as opposed to manually rescanning by accessing the menu.

Had I known this feature was not working, I absolutely would not have migrated my box to Linux.

It’s works great on my sonicTransporter i5 which is Linux based. Any changes I make to the music files on the Roon Core using my iMac are immediately picked up by the Roon Core b

Are your music files on the same Linux box that your Core is running on? Keep in mind I’m running Core on an Ubuntu machine and my media files are on a separate NAS.

Yes, my music files are on the same box as my Roon Core. Why do you have them on a NAS?

My NAS is a dedicated file-server running XigmaNAS (built on FreeBSD). It’s over 100TB and serves many clients so no real room to run Roon and Plex.

So why not add a drive to your Roon Core for your music files. Then backup the music files to the NAS. This will reduce network traffic, improve access speed to the music files for the Roon Core, and solve your update problem…

Because my mini-ITX Ubuntu box running Roon and Plex can hold 1 hard drive and I would need about 6 to hold my music.

Hi @ar9,

As I noted in my linked thread above, this has been a limitation that we are well aware of and have done what is possible to mitigate it as mentioned by our CTO and Product Manager in the following threads:

I wish I had better news for you here but at the end of the day Roon relies on the NAS share to report file changes reliably and if the NAS is not performing this function as expected, Roon won’t be able to automatically see the new content.

Thanks for the summary, @noris. I’ll have to figure out how to manage this moving forward.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.