Roon keeps freezing and crashing on Windows (mostly when resuming from minimized) [Partially Solved]

Roon Core Machine

Nuc7, Windows 10, i5-7260U, 16 GB

Networking Gear & Setup Details

Hardwired to Unifi switch

Connected Audio Devices

Osx, Android, Chromecast audios, ropiee all over wifi

Number of Tracks in Library

Around 5000

Description of Issue

Since the update to build 952 my core is becoming unresponsive intermittently, up to a few times an hour

Hey @Jeremy_Rubman,

Thank you for getting in touch with your report, we’re sorry to hear that you’re having issues. Can you please provide a few details to let us know specifically what’s happening, please? This might be consistent with an issue we’re tracking. Thanks!

Sure. I am running my core on a dedicated Windows 10 NUC. Its hardwired in to my network. Previously it was rock solid - ran forever with almost no attendance to it.

Now, after any period of time longer than say 30 minutes, the core crashes - in Windows it is completely unresponsive and is using 30%+ of the CPU, hitting disk hard, and using 10GB+ of memory. I have to force quit it, restart Roon, and then it will work for another 30-60 minutes and repeat.

1 Like

@jamie Does support have any update or advice here? For over two weeks now I cant use Roon for more than 30 minutes and aside from asking for more details there has been no communication at all

Hey @Jeremy_Rubman, the fix is clearing QA testing and is slated for the next release. We don’t have a firm release date yet as several fixes are bundled in and working their way through testing - but it should be ready very soon.

1 Like

Excellent @jamie and @support
I appreciate the updates and support!!

1 Like

Thanks @Scott_Grant - we’re sorry for the inconvenience and trouble you’ve all endured and appreciate your courtesy during the wait. We hope to have everything righted soon. :pray:t2:


Roon Core Machine

Mac OS Monterey, 2 M

Networking Gear & Setup Details

Netgear on Wifi and Gigabit Ethernet

Connected Audio Devices

4 Bluesound devices and a Naim Atom

Number of Tracks in Library

1200 ripped CWDs, and a variety3 of hires files

Description of Issue

Ever since last update Roon is unstable. For example if I am away from my laptop or desktop for an hour or so and comeback I get no display the in Roon app. If I look at my queue it is blank. Roon is also unresponsive to any click. I have to stop Roon app and restart to set things right and that’s never been an issue before. I’ve made no changes to my network or hardware. Also, the blank screen on Roon that I have reported on Roon running on my Mac Laptop for almost 2 years has now spread to my desktop machine. This really is the worst functioning software revision I’ve seen. My Roon software and Nucleus plus are all on Roon 1.8 and build 952.

I literally slept on making this comment, but my conscience implores me. While I fully understand the desire to have a fair and polite forum environment, and the need for all involved to be respectful, I have to say this is one of the most distasteful, unprofessional posts I’ve ever read in a company support forum. This should have been done directly and not out here in “public”. As a yearly paying customer and a rabid advocate for Roon, this way of communicating seriously gives me a bad taste in my mouth, especially considering Roon is indeed 100% unusable for a significant number of us. A company should put itself in the customer’s shoes and be an advocate, not an admonisher (and especially not in such a manner as was done here). Maybe people’s angst comes from A) the right-on-cue apologists who insist it must be user error or due to someone’s specific machine, or B) the fact that this has been going on for so long in so many threads, and only recently seems to be fully realized, acknowledged, or otherwise taken seriously. That very well may not be the truth behind the scenes, but it could certainly seem that way from taking into account the timeline of the various threads and the responses within. For those affected, this is not simply some annoying glitch. It is literally crashing our computers each and every time we try to use the product.


Hi Roon Staff,

at my windows computer I have the same problems since last update I think.

  1. It occurs while the app is in use, maximized status
  2. Last active window is Queue (German: Warteschlange)
  3. Windows Task-Manager shows correct working, Roon at about 3% (Intel i5-4590 3.3 GHz)

There are no crashes, but the app is frozen. No possibility to pause or to change volume. Music is playing, but in the queue the playing sign stays at an already played song. After five to ten minutes it refreshes, but often freeze again. This happens mor often a day.

Hope these informations help



Hello Roon Staff,

Seems I might have a related or same problem here.

Issue: My Roon Core machine would not start Core anymore, and all clients therefore failed to connect.

After a reboot of the Windows machine and uninstall and reinstall of Roon while keeping settings and database (which did not resolve the problem), I have resorted to a clean reinstall of Roon (removing all settings and db), and Roon Core, but even that does not result in a working Roon Core.

During installation it seems Roon Core has a dependency that is not fullfilled by my Windows 10 machine (with latest updates, but also a very basic graphics card - it is mainly used for server purposes). During install I get the option to “install this machine as a roon core”, get through the login page, get to the “add your music” page (nothing added, want to do that later), but after that the install hangs (window not responding, looping). It seems to retry several times an installation part, but fails in the end.

After a minute or so I get to the page “add music service” (nothing added, want to do that later).

I then enable my Cambridge Edge NQ, and press Finish.

After that installation the Roon Client starts on the Core intended machine but is excruciatingly unresponsive (probably due to said graphics card). However when this core machine client is running, the other (intended) clients are able to connect. When I close the core machine client, the other clients (iPad/iPhone/laptop) report the core is not available (“waiting for roon core, uh oh something is not right”).

when I check the Apps list on the intended core machine, raatserver is not installed. Roon client is though.

Hope this helps.

Best, Floris (NL)

Thanks, Brandon for the support and honesty.
You comments are spot on but, imho, are wasting your breath.


While i was censured, my server RAM approached 9G of usage just for roon only. This was while nothing was playing. No, there is nothing but windows services (and all essential have been turned off) on the same server.
It typically ranges between 2.5G to 4G.when connected and playing.
IF this doesnt point to a memory issue, i dont know what does.

Have you updated to the latest build of 970 which has just been released today?
If not please do so and reassess the situation.
Thank you for your patience and understanding

I updated to 970 today
Will report back here my results

1 Like

Well, I’m cautiously optimistic. After updating and restarting all devices involved, RAM is now hovering around 1,800MB, give or take 100MB either way. So far this has held up for around 30 minutes of focused shuffle play (my regular use scenario) and appears to be relatively stable. BTW Does 1.8GB of RAM seem right for a library with 50k tracks?

Of course now, in testing and after working for a bit, it refuses to play any streaming tracks and just sits on them. Restarted Roon on my Core and now it works again (sigh). So I can’t help but worry something is awry there. :-/ Roon Core is connected to a low-latency gigabit connection via ethernet and runs on a dedicated NUC.

But memory problem is at least vastly improved.

Update 1: Glad to report that after an hour or so it’s still around 1800MB and both Core and remote are responsive with both local and streaming tracks.

Update 2: RAM use seems to be slowly creeping up. Got to around 2300MB and then my Windows 11 remote said “no audio device” until Roon was restarted on Core. I will keep watching.

1 Like

Hello All,

Thank you for your feedback and patience so far, it is greatly appreciated! Today, we released build 970 which addressed a couple of issues related to memory growth in Roon.

As noted by several users earlier in the thread, the application hangs/crashes may have been partly due to the memory leaks, so it would be very helpful to know if the update has helped with the symptoms on your end.

Do note that the update may not resolve all possible causes of the hang, but please, do let us know if you’ve noticed any improvements in the behavior. You can find the full release notes below.

Thanks everyone!


Same issue here as the title says on windows 10 the programme crashes or hangs as the programme is not responding when resuming from minimized or sometime it does this when changing album .
My PC is up-to-date on all software and Roon worked great about 2 updates ago i guess Roon is supporting windows 11 now but not everyone can afford to change over to windows 11 as you basically need a new PC to run windows 11 which is silly in this day and age as the cost of living thing is hitting us all .
No disrespect to ROON here its properly unrelated

So far, no difference for me. All optimism has been eliminated as server task manager readout is observed
Server memory usage is still really high (higher than normal but lower than peak) > ~4G of memory from only Roon with nothing playing.
Still freezing. Dont know what the update intended to correct but did not fix my issue

Is all updated

and restartet from Router, audiodevices, Computer, Remote Device…?