Roon keeps losing connection to Synology NAS

I have been have multiple issues with Roon connecting and maintaining connection to my synology NAS via SMB2.

I had set this an organised network folder e.g. smb:// It will scan the music sometimes all sometimes part way and then drop the connection. Roon core is running on a MAC Mini. Also Roon seems to have wiped random tracks from albums from the NAS drive during this process. I have additional copies of my music so that I can sync them all back. I won’t be trusting roon with organising my data until these issues are resolved (on my side or the app side)

For now I will change to using a Watched network folder on the same smb connection rather than trust roon with organising on a remote system.

Is there perhaps a library size issue or stability of connection with roon app? I have 200000 tracks in total which scanned but didn’t import up to that number 120000. Interestingly it scanned over 200k initially but is now scanning a lower number, suggest maybe 80K of tracks are missing?

I know my SMB is stable to the NAS because I have been running Jriver20 to the same share for a while. I tried to confirm no AFP was sneaking into the mix as per another earlier support item

I have a similar setup but only 29,000 tracks, a pittance in comparison.

Synology NAS 1812+ with 3GB memory connected via ethernet to an Apple Extreme Router. Mac Mini upstairs connected via ethernet to an Apple Extreme Router ( it works fine wireless as well).

All my music is also in one folder, smb://

Setup as a network folder with username and password for login. I however do not use organized folders as my music collection is already in an artist/album/track format.

So while I can offer little assistance, perhaps it provides a data point to the Roon folks.

  1. You have many many more tracks than I.

  2. You use the organized folders function, I do not.

Thanks for the Feedback bplexico.

I am switching to a watched folder to see how that fares. I will use the same NAS volume share. I should have tried that option first as my files are also in the folder structure of \artist\album. I am now running a sync with a spare copy to see how many files need to be restored.

My Primary NAS is a Synology DS1010+ with 21TB of disk (DX510 expansion)

The weird thing is that Roon Interface found files and when I played them as an album it would skip some files and when I looked at the source they were gone. it would be up 1/2 files on 1 album, which suggests it could not be due to the rip or transcode done earlier as all files in the same folder would have be ripped the same way.

My best guess is the unstable connection (for whatever reason) has impacted the moving/updating of files under the organising activity of Roon app, and at a critical time they may have been deleted/hidden some how

I had the full range of files form mp3 to ALAC 16/44, ALAC 192/24 and DSF files (which I know currently will not work with Roon).

Looking closer at my Synology, AFP was still enabled, this happens when you have the time machine option on in Synology file settings.

I have now turned this feature off

Mac OSX is “sneaky” and always tries to use AFP over SMB.

Currently scanning my library as a watch list (so far successful), but still have files to be restored

Yes I forgot to mention that I have turned off AFP as well to ensure proper support with Roon.

I now have 185000 tracks successfully imported. The application still randomly crashes on the MAC mini but on my way to getting all the tracks listed. I guess it will ignore the dsf tracks until that function is enabled in the app.

Can’t wait for this product to mature, it really is amazing way to explore your music. I have started using the android remote on a 12" Samsung Note Pro. This works quite well.

I have also installed the remote on a windows 10 1080p HP spectre x360 touchscreen, but all the buttons are off, you must press 1/2 cm higher than the actual button/link to be successful. It is running windows 10 maybe that is the issue

Hi @demondes – I’m going to get in touch via PM to get some more information about your crashes.

Sorry for the inconvenience!

I’m also seeing this problem.

Interestingly, I did not see this problem during the beta.
(Although, I believe I was using AFP during the beta. I just used “browse” to the /Volumes/ mount point, which I know was AFP. The GA installer recognizes AFP and says it isn’t supported!)

I’m using a Synology 508+ and a 1512+. They both experience the same disconnects.
The disconnect seems to happen after scanning about 66k tracks.
It will then remount and begin scanning/importing again.

I don’t see any errors on the Synology side.
I do see the disconnect/reconnects in the Roon logs, but no obvious errors.
I can share these logs…



Hi @joe – we just released a build with a new implementation of network storage for OSX. Can you try that out and then report back?

And yes, AFP is no longer supported in Roon.


downloading version 1.0b15 using the built-in updater now.
Will let you know how it goes.

Really, no AFP?! Why no?



Some more information here.

Build 15 seems to have fixed the SMB problems I was having with the Synology NAS. Thanks!
I’m seeing a few other issues, but I see forum posts on them, and I’ve noticed you’ve already released build 16 to address those issues.
I’ll try that and report back here to let you know if build 16 still fixes the SMB issue.

Thanks for the quick fixes!



My original connection is reporting "Error connecting to network share:68

but I created a new share /volume/music and now it seems to be starting my library from scratch

I had exactly the same error in the last hour with build 16. Tried deleting and reconnecting three times over and magically on the third go everything picked up.

Robtodd did you keep the smb connection as I had above or go to the /volumes/music connection?

My /volumes/music connection is working but because it needs to injest 200000 tracks is it only getting part way through before roon crashes. I have to restart and it gets further along, about 1 quarter of the way complete.

Will Roon work with SMB3? I enabled SMB3 on my Synology NAS and disabled AFP and I am having issues.

Should I go back to SMB2 on the Synology NAS???

Mac OS X should be ok with SMB3

@demondes - I just switched to SMB3 from SMB1 on my Synology NAS. AFP disabled. Mac OS 10.10.4. Playback issues I had with some content are resolved. FWIW.

Unless you are using the Time Machine functionality of the Synology [or any other NAS}, then it would be best to switch off Time Machine in the NAS

The problem is that OSX still tries to connect to any devices with Time Machine via AFP…while it will use SMB to connect with any other network devices

This could be causing the interruptions you are seeing

So my suggestion on any NAS used for Roon would be to

  1. Turn off the Time Machine functionality
  2. Turn off AFP Services

Yes AFP and TImemachine were turned off abut 5 days back, so that shouldn’t be the cause.

Mac OSX 10.10.4? I don’t see that as an available update yet? I am still on 10.10.3. Just checked the apple store

Maybe just the library size, Roon is crashing and or SMB connection is lost to NAS. It is taking days to import the whole library but it is getting there slowly

It should import at about 5,000 Albums per hour based on what I’ve seen over many builds…and on a 100Mbps broadband connection [for Metadata and Cover Art collection]

If it’s slower than that, then something is amiss

You’ve probably mentioned this already, but have you set Roon to WATCH the Folder…or are you importing into the Roon “Organized” folder??

Watched Folder is the better option for most users I think