Roon Memory Leak on QNAP / Synology?

There is a new posting/review of Roon + QNAP and large libraries over on Audiophile Style entitled:
Running a Large Roon Library on a QNAP TVS-872XT

I have a similar experience to the reviewer, however, I am Synology-based.

My Synology DS-3617xs:

Intel Xeon D-1527
4 core
10Gb Ethernet

I also have a large local library with lots of HiRez files:

11K+ Albums
165K+ Tracks
~3K+ Tidal albums

When freshly booted, my NAS is snappy and performs well running Roon. Overtime, performance degrades - playback is fine but searching, pulling up info, etc… all things UI-related. I suspect a memory leak. Regular reboots isn’t a good solution as my NAS does other things as well which don’t like to be interrupted. I believe that Roon on a NAS is an infrequent deployment mode for Roon, and perhaps it doesn’t get as much engineering attention as other deployment modes. I love Roon, and am hopeful that one day a fix will appear. Especially given that running Roon on a NAS is really an ideal deployment mode.

I was observing the very same symptoms on a Synology NAS. Clogging Up after a while. Reboot and everything works until you need to reboot again.

I hope Roon eventually solves this not just for QNAP but also for Synology.

On a NUC now but this is only second best (and very slow because it has only 1GB Ethernet while my Synology is on a 10GB Net). Shuffling files to that NUC is a PITA because of that poor network speed.

Any news here?
Also on my system (16 GB Ram, i7 3770T 2.50 GHz) Roon Appliance eats a lot of memory (increases after some days until to 90%).

I don’t think you need a full reboot to reclaim the Roon memory leaks. Just restart the Roon package (on Synology). You could do this every night at 3AM, for instance. Set up a script in the Task Manager to do it, and use something like

/usr/syno/bin/synopkg stop RoonServer
sleep 10
/usr/syno/bin/synopkg start RoonServer
1 Like

I have the same experience on a QNAP TS-677. I’ve got 48GB RAM in it, and Roon will eat all of it if I leave it long enough, but once it gets to about 5 or 6 GB it get so unresponsive that I need to restart the process. Definitely a memory leak somewhere, no question. I run enterprise databases with many millions of rows which don’t use 6GB RAM…

Hopefully 1.8 might fix.

Same here (QNAP 473 with 32GB, Roon on SSD)

Currently I disable/enable Roon 3 times a week at 5:00 with a schedule in QBoost.
Rebooting a NAS (link in opening post) is quite absurd.

So, could this be a “mono thing”?
–> has anyone compared with roon on a windows system or also using rock (there should also running roon in mono)?

On QNAP you can schedule Roon server to restart or stop for an hour every night (or any time you like) by QNAP’s own app called Qboost. This way it has worked smooth for me for ~two months now. I like to schedule few other apps (like Plex server) to shut down nighttime also since this helps the NAS to enter sleep-mode when not used.

Obviously this is not a solution but workaround. Memory leak problems should be fixed completely.

1 Like

That is a nice spot. I didn’t know QBoost had an app scheduler.

The memory leak issue is a pain, and it’s been a problem ever since I’ve had Roon, five years and counting.

I’ve submitted logs but it’s never gone anywhere. The odd thing was last time I was in correspondence with support about it (couple of years ago?) they said they couldn’t reproduce the issue.

This seems really odd as pretty much every QNAP/Synology or even any Linux Core user has experienced it or is experiencing it regularly.

It’s bit to early to say, that Roon 1.8 has solved the memory leak, but it seems that on my QNAP Roon will not eat so much memory than the older versions.

You’re right, it’s far too early to say :slight_smile: