Roon not connecting to Vivaldi upsampler

I am using ROCK connected via network to a dCS Vivaldi upsampler, wordclock and DAC.

So far it worked fine, Roon in audio settings shows the Vivaldi via AirPlay and the upsampler via network.

Now the upsampler does not show up anymore in the Roon app, only the Vivaldi Airplay.

I have not changed anything and the updsampler is on the network and plays well with the dCS Mosaic app.

Is the upsampler no longer supported by Roon?

Go to the Settings → Audio, and in the RoonReady section see if the Upsampler shows and is enabled. If you updated the firmware of the Upsampler, it is possible Roon does not recognize it is the old Upsampler.

If it shows disabled, enable it. If it doesn’t show at all, then I don’t know what to advise other than reboot EVERYTHING.

Thanks, upsampler has not been updared, is and was running before on the same current version, all devices have been restarted, but the vivaldi upsampler as a network device does not show up in roon under settings-audio, only the airplay version.
After starting the upsampler usually first the airplay upsampler version comes up, after another minute the network version is visible and can be chosen. Now only the airplay upsampler connection comes up.

Have you rebooted Roon?

I’d also consider restarting your switch if the Roon restart doesn’t work.

Post on

1 Like

I did everyghing which has been mentioned here and on my post in the dcs forum, rebooting, latest software, changed switches, connected directly to the router … my Linn DS shows always up as airplay and via network, only the upsampler not (only as airplay). Via mosaic the upsampler shows and plays via network, why roon does not show it anymore is strange.

I have another roon core running on my windows desktop on the same network, also here the upsampler is not showing as network device, but the Linn does

You really need to get dCS’s support. I am out of ideas.

I am as well. I’ve gone back through this thread and without actually being there, I can’t think of anything else to try. Especially now that you’ve tried two different Roon core’s.

Good luck!

to get around windows firewalls etc I loaded a new roon core on my MAC, looked for audio devices…still no upsampler via network, only the Linn shoes up. So it is exactly the same result, whether running the roon core on windows 11 Desktop, NUC or MAC. I guess this could show that really the upsampler is the problem?
I posted it also on dcs community, so far also no solution to this, let’s see

Have you tried using a dummy (ie not smart with smart filtering etc) network switch, connecting both your Upsampler and your Roon core to that same switch, and connecting another port of that switch to your home network (Roon needs internet access)?

You should have unfettered access between the core and the Upsampler this way. You should be able to access the Upsampler’s web interface (just type it’s IP address in a browser in the core, you will have to discover that IP address obviously). If the Upsampler doesn’t show in Roon, but Mosaic works just fine, there’s something INCREDIBLY WRONG with your upsampler.

I am assuming you’ve looked into Roon’s Settings → Audio configuration and the Upsampler does not show there at all. If it does, and it is disable, enable it and it will show. If this is the case, then you owe us all a meal as you’ve massively wasted our time. :slight_smile:

Thank you Miguel,
I did it alread using the same switch the Linn is using, no success. Upsampler in roon-Audio configuration showns only up via airplay, not via network. The Linn shows up as airplay and separately over network. Before the issue happened the upsampler and the Linn showed up as possible network players and coud be used as audio device.

Stupid question: Did you try a different ethernet cable?

several different ones, different switches…

The thread is getting long, so I want to summarize where we are;

  1. I had ROON on a NUC (full spec) connected via Netgear GS 308 switches to my LAN and to the Vivaldi Upsampler. For a long time all was working perfectly.
  2. 2 weeks ago the upsampler did not show up any more seettings-audio in the roon app on my iPad. Only the airplay version came up under Other Network devices. I had not changed anything in my Network, no updates, no other switches, no different cables…
  3. As recommended I rebooted everything, the NUC, the upsampler, all switches, the app… upsampler still not showing as a full network device
  4. I upgraded the upsampler network interface to the latest version, 510, no scussess
  5. I installed another core to my windows 11 desktop on the same network …upsampler not showing up
    6 I installed another core to my MAC connected via mesh to the Ethernet network, no success
  6. I connected my Linn Klimax DS to the network via the same switch where the upsampler is connectected to… Linn is there as network device and airplay device, upsampler only via airplay
  7. I connected the upsampler and NUC directly to the router… no success
  8. I connected the upsampler to different switches … no success
    10 I sent the upsampler logfile to dcs… nothing unusual to see
    Now I am really running out of ideas and time. Would be great if someone has a hint why it is not working and what else to try. Probably one have to look into the details of how roon is recognizing roon ready devices and how dcs has adapted this. But I am not a software expert.
1 Like

@Wolfhart_Hauser - any luck? I hope it’s fixed.

I may able to help you as a client has the same dCS components. Before I go any further, have you spoken to dCS and / or your dealer?

Thanks for all the ideas. Menawhile the updlampler is with dcs for repair, probably backup bttery failures
I will update when it is back

1 Like

Hi Wolfhart,

Read through this thread and wanted to toss in my 2c worth. You say that the Vivaldi Upsampler (VU) still appears in Roon as an AirPlay endpoint. This would suggest that it is not a networking (IP-level) problem and much of your networking troubleshooting has been redundant. Since the problem only affects the Roon Ready endpoint it would appear to be a protocol-specific issue to RAAT.

The first question I would ask myself is what changed two weeks ago? You say you hadn’t changed anything, but could something have changed itself without you noticing? For instance I have set my Roon core to update automatically, don’t remember if I have set my Bartók to do the same, need to check when I get home.

My hypothesis, based on the above, is that an automatic Roon Core (or less likely but still possible dCS firmware) update has broken something, and that if a complete reboot of everything as you describe hasn’t fixed it, then a likely explanation is a regression bug in Roon or in the dCS RAAT implementation (I believe the latter is less likely just because the end-point code is much simpler and more stable). If this is the case these are both beyond your control to fix.

I hope this helps (at least a bit)!! As long as your Roon Core can see the VU as an AirPlay endpoint (and you haven’t done anything funky with firewall rules) then the problem is almost certainly not a network level issue.

@AMP would you agree?

Hi Struts, thank you for your comments. I thought from a beginning it is not a network problem, because I had not changed actively anythinhg. But be it roon or dcs they want a lot of checks to be done, I even installed differnetr roon cores on different machines, changed switches…
It is clear now that the upsampler had a (hardware/bakup-battery) problem and is with dcs. I heard the repair has been done, but so far I don’t know what was wrong with it.