Roon Not Showing All Albums in Music Folder

I have CDs that I’ve ripped to my Zenith MK2 that are not showing up in Roon.

Core machine: Innous Zenith MK2, Roon Build 610
Network: Verizon FIOS - Ethernet to MK2
Library details:

  1. FLAC , DSD, & MQA files are stored on the MK2
  2. iTunes files are stored on a Synology NAS
  3. Backups are stored on the Synology NAS

Zenith Music Folders:

  1. cd-quality - FLAC CD Library
  2. high-res - DSD and MQA Files
  3. ripped - FLAC files created using VinylStudio
  4. unsorted - iTunes files

I have two copies of “The Chi-Lites Greatest Hits” stored on the MK2 - one in the unsorted folder; the other in the cd-quality folder. The cd-quality version does not show in Roon.

Did you verify that one is not listed under the alternate Versions of the other? Go to the album view of one you see and check on the Versions Tab ( next to the tracks and credit tab)

Checking Roon versions was the first thing I did.


Unsorted iTunes version that shows up:

CD quality version that does not show up:

If I could get the CD quality version to show, I’d delete the iTunes version. Also note, the album is not available on Tidal.

One problem is solved, but now there are others.

The CD version is showing up as the “[Rhino]” version. When, I click that version, I see two versions.

I think I caused this when I enabled the “Music” folder when troubleshooting last evening, which duplicated my library.

I’ll disable my old \192.168… folder

The album art is incorrect. I’m guessing, I could copy the .jpg from the unsorted folder to the Music Folder location to fix that problem?