Roon on 2018 Mac Mini makes all my devices slow

Hi Mike, of course!

I currently have 21783 tracks. And here’s a screenshot crop of the current usage. Doesn’t seem to be much memory usage if you ask me. Still it makes everything on my Mac (except Roon) run slow. Same goes for my Macbook Pro that I use as a remote!

That doesn’t look odd

Let’s see if @support can help

yes that’d be great!
Ram usage fluctuates btw: now it’s at 1,31GB.
CPU at 45%

Roon is “thirsty”

Hi @Keimpe_Koldijk,

We are aware of a few reports surrounding high CPU usage on MacOS and are currently investigating this issue internally.

As for your specific case, can you please check to see if using RoonServer instead of the “All-in-one” version of Roon exhibits the same behavior? RoonServer is the Roon Core, but it has no interface and you can control it from the Macbook Remote/All-in-one on the Mac Mini.

It can be found on our Downloads Page .

Hi Noris,

Thank you very much.
I tried the suggestion of exhibits but it doesn’t change my problems.
I guess Roon is a bit too heavy to work on my devices :frowning:

got 3 days left in my trial period and I have been unable to make Roon run smoothly. Too bad :’( I think I won’t buy a subscription

Hi @Keimpe_Koldijk,

Is there any change in behavior if you host the Roon Core on this Macbook instead?

Are you using the latest Operating System on both Macs?

Hi Noris,

I use the latest operating system on both machines.
I did use the Macbook Pro from 2014 as a core at first but switched to my newer Mac Mini because I thought the laptop was too old as Roon made the laptop slow…

Am seeing much increased heat and battery zap on my Macbook Pro 2015 acting as a remote.

1 Like

Hi, I tried all mentioned things but still experience an immense decrease in speed on all my devises.

Similar situation:
Built a an 8TH Gen NUC with recommended i7 settings via the NUC KB from ROON. That runs great and is noiseless (except for my music of course) in a Akasa Turing case.

Here is my issue with my actual desktop device and slowdowns, stutters, and no discernible cause in Activity Monitor (OS X):
Took 2018 iMac i3 (32GB Ram) out of service as Roon Core and formatted and reinstalled OS X and my apps to use as a desktop device for typical email and office apps, my 2016 MBPro Fan was a jet engine running my 3 monitors so that had to go. When I open Roon (as a controller from All In One Roon App) on my desktop MM (Mac mini from now one) it causes any usual tasks to slow, stutter, and crawl. From just moving the cursor from app to app let alone opening safari links to typing, to highlighting text to copy and paste. I close the Roon AIO App and all is good in the hood again. Now for time being I will run Roon on my iPad and my iPhone until this is resolved but please keep us updated on a resolution. If I can offer any diagnostics please reach out and I will provide.
Thanks
Joe

4 posts were split to a new topic: 2018 Mac Mini High CPU Usage

Hello All,

Thank you for the additional reports here.

We are currently investigating this high CPU usage behavior internally.

One aspect which we were able to discover was that turning WiFi off/on on the affected PCs temporarily resolves this behavior.

Can you please let me know if you are seeing the same on your end? Does toggling WiFi trigger any change in behavior?

Same here on wired Mac Mini with WiFi disabled. I will try to toggle it on and see if I have same behavior.

1 Like

Toggling wifi has no effect on the CPU usage for me.

I’m using iMac (2019).
This issue was solved by changing WiFi from always off to always on.

I am also using a 2018 Mac mini for my Roon Core and have the 6 core i7 version with 32GB RAM and 256GB stupidly quick SSD. Roon playing a 44.1/16 FLAC file to my microRendu takes approx 60% of the CPU of the core which seems very excessive to me…

I have tried toggling wifi and this has no affect. I am using a wired network connection for the microRendu.

Hello All,

Please see @dylan’s update from here regarding this issue:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.