Roon on Asustor NAS

I know it isn’t as popular as Synology and QNAP, but I’ve been running an Asustor NAS for quite a while with flawless results. When I outgrew the 2-bay model, I explored other brands but ended up right back with Asustor and their AS6404t model. Love the software, and love the value of the device itself compared to the other brands.

The downside is that it doesn’t have a premade package for Roon in the same way Synology/QNAP does. I’ve seen a few threads on the topic and the general consensus was that Roon wouldn’t be supporting Asustor anytime soon… too small of a demand.

That said, I was wondering about the feasibility of running it as a virtual machine. My NAS has a reasonably potent Celeron J3455 CPU, and 8GB RAM, plus a 256GB SSD drive (along with a pair of 8TB traditional drives). Seems like all the ingredients are present for a good basic Roon experience, obviously not trying DSD512 upconversion and 8 zones.

I have never messed with virtual machines but I know the option exists. Has anyone else tried this on an Asustor device? They make a good number of models with i3 and i5 processors, in addition to the Celeron-based models like mine, so I figure someone out there has probably done it.

I haven’t seen a post by anyone who has tried it and succeeded. I have a ReadyNAS of the old variety and was able to begin a partial install (via ssh/cli) but never got it quite completed.

I’ve got a Synology with near identical hardware footprint (J3455, 8GB).

I’m running Roon bare metal via @crieke’s SPK, in Docker and in two VM’s (Roon Server on Debian and ROCK – just for shits and giggles). The first two are fine, but the VM’s suffer.

No Docker for your Asustor?

EDIT: It appears there is:

This should run just fine:

1 Like

Thank you for that, it gives me hope. I’m not very familiar with more complex stuff on the NAS (typically just use their apps like Plex etc) so is there anything else I really need to know?

Alright I’m at a loss as to how I implement your linked Docker project into the DockerUI app on my Asustor NAS. Tried playing around with it, but don’t even know where to start.

Can you walk me through it, pretending I am a total idiot in this arena? Thanks!