Roon OS 1.0 Build 253 Observations


Instructions for the Reinstall directory are here:

You will need to use this file: roonos-production.bin

(above download link edited to be the correct one for RoonOS)

Short version is:

  • Download the file linked above to your computer
  • Mount the Data folder from your RoonOS device on your computer and navigate to the Reinstall folder
  • Copy the downloaded file to the Reinstall folder
  • Hit the reinstall button on the admin page

This string is cached on the Roon side and isn’t refreshed often. Restart your remote and it should be correct.

1 Like

Thanks Andrew … I’ve tried a couple of times. followed the instructions, but it’s stubbornly staying on 253. earlyaccess. Any other ideas?

Screenshot 2022-11-10 at 18.09.29

Yeah it has disappeared now, thanks!


I am having the same issue as @mikeb, with the os-production.bin file in place and hitting Reinstall does not move the RoonOS from 253 to 254. Although the .bin file is removed.

In fact all this has done is move my Core version from earlyaccess 1149 to produciton 1148 :frowning:

Yeah, it would have really, really helped if I had given you the correct file to download. That one was for Roon, not RoonOS. This is what I get for jumping in before that second cup of coffee…

Here’s the correct file:

The one you downloaded moved your Roon install back to production if you want to be on Roon earlyaccess then you need to use this one: roon-earlyaccess.bin


Nope that hasnt worked either. Still on RoonOS 253 earlyaccess.

@Tim_Rhodes … download the file again and copy it over then reinstall. I noted an error which I’ve now corrected.

1 Like

Yeah I used the correct file from your last message, it didn’t work, although the file was deleted after the reinstall.

no, there’s been another correction since the post I made. download it again.


@ivan @simon_pepper

I see details about Intel HDMI audio vs Intel HD audio here…

I think this is a feature of the new Linux kernel. The old one seems to have depended on Intel HD to make the HDMI work. You were able to disable HD audio in the past, which broke HDMI support. They seem to have eliminated that requirement now. I don’t think you can actually disable HDMI audio in the BIOS, just “HD Audio”

We should move this conversation about HDMI and Intel HD audio here:

1 Like

No jumper settings.
This additional audio options seem to be ALSA driver based, rather a hardware based option.
Can the inclusion of ALSA drivers in RoonOS be made optional?

Ah sorry I misunderstood. Yes that one has worked now RoonOS 254, thanks :slight_smile:

That worked better, thanks… RoonOS is now at 254, though OS version is still “earlyaccess” - how can I get that back to “production” for a clean house?

This should happen automatically by a prompt in Roon (if this works for you) as per here:

(Not happening for me yet, though)

Yes, all good after Remote was quit and re-opened.
@AMP all good here now, thanks for your assistance.

On my non nuc core my disabled HDMI don’t show up on this build so it must be a combination of bios on the NuCs as well.

I don’t think that @danny feels the wish to make a product designed to be simple more complicated for just that? I think most users see outputs/potential listening zones they never use when looking into Settings|Audio. It’s seems to be easy for most to just leave them alone and disabled.


I think the volume of “what are these and why are they enabled” is quite low. The support volume from users disabling the extra ports, forgetting they have done so or forgetting how to re-enable them would be much higher.