Roon OS build 183

Tried searching but no luck - just noticed that my roon rock notified me that there was a new build available for the OS - 183. But the latest build I see on the web is 175 . . I updated and everything seems to be working fine. Just wondering if there were any release notes for the new bill or perhaps it’s a glitch…


Not sure if it is Nucleus only

Also for Rock, just installed it on mine. Goto: Settings > About

The Release notes don’t appear to be online yet.

Well - I just took a backup, so I am going to jump into the deep end and see what happens.

Update - No problems, ROCK came back up quickly and my endpoints all connected with no issue.

Yup - same here. I’ve got ROCK installed on a NUC. When I went to “Settings” and clicked on “About” the update (183) started automatically, even quicker than I could read what it was doing. Back online in less than 2? minutes and all is well. It sounds like one of the update’s functions is added support for the Nucleus to hook up with a “super drive”? Is that Roon’s brand of CD ripper for the Nucleus? Edit - I guess the SuperDrive is the Apple’s add-on USB CD drive for their products.

1 Like

It’s Apple’s SuperDrive as you already suspected :slight_smile:

After reading this post I checked and found the update for 183 for my NUC/Rock setup. First time I’ve had an update and was wondering how it worked. Seems like it took less than 1 minute. Now I know.

My update to build 183 appears to have stalled. Is there a way of removing the download on ROCK and redoing it? If I go via my MAC the build 183 is shown. If I browse to my NUC and reinstall via the web browser it installs the old build 175.

It’s probably best that you post this as a new topic in the Support category of the forum - that way it will be seen by, and responded to, by the support team.

1 Like