Roon playing local MP3s instead of high resolution Qobuz streams

My local library has grown organically over decades and is comprised of a combination of FLAC and MP3. Sometimes when I use Roon to play “radio”, I notice it playing local MP3s rather than streaming the equivalent high resolution files from Qobuz. I don’t understand why.

Here’s an example of one such item I see in my history. You can see that this is a local MP3. When I click on the file I am navigated to the album. When I click on “Versions”, I see that there is 1 Library version and 1 Qobuz version, so this isn’t an issue of the local file not being correctly associated with the Qobuz version.

Is there anything I can do about this short of deleting all of the MP3s from my local library?


You could add the Qobuz version into your library. Roon should make the highest quality version the Primary version for playback.

Thank you @xxx and @Geoff_Coupe.

I have hundreds, perhaps thousands, of albums in this state. The albums in my local library all appear to be associated (through automagic mapping) to the equivalent Qobuz albums.

My question is : am I truly required to manually intervene in order to get the preference of local MP3s to stop? I get that I can go album by album and add Qobuz equivalents to my library or perhaps just directly make Qobuz versions primary, but that’s hours and hours of work for something that I would expect to be an automatic behavior.

Any other options?

Thank you again.

You could use Focus and just Bookmark those that aren’t (or are) MP3s. Bookmarks automagically update should you add new material.