Roon, Plex and Sonos

I live in a 3 storey house and the ground floor kitchen is at the furthest distance from the middle floor living room, which is where the router sits. Almost every time I play from Roon to my Sonos speakers in the kitchen, after a few minutes I get the dreaded “Roon lost control of the audio device” message. Using the same speakers from the Sonos app and the various music services it includes there are never any problems. These music services include Plex which works just fine in this way. If it is the case that music services within the Sonos ‘ecosystem’, which presumably use SonosNet, work well then why isn’t Roon included within Sonos as a music service, potentially improving stability and reliability?
In my main ground floor listening room I don’t use Sonos but a separates system and a BlueSound Node. This is 100% reliable with Roon, either using the Roon app or the BlueSound OS app. So my decision is - whether it is a good investment using Roon in this limited way rather than in a multi-room setup as originally envisaged.

Roon requires a good network transmission to function properly throughout your domain.

With WiFi, network speed is greatly affected depending on the signal strength. The weaker the signal, the slower the transmission. Also when the WiFi strength is at or below 50% it to is also greatly affected by other wireless factors interfering.

I had a customer that was on the fringe end of their WiFi and at times could not stream Youtube consistently. In the middle of the 2, I setup a Wi-Fi extender and this greatly increased their WiFi signal strength and in turn also increased network speed. It was either use this method or hard wire a access point in the middle of the 2. I tried the extender first and it worked.

Hope this helps.


Thank you for your reply. An extender is definitely something I’m considering. I’m still not clear, however, why everything works fine for the various music services in the Sonos app (including Plex) but mostly the opposite of fine using Roon.

1 Like

This topic has been brought up quite a few times. In Version 1.6 and earlier this would happened even if you were hard wired. There were lots of threads on this. In Version 1.7 and later for the most part, this issue mostly went away if you were hard wired. However when it comes to WiFi, you are not alone and many still are having this issue while others have no issues at all with WiFi.


The problem is that, particularly with houses on multiple floors, hard wiring is rarely a practical solution.
Also, I don’t understand why Roon can’t operate within the Sonos app like, say, Plex.

I have a Mesh network that works really well out into the garden and used to support 7 zones of Sonos that were mostly paired to stereo.

My brand was Orbi and they can be used to extend Ethernet to Sonos but I stopped doing that after 1.7 due to Roon and Sonos changes breaking thing’s.
I am sure others will work as well, but make sure they have dedicated back haul channel as that makes a big difference

1 Like

If you get an extender make sure you get one with an ethernet port. I found that using the extender as a “big aerial” and then connecting via Ethernet cable gave much better results than Wi Fi itself

I am not sure how that will work with Sonos but certainly ethernet is the way to go

Roon is a bit finicky with network. While other software does not really care to keep things in sync, and I can hear this with Sonos app, Roon will stop playback as soon as one speaker drifts from any other. Also, this seems to be even more sensitive with Sonos endpoints of late (do a community search).

More network (as others have stated) or hard wire is the answer. You might even try just adding a boost wherever you can hard wire it closer to the misbehaving speakers.

1 Like

Thanks. Again, the practicality of hard wiring remote speakers in a fairly large space remains an issue. I do have a Boost connected to may router but that is in the living room where the router is located. The contrast with my Bluesound Node setup in my main listening room is marked. This setup uses wifi only, and the room is only slightly closer to the router, compared to the kitchen. I never have any dropouts here. Interestingly, Roon is incorporated in the BlueSound app unlike Sonos.

BlueOS is Roon Ready where as Roon I believe hacked together a Sonos talking app. Sonos neither support or acknowledge Roon’s existence when I logged tickets several years ago because of broken solutions and Roon for their part takes forever to fix anything broken by Sonos or themselves. An exercise in frustration I found. It is one of the reasons I have away most of my Sonos gear and started focusing on devices that supported multiple streaming protocols including Roon Ready.

Personally I only have a Boost plugged in to Ethernet but in a bigger house I would run a second Boost nearer the third floor in your case. I would probably plug it into a Mesh node.
I think that would likely help your situation, but sadly nothing can be guaranteed with these things

Thanks. That sort of confirms my worst fears about Roon/Sonos reliability.

Peter my Sonos has been super reliable for a few years now, but I rebuilt the network a couple of times for that level of reliability.

Just a Boost plugged in on Ethernet plus Sonos WiFi has stopped it getting caught between all the different issues around Mesh, Sonos routing and Roon issues

Thanks. I do have a Boost connected by ethernet to my router, although this is in my living room. The kitchen Sonos speakers are some way away and connected only by wifi as hard wiring is not practical. All the music services on Sonos are fine with these speakers - presumably via SonosNet - but not Roon where ‘lost control of the audio device’ is the norm.

Have you tried to change the playback settings to 16/44.1 from the default 24/48?

It may just be that the way Roon plays music (uncompressed PCM) overwhelms the Sonos device and I saw a lot of that in the past. It pushes a lot of traffic out.

It might be worth getting a second Boost and seeing if it helps, you can always return it if it doesn’t help.

Thanks again, Michael. I tried changing the playback settings to 16 but no luck. It got to 20 seconds then "Roon lost control of the audio device’. I’ll look at getting a second Boost.

1 Like