Roon Remote 1.8.00763 crashes, 1.8.00764 still as well

After the update to the Roon remote app (1.8.00763) on iOS using an iPhone 11 the app randomly crashes after a search or selection.

Never had this before, the previous version ran perfect.


It’s crashing persistently on mine. Won’t stay open for even a minute. Same phone and same version of the app.


My Roon Remote crashes continuously as well. No 1 track plays to the end.
System: Roon Rock 1.8 build 763
iPhone 11 Pro
iOS 14.4
Roon app vs 1.8.00763 downloaded via App Store


It’s purely the app from the Apple store, as I didn’t have any issues before. I also notified there in a review.

1 Like

Do you have iPad language set to English?
When I have the iPad language set to Polish, failures occur very often. When I change to English, very rarely.
Despite everything, they still exist.

Everything in English. Never even touched the language.

So, I tried a clean install. Not helping on my iPhone. It’s working fine on my iPad, btw.

All in English here.

It plays whatever I tell it to as long as I get the command in quickly before the app crashes again.

Haha, yes. I bet we could time the crash.

1.8.00764 didn’t solve crashes. It’s crashing even faster now on my iPhone 11.


So. Even with just opening the app and doing nothing, it will crash after 17-23 seconds.


It’s a very poor effort.

Why would anyone release something that worked so poorly? Even governments manage better software releases than this. Well, sometimes anyway.

1 Like

After upgrading Rock and the iPhone app to build 764 the iPhone app keeps crashing.

Indeed it also crashes without playing anything or using the Roon app on the phone, just having it open.

System: Roon Rock 1.8 build 764
iPhone 11 Pro
iOS 14.4
Roon app vs 1.8.00764 downloaded via App Store

My ipad pro also crashes and roon doesnt remember where it left off

This is becoming a major issue on a wider scale. Not good at all!

1 Like

This is actually nothing new, as a search of this forum will show. The iOS app has crashed from time to time in prior versions, particularly on the iPhone for some reason. The latest version is so far running fine for me, but in the past when the iOS app began crashing, the only “fix” that has worked has been to reboot the phone. This works for a while, but unfortunately does not seem to be permanent.

1 Like

Iphone X iOS 14.4 german Roon 1.8.00764 crash (ca. 15sec)

In addition to above:
iOS 14.4 Dutch (Nederlands)
Roon app vs 1.8.00764 downloaded via App Store in English

So it’s getting weirder by the minute. I made no changes, did not do a phone reboot. App isn’t crashing anymore.

Switching off the Iphone brought an improvement for the time being. Just how long? Since which version has this error appeared and when does the error come back so that you have to switch it off again?