Roon Remote unable to load PDF booklet after update to build 536

As off yesterday I noticed a severe error in the Roon Remote app on my Samsung Tab S5e tablet.
After starting up the Roon Remote app for the first time after the recent update I saw the exact same warning (as posted here Screen resolution error) about my screen resolution being too small to run Roon. After clicking on “maximized”, all appeared to work without problems.
“Appeared” indeed.
Because now the opening of PDF booklets from the Roon Remote app does not work anymore. Might there be a relation with the resolution warning?

After clicking on the “Open File” link (see the above screenshot of my tablet) nothing happens.

Opening booklets from within the app was for me one of the most important reasons to start using Roon, so I really hope this can be fixed asap!
Just to prove that the problem does not lie within the tablet itself I tried successfully to load a PDF booklet via the ES File Explorer on my S5e. But that’s way too cumbersome for reading booklets on a regular basis!
Oh, and opening the very same booklet that I tried in the above screenshot is indeed possible from within the Roon Remote on my PC, so, I assume the Core is not at fault here.

Please, Roon, get this fixed ASAP!!!

I can reproduce this with a Samsung Tab S2 plus Rock.

1 Like

And I get the same failure to load a pdf on a Huawei M5 Lite tablet which I believe uses a slightly different version of Android than the Samsungs. Like Hans I am able to open pdfs outside roon.

1 Like

Same here, I can reproduce this on my S5e.

Just now tried the same on my older Samsung Galaxy Tab S 8.4 where the previous version of Roon Remote (build 528) is still installed. Here the downloading and showing of PDF booklets still works.
I then copied the .apk file of the app from the S8.4 to my S5e. After enabling “install from unknown sources” I tried to install the .apk after uninstalling the 536 build. But at the end of the installation procedure it simply says “App not installed”. I have no idea why. Maybe because the older tablet still runs on android 6.0.1 and the newer on android 9?
Anyway, it would be useful if Roon could make the older build available as a download and in a way that it can be installed on any device and any android version, at least until this bug has been removed from build 536.

Your move, Roon!

Thanks for the report everyone — We are looking into this and I’ll be sure to keep everyone updated as soon as we have more information.

@dylan, thanks for picking this up.
But could you, for the time being, roll back the Remote app to the previous version which seems to work just fine with the updated core. Or at least give us the choice.
I suppose it’s not all that hard to make the .apk of the previous build available for download?
And by the way, am I correct in assuming that different versions of Android require different versions of the .apk? (which would explain why the .apk of my Android 6 tablet cannot be installed on my Android 9 tablet)
I really can’t live without this booklet function which I use multiple times a day!
Thanks in advance!

Server: Roon Nucleus+ running Roon build 1.7.537
Client: Samsung TabS2 running 1.7.537 Client on Android 7

Router: Asus RT-N66U
Android talking to Roon Server via WiFi
Roon talks to my Benchmark HGC3 DAC/preamp via a Sonore UltraRendu over Cat6 to the endpoint and USB from the endpointe to the DAC/preamp

“Open File” for any PDFs found in the album directory and listed on the Album display does not do anything. I use this all the time and know it was working before the latest Android update. Opening a PDF on the Windows Client (on Windows 7) works fine in 537 update.

Same problem, Pixel 3 XL running Android 10.

Already discussed here: Roon Remote unable to load PDF booklet after update to build 536

Hi @WillK — I moved this post to another thread where this is being discussed. We have a ticket open with our team about the issue with Android devices being unable to open PDFs. We’ll be sure to keep everyone updated as soon as we have more information.

Seems to be fixed, I can open pdf’s again. :+1:


Did you have the Roon Remote updated, @Bluebeat? I have not noticed any change in behaviour on my tablet but then again, it’s still the same build 537 that’s running…
And there does not seem to be a new update ready for download in the Google Play Store, at least not where I live (Holland, aka The Netherlands)

Hi @Hans_Valeton

There was no update, at least not one that could be downloaded from Google Play. I opened several pdf’s without any problem.

But just now there were some hiccups (I couldn’t play some Qobuz albums, and a few error loading page messages) now I can’t open them anymore. :no_mouth:

I haven’t checked thoroughly, but it seems to me that some Qobuz albums that normally have a pdf with them, now don’t.

Something is afoot… :wink:


Hi @Hans_Valeton

Just now it worked again. And I found a qobuz album with a pdf! Looks like progress is being made.

Did you have any luck?

No, still not working. Bluebeat you are using an Android device with build 573, aren’t you? What device do you have?

Hi @Stan_Jones
I’m using build 537 on a Samsung Galaxy Tab S5e (Android 9).
It’s still working. Right now listening to an ECM album, Baida, by Ralph Alessi through Qobuz: pdf booklet available and I’m able to open it.

Hi @Bluebeat, imho it would be impossible for a problem that came with a new build to suddenly disappear without the implementation of a new one.
Perhaps the on/off successes that you witness on your tablet have to do with the fact that it concerns booklets that come from Qobuz? I don’t use Qobuz, so I couldn’t comment on how that works exactly, but I assume that these booklets reside on the Qobuz server and not on your own?
My booklets are all stored on my NAS. And since 572/573 I have systematically not been able to open any booklets on my Samsung S5e tablet.

I’m not so sure it can’t be solved without an update downloaded from Google Play. I guess it depends on the problem too. But I’m no expert.
I have pdf’s from Qobuz and on my NAS. Both didn’t open when I first noticed this problem.
A few hours ago I only had time to try with a pdf from Qobuz. Maybe later today I’ve time to try a pdf located on my NAS.

Well, just did a quick test, only one NAS album with pdf involved, and the pdf won’t open. We’re not out of the woods yet.