Roon Rock loose Connection


for a few days a have set up a roon rock on intel NUC7i7BNH.

Before this a have the Server on a macbook pro and everything is fine.

But now i can only connect to the roon server for 1-2 seconds and then it loose the connection.

I have read at the community for the firewall, but i don´t now what i can do.

I have a lancom router:

:|5|2018-09-19 21:32:49|LOCAL3|Alarm|Dst: {MP_PRIVAT.intern}, Src: (UDP): connection refused|
|6|2018-09-19 21:31:47|LOCAL3|Alarm|Dst: {MP_PRIVAT.intern}, Src: (UDP): connection refused|
|7|2018-09-19 21:30:40|LOCAL3|Alarm|Dst: {MP_PRIVAT.intern}, Src: (UDP): connection refused|
|8|2018-09-19 21:29:38|LOCAL3|Alarm|Dst: {MP_PRIVAT.intern}, Src: (UDP): connection refused|
|9|2018-09-19 21:28:36|LOCAL3|Alarm|Dst: {MP_PRIVAT.intern}, Src: (UDP): connection refused|

The is the Nuc … the is my iphone with roon app.

I have make a rule in the firewall that every connection to the Nuc is allowed …

What can i do?

Many Thanks.


@noris - Doesn’t this sound like the @Lloyd_Borrett problem? Maybe Lloyd is getting the same messages, but just doesn’t see them?

I don’t know how or where to look for such messages.

Yeah, I just mention it because maybe noris can supply some more insight.

What do you think of the suggestion to boot from an Ubuntu thumb drive and see if you can access the Internet. In order to check out your network connections, etc.

We should talk about this in your thread, rather than here.

Those messages are from Marc’s router logs. Not something from ROCK.

I’m thinking it is a VPN / Firewall issue. Try turning them off and see if the issue still persists.

Hello @Marc_Petrowitz,

Thanks for contacting support, I’d be happy to look over this issue with you. Can you please let me know the model of your router and how the NUC and Roon Remote is connected to it? Are you using a laptop as a Roon Remote or an iPhone/iPad?

I have looked up Lancom Routers and they seem to come with VPN technology built in, which can cause some issues. You should be able to add exceptions to your router’s firewall from the router’s Web Administration page. To access the Web Admin page, you need to:

  • Open a web page on a device connected to the router
  • Input your Router’s IP address (seems like it is from your post)
  • Put in your router’s login information (usually it’s admin/admin or might say it on the bottom of the router itself)
  • Search for Firewall Settings
  • Add (The NUC’s IP) as a firewall exception
  • If you need to add a specific port range as a firewall exception, the ports Roon uses are:

Please let me know if that helps and if you still require more assistance after doing the above steps, a screenshot of the router’s firewall page will greatly help.


1 Like

Hello @noris ,

I have make a firewall rule and Port-Forwarding: (I have Change the IP for the Rock to .158)

The firewall rule allow all communication from and to the rock.

If I disable the firewall nothing happens.


I use as remote a mac and a iphone … the same.

I have try to reset Database and Settings and then it worked … for 2 hours :hot_face:

Is it really the firewall? … if i have the roon server on osx everything is ok.

My router Modell: LANCOM 883 VoIP

The Rock is connected to a unmanaged switch from TP-Link.
The Mac (as remote) is connected to the same switch. The Ipone is connected
to a Ubiquiti AP AC Pro

Please help me.


Hello @Marc_Petrowitz,

Thank you for posting the requested information regarding your router.

This issue might be the router, it might be something else, and I don’t want to waste your time, would it possible to confirm whether things are stable on standard consumer router using the same ROCK?

If you have the same issues in that environment, we won’t waste time troubleshooting in that direction and can focus on the ROCK itself. Please let me know if you are able to borrow a router from a friend/work or purchase another router to test this theory.


Hello @noris,

Thanks for the answer. Unfortunately, I have no access to another router spontaneously.

Can it be the router at all?
If I turn off the firewall is still the same effect.
… and if Roon is running on the Mac on the same network, everything works.

So I really have to buy yet another router?

The problem is that I definitely have to use the Lancom again because it maintains a VPN connection to our corporate network that I need for my home office.

So far I’ve had no problems with other Software and the Lancom.

Does it make sense to completely reinstall the Rockt?

The first installation without the update to 158, It was a bit more stable, but as soon as I pressed on DSP crashed the Roon Remote software on the Mac.

Many Thanks.

Hello @Marc_Petrowitz,

Thank you for your reply.

We have often seen issues where a router with VPN capabilities cause issues within Roon and I would like to verify if your ROCK works on a standard consumer-grade router. Would it be possible at all to bring the ROCK over to a friend’s or relative’s place and try to see if you have the same issue there?

If we can rule out that the ROCK is the issue or if it is the router that will bring us one step closer in understanding the underlying cause. I don’t think that reinstalling the ROCK operating system will help in this case since as this seems like a networking issue and the VPN router is blocking communication to the ROCK on non-standard ports. I would also try rebooting your ROCK and network to see if that changes anything.

Please let me know when possible if you are able to confirm if this same issue still exists on another network.