Roon Rock on HP Slim PC

Hi everyone,

I am thinking of buying a HP EliteDesk 800 35W G2 Desktop Mini PC:

The HW config seems to be pretty OK for running Roon but I am wondering if it is compatible with Roon Rock. As far as I know Roon Rock OS should be used only with Intel NUC but I was hoping someone could tell me if this HP Mini PC could work before I actually buy it :).

Thank you.

ROCK more or less runs on most modern intel based systems as long as it has legacy bios and not UEFI but there is always a risk it wont. I don’t run ROCK on a NUC. However Roon dont officially fully support the software if it’s not on approved hardware. Saying that though they have always been fine with me.

So you just installed the Roon Server version on a Windows based NUC?

No I installed ROCK on a non NuC pc. If you want the hardware buy it and try it. If it doesn’t work you can always put windows back on it or another music focused Linux distro.

Or, buy something that is Roon approved so you know it will work.

Roon Rock is based on Linux. It is locked down and nothing else can be loaded on the system. This means that no extra drivers can be loaded. It is built specifically for Intel NUC based motherboards, and so only includes drivers specific for those motherboards. So, you might face a situation where some aspects of the system will not function because the right drivers are not included; a good example of this would be WiFi on some machines.

However, like basic Windows, I assume Rock contains generic drivers for LAN, HD Drive, etc I have not yet found a motherboard running an Intel CPU, desktop or NUC, which actually did not load ROCK. (Assuming it is not a newer model where legacy mode has been depricated).

That HP seems to be based on the 6th generation Intel NUC platform which “should” be fine with ROCK. And in fact, just because it is an HP machine does not mean that there is not an Intel NUC motherboard inside. But, I don’t know and couldn’t find any HP material specifying the motherboard. You might try to find out.

As mentioned by Jim, tech support is geared toward helping those using the specifically suggested hardware. But, all you need to do would be to ask in the Tinkering section. There are loads of people who have been running ROCK on other than the recommended hardware since its release. I still have a version on an old 2009 i7 920 desktop with a gigabyte board that is lying around. Works fine.

So, as someone else has said, try it. If it doesn’t work, then load Windows. Windows works just as well as ROCK. Or, if you are worried about it, then just get one of the specified NUCs.

Hi Daniel.
Thank you for such a comprehensive explanation.

To be honest, my initial thought was to go indeed with an Intel NUC but this HP is from my work place and I can buy it for 100$. Its configuration is pretty good and I made it even a little better by putting a Samsung EVO 500GB SSD which I had lying around the house. And with another 100$ I can buy 16gb DDR4 Corsair RAM.

If I go with the Intel NUC version, I have to spend at least 600$.

If ROCK doesn’t work on this HP I will still probably keep it, install W10 x64 on it and just use it for Roon Server and not install anything else. But I wanted to try ROCK first because everyone keeps telling me the sound is much better from ROCK compared to ROON running on Windows.

I tried it a bit last night but I ran into a small issue which I hope I will be able to solve:

The device was plugged in a Wireless repeater and not directly to the router. So I hope this was the cause.

Plug it directly into the router then. Your wireless network needs to be on the same subnet as the wired network for this to work.

I had a similar issue on a macmini…so I put a usb Ethernet adapter in and it all works fine…have to force a option key restart to get it loaded but it works…other pc motherboards I’ve tried have worked without issue too

So now it works. By connecting it directly to the router it gave me a normal IP address.
The problem now is that I can’t connect to the shared Drive it supposed to create over the network in order to copy there the codecs.
According to the documentation, I have to enter Windows Explorer and put \\\ or \\\Data but this doesn’t work.
Any idea how to do this?

Is the IP address of the computer you’re doing this on also in the 192.168.1.XXX range?

Try putting http:\ in an internet browser like Firefox, Chrome, etc and see if the ROCK home page comes up.

Finally made it work. The initial issue with the Windows Explorer not being able to open the shared drive of the Rock was because of the stupid security group policies which were enforced by default.
After fixing this I followed the steps described masterfully :slight_smile: in the help section and I installed the codex, made a BKP of the initial Core and uploaded it on Rock.
I booted the Rock and used the Roon windows app to switch from the old core to the Rock and everything works great.
I will start testing tomorrow. :slight_smile:
Thank you guys for your support.