Roon running in Docker on UnRaid 6.x

Not sure what you mean…are you getting an error message or something, to know there is a problem?

Hi mannp, thanks for inquiring. I used my laptop to install Roon on my unraid computer using docker. I imported some files as a test. If I reboot the unraid machine, everything looks okay and I can see the files I imported in the library view. If I reset the laptop, the library disappears and needs to be re-imported. I don’t see the libraryinformation files on the unraid computer so I’m wondering if they’re just being held in memory on the laptop somehow and when I restart the laptop they are erased. Something is obviously not set up right. I figure if I could locate the library information files on the unraid computer I might be all set.

If I am understanding correctly the music is on your laptop?

You need to setup docker to point to shares on your unraid server to where you want the config files saved, where you want the roon library to be stored and finally where roon can find your music.

Sorry for being unclear, the music is actually all stored on the unraid server. I think the part I’m missing is how to actually setup where the roon config and library files are saved.

Mine are set to /mnt/user/data/docker/roon/application/ and /mnt/user/data/docker/roon/library/

Hello, Im new to unraid 6. was able to set up plex via the lso repository. what is the https:// address for this repository?
Ive tried these addresses but they do give me a template.



This is the one i used by adding ronch/roon-server to the repository setting in a blank template, as I mention in the first post.

I think I have things set up properly but have no experience with Roon. Should there be a way to access a WebUI as with my other dockers or is configuration etc, all done through the other Roon apps? And if the server is working, which apps do I need for my desktop and mobile device? Is it just the Bridge for my computer and the Remote on my iPhone?

Also, do I need to/can I run Roon Bridge on my Unraid machine if it’s connected to my AV Receiver?

Yes, just download the apps for mac, android, ios etc and connect to your unraid server roon.

You should be able to see your av receiver connection in the audio setup, once you have a client connected.

Slightly off topic, but is there any solution to listening outside of the same subnet? Apparently others have gotten this to work with OpenVPN but I haven’t found a way yet

Hi there,

First time poster… What an awesome community…

Have installed the Core on my unraid server using this Docker. I can’t seem to see the settings for the dsp engine in the settings Audio tab.

Currently running the music into a PS Audio direct stream Jr.

A friend has the same streamer being fed by Roon installed on a Mac. Both are v. 1.3.

Is the dsp engine not available on unraid?

Thanks for the help…

Fauzi Garib

Hi Fauzi –

Welcome. :slight_smile:

Are you by any chance using a phone for your remote? DSP settings are not accessible in the phone interface – they are available in the tablet and Mac/Win applications.


Woah! Nail on the head! Loading Roon on my iPad as we speak. Great!

1 Like

I’ve just gotten unRAID 6.3 installed from 5 and am still figuring out the dockers. I installed the Roon docker as described in the first post but there is no option for port and volume mappings. unRAID says it is running and was downloaded but I have no way to access it that I can figure out.

Should I be installing on the docker page using the “add container” button or should I be using the Community Apps plugin? Any help would be appreciated. Thanks

There is no port mapping, but you do need to add the 3 mappings for you sh, app and music.

I added via add docker and entered the details manually.

Not at my machine for 30 mins, but will upload a screenshot of my mappings for you…

You access the server via a roon client, so will need to install that too.

Add the following path from the ‘Add another Path, Port or Variable’ in the ‘Add Container’ setup page.

1 Like

Thanks for the reply. I believe I have everything setup properly at this point, thanks!

Thanks mannp! Using your screenshots I was finally able to get Roon up and running on my unRAID server.

1 Like

Hey there,

Please let me know your experience. For me, it’s hit and miss at best. I have a lot of crashes on the server side. My server is a core I5 with 8gb ram.

When I shifted it to my MacBook pro (older core 2 duo), works flawlessly.

Have installed it a few times on unraid but, like I said, hit and miss.

Fauzi Garib

No crashing issues due to unraid at all to be honest. Been running well from the start.

Some glitches with roon itself especially how it reads directories on a linux system, where I had to re-enable the file locations.

Other than that working well here.

Did you try with a clean config each time or did you reinstall while keeping the same config and library directories.

Hi there,

TBH, now that you mention it, I don’t think I did a clean config. May be worth a shot again.

To do that, remove the docker, image, and what else? Remove the app directory?