Roon Runs Slow On Desktop PC

Lots of specs given, but not of the “slow” machine.

Can you dump specs/setup of Windows 10 Desktop PC, and explain what you mean by “slowly”.

Sounds like a graphics driver issue to me… There’s a known issue with Intel graphics hardware and drivers and the OpenGL library used by Roon’s UI. If you can’t get a version of the driver to work, try using the 32bit version of Roon on the desktop PC. That’s a workaround that is known to work.

Intel Core i7-3770K CPU @ 3.5GHz
16GB RAM
Windows 10 Pro v1709, 64 bit
Intel HD Graphics 4000 display adapter (Motherboard)
NVIDIA GeForce GTX 750 Ti display adapter
Display 1: 2560 x 1440
Display 2: 2560 x 1440
500GB SSD system drive
2 x 4TB HDD
1 x 2TB HDD
2 x Synology 216play 4TB NAS
Pioneer BDR-209D Blu-Ray/DVD/CD drive
Acronova Nimbie USB Plus NB21-BR Blu-ray/DVD/CD disc autoloader

Slow…
30 seconds to load Roon
Around 2 minutes to display a screen of 21 album covers.

Maybe try disabling the onboard driven screen and just use the nvidia temporarily just to eliminate the motherboard graphics.

High specs even with Intel driver. Really can’t see hardware as the problem. Perhaps a conflict with nvidia driver. I would remove the nvidia card and see if that solves the problem.

Actually, the suggestion to use the Nvidia hardware in place of the Intel HD Graphics 4000 hardware is probably the better option. This issue is almost certainly a conflict between the Intel Graphics driver for the HD 4000 and the OpenGL library.
https://community.roonlabs.com/t/roon-becomes-unresponsive-ghosted-out-completely/13683/10

RED Flag right there.

If you can disable the MoBo intel adapter and run both displays off the Nvidia card that would be a better bet.

1 Like

While I agree the Intel 4000 could be trouble, that should not impact startup or showing a screen of covers.

@Lloyd_Borrett, please confirm you are seeing an animated Roon logo during these “2 minutes”, and that the Roon logo is moving in a fluid manner.

Not seeing any animated Roon logo. And now it’s starting up okay, but still taking ages to load album images. Please see the video at http://www.borrett.id.au/downloads/roon-video-2018-03-31.mp4 (43 Mb) for an example.

Looks like the graphics driver issue to me…

I don’t think I’ll muck around trying to disable the Intel motherboard graphics and running my two monitors from the add-on graphics card. I can see that providing nothing but ongoing grief with Windows and driver software updates going forward. I’ve just arranged to purchase a Google Nexus 9 (the Android tablet recommended by Roon Labs) secondhand to use in my study/office as the Roon remote.

Then the simpler route would have been to use the 32bit version of Roon on your Windows PC. That isn’t affected by this issue. It wouldn’t have cost you anything either. Still, enjoy your tablet… :grinning:

The 32-bit version does work. Thanks.

Nvidia’s are built to handle multiple monitors, one of their whole points actually. The card’s own graphics card handles all processing, and having the card run both monitors will allow it to do better screen sharing (as well as other things). And the drivers should always be the latest from the manufacturer, never what windows updates gives you. That goes for both Intel and Nvidia.

this is no longer the recommended tablet. The hardware was fine on older operating systems, but newer operating systems have slowed it down considerably.

Our team is mostly Android people, but we all use iPad Pro’s for Roon. The bigger, the better. The iOS Roon experience is also better.

Tell me where you learned of this ancient recommendation, so I put up a modern caveat. Never trust “old” advice as valid. I can’t imagine this advice was posted in 2017 or 2018.

You should never use the 32bit Roon unless you have no other choice, it is greatly limited in how much RAM it can access.

I’ve been debating removing the build completely. it is slower, less capable, and more prone to bugs.

@danny - if it’s purely being used as a Control, then does this really matter? Until the graphics driver issue is resolved, then it would appear we have little choice.

well, on the Core, using 32bit limits you to an insanely small library – remotes are a bit better, but not much.

I dont understand why 32bit fixes this driver issue… can you explain?

@danny - I have no idea why the 32 bits version of Roon works with this redrawing issue, but it does.

In all the cases that I know of where folks have reported problems with an Intel graphics driver and the OpenGL library, they have had the 64bit version of Roon installed. Changing that to the 32bit version makes the issue go away. So, not changing the Intel graphics driver, but switching from the 64bit to the 32bit version of Roon. That’s also been my experience on two Windows machines (an Atom-based tablet and a Surface 3).

1 Like

It came from the Roon Knowledge Base. See https://kb.roonlabs.com/FAQ:_What_Android_devices_can_I_use_Roon_with%3F
Page last changed Thu Apr 14 2016

Seems that needs an update.

Maybe I should have asked the question here in the forums rather than relying on the Roon Knowledge Base.