Roon server file for Synology beta version DSM 7.0-41222?

I upgraded to DSM7 not knowing it would kill my Roon Server. I then spent hours trying to make the ‘docker’ solution work, but I couldn’t make it work since I do not have the backup files required (or what is described in the walkthru) for docker but only the original files from the server. I might also not be experienced enough.

I see some workarounds here - do they work? I went through the posts but I could not distill a clear strategy. Thanks.

@Jan_Michael - I’m sorry to hear that you weren’t able to get the Docker-based solution working. If you truly don’t have either a backup or your previous “data” folder, then you’re probably going to need to do a clean install, which is unfortunate. If that’s the case, you should be able to get docker working, no?

Just seeking clarification of what the downside is of doing a regular Roon install on DSM 7. I have it working, but it seems I need to repeat the sign-in when the server reboots. No big deal given that reboots are infrequent events. I also got the Docker version working, but for the moment do not see a critical need to use Docker, but perhaps I’m missing something?

Hi @ACvitus,
I am planning to release an update to the RoonServer DSM7 beta installation today / tomorrow.
Main differences:

  • The reauthentication after reboot will be solved
  • USB storage devices can be chosen to store the database
  • ffmpeg can be manually added in a dedicated bin folder in the parent database folder.
  • Roon Server’s database folders (RoonServer, RAATServer, RoonGoer) will be grouped in a new parent folder “RoonOnNAS” (which also contains the mentioned “bin” folder for ffmpeg).

I am currently in testing phase and it seems to work well so far.


sounds encouraging. I had just started doing some library re-building on the DSM 7 install, sounds like I should wait to do a clean install with the new installer?

I have put a new installer for DSM7 on the website.
I’d recommend to uninstall the previous beta first, before installing the new one (don’'t worry, database does not get touched during uninstall).

  • When installing the new version (as mentioned in my previous post), your old database is moved into a new folder on your database shared folder called “RoonOnNAS”. It also contains a bin folder, where you can add your own ffmpeg.

  • You can also choose usb storage volumes now as your database location (without getting an error).

  • The Reauthentication issue should be fixed.

  • I have added a preset for Synology firewall with relevant ports of Roon Server, when choosing “Select from a built-in application”. But I have to admit, I have no experience with running it behind the Synology firewall.)


I looking for my time to jump in. Is this a stable enough release for me to hop on board?

Just installed the beta version. Wow! My music is back. Thanks your great work. :heartbeat: :heartbeat: :heartbeat: :pray: :pray:

I was actually thinking about removing the beta for this release. But due to the high amount of time spent on this new spk and the fact, that it is the first NAS installer that uses a parent folder for Roon’s database, I decided to keep the beta for a short while.
But I am confident, if there actually are issues with this DSM7 installer, these are minor ones.
You can think of this spk more like a release candidate.


That’s very reassuring.

So I do a backup, uninstall roon then upgrade to DSM 7.

Install the new package and restore from backup right?

Where can I donate for your efforts?


RoonOnNAS – Utilisez votre NAS comme un Roon Core

En bas de page

You can also keep your current database in place. The DSM7 installer will pick it up, if you choose the previously used “RoonServer” shared folder as your database location.


@crieke, many thanks, terrific work. Just curious about when it will be necessary to copy over ffmpeg to the new /bin folder. I just did a clean install under DSM 7, and playback of AAC files works straight away. Could that be because all the endpoints I tested have their own AAC support already, or is Roon simply picking up the OS-level version of ffmpeg which comes with DSM 7?

Normally Roon Server will pick up the OS-level version of ffmpeg. I had noticed on my system, that I was not able to play any AAC files by default. If the endpoints have AAC support should not matter here. (Maybe you had other apps installed, that contained a more comprehensive version of ffmpeg?)

In case you want Roon Server to use your own version of ffmpeg, you’ll need to stop and start Roon Server in the Package center after ffmpeg has been copied to the bin directory.

I will also update the info on the roononnas website to address these options.

My NAS also has the community package version of ffmpeg installed, but Roon kept playing AAC without it. Anyway, good to know the installer provides for a local ffmpeg should it be needed.

After install as it pulled all my music and setting automatically I forgot to do a restore. After a restore everything seems to be working as it should. False alarm and great work.

1 Like

Installed the Roon Server for DSM7 today. Pointed it to my old RoonServer directory that after install shows a RoonOnNas subdirectory. On my RS815+ NAS all seems fine i.e. Roon shows up installed and running.

However on my Win10 PC and Android Phone Roon will no longer successfully connect to the Roon Core. It halts at,

Any suggestion what I might have done wrong or can do to fix this?

I’ve seen this with different cores in the past. In most cases it could be solved by rebooting the Core and remote device.

The new dsm 7 package it’s working very well, but I have a little issue that I noticed, it still requires a manual force scan of the library when adding new albuns.

In DSM 6 after adding a new album roon scanned the folder automatically. Could be a DSM 7 limitation.

mmm, not in my case. Tried,

  • rebooting NAS → not working
  • rebooting remote device → not working
  • uninstalling Roon Core, reboot NAS, install Core → not working

In ‘RoonServer_log.txt’ there is a ‘Critical’ event listed

07/28 08:42:13 Critical: scx: System.NullReferenceException: Object reference not set to an instance of an object

  • at Sooloos.Broker.Music.LibraryApi.Sooloos.Broker.Api.Library.get_Playlists () [0x00000] in <5ece48cf53214b34b20d8f9d428b1ccf>:0 *
  • at Sooloos_Broker_Api_Library_Adapter.Serialize (System.Object obj, System.IO.Stream stream) [0x0002c] in <68250c97138641c7ae4d9fa97d66ad86>:0 *
  • at Sooloos.Broker.Remoting.RemotingServer._PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x0010b] in <3c153672c34a4191ac0cb54910d2f09c>:0 *
  • at Sooloos.Broker.Remoting.RemotingServer.Sooloos.Broker.Remoting.IRemotingContext.PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x00000] in <3c153672c34a4191ac0cb54910d2f09c>:0 *
  • at Sooloos_Broker_Api_Broker_Adapter.Serialize (System.Object obj, System.IO.Stream stream) [0x00265] in <68250c97138641c7ae4d9fa97d66ad86>:0 *
  • at Sooloos.Broker.Remoting.RemotingServer._PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x0010b] in <3c153672c34a4191ac0cb54910d2f09c>:0 *
  • at Sooloos.Broker.Remoting.RemotingServer+<>c__DisplayClass28_0.b__0 (Base.Result`1[T] result) [0x0002b] in <3c153672c34a4191ac0cb54910d2f09c>:0 *
  • at Sooloos.Broker.Distributed.ServerConnection.OnGetService (System.Guid guid, Base.ResultCallback`1[T] cb_result) [0x0001e] in <5ece48cf53214b34b20d8f9d428b1ccf>:0 *
  • at Sooloos.Broker.Remoting.RemotingServer.OnGetService (System.Int32 rid, System.Byte[] body) [0x0001f] in <3c153672c34a4191ac0cb54910d2f09c>:0 *
  • at Sooloos.Broker.Remoting.RemotingServer+<>c__DisplayClass22_0.b__0 () [0x00011] in <3c153672c34a4191ac0cb54910d2f09c>:0 *
  • at Sooloos.SynchronizationContextThread+<>c__DisplayClass45_0.b__0 (System.Object _) [0x00000] in <5c9a320b13194534a515c0c5861f65bd>:0 *
  • at Sooloos.SynchronizationContextThread._Dispatch (Sooloos.SynchronizationContextThread+SendOrPostWrapper& ret) [0x00012] in <5c9a320b13194534a515c0c5861f65bd>:0*