Roon server file for Synology beta version DSM 7.0-41222?

How did you ignore that 8888 error? You mean the roon app would open on your devices, just not in the browser? I get that error and the devices won’t connect.

My permissions look right and the logs don’t have any errors.

donc comme je le dis il ne trouve pas le périphérique audio

I just closed the web browser. when I checked status of application it says running. I then left core running and went to application and is saw devices on network. I am able to enable and configure, I am just not able to select them as show in screen captures by Domtous.

You are in a similar situation. sorry it took so long to respond, I had to use google translate. The only difference is you are using USB, in my case I am using network connected devices. They all worked before upgrade to DSM 7. Great idea using screen captures.

Going back is not possible, ability not provided by Synology in fact they specifically warn about that at upgrade. However, benefits from DSM 7 outweigh Roon issues.

In addition the problems that are mentioned by Domtous are still present in network devices.

Non je ne suis pas en USB je suis en reseau

This was posted elsewhere, in case anyone is desperate.

I just wanted to share that I upgraded my DS1815+ to the released DSM7 after having first uninstalled roon. After the upgrade and successful reboot I changed the user permissions as described by [crieke] and installed the beta roon package he released.

I’m happy to say that I didn’t run into any issue, all devices playing nicely and even AAC files (i.e. my ripped audio books) play without any issue.

Overall the system feels more responsive and the CPU load is lower compared to DSM6.Though I’ve got LMS (Logitech Media Server) running via docker in parallel to roon and if I’m not using
either to play music the CPU load is between 0 and 1%.

1 Like

Bonjour,

Voilà tout est rentré dans l’ordre, je suis simplement revenu sur une ancienne sauvegarde.

:slight_smile:

Thank you for sharing your experience. I will give it a try and upgrade my DS918+ this weekend.

Bonjour,
Donc avant de mettre à jour vers DSM 7:

  • Faire une Sauvegarde de Roon
  • J’ai ensuite installer DSM 7 sur mon Synology DS1817+
  • J’ai installé Roon serveur béta (trouvez ici sur le forum)
  • j’ai essayé sans faire de mise à jour sauvegarde (matériel audio pas détecter)
    J’ai faire une restauration de sauvegarde et tout est rentré dans l’ordre “POUR MOI”

@+

Thank you for the tips

Merci and Thank You for sharing your experiences @Domtous and @SSt. I may give it a try this weekend as well.

hi everyone,

i’ve updated, and i’m using the beta package.

now i can only see one device to play music to it…to change it i have to disable all devices, and enable the one i want to use.

does anyone have the same behaviour?

I just found out that I had to change the ownership of all files under the RoonServer share to RoonServer:RoonServer to enable Roon to store the license related information.

Without this change whenever I restarted the roon server (either via a script or by rebooting the NAS) while the PC software client was not active roon core lost its license information and I had to reenter username + password.

I upgraded to DSM7 not knowing it would kill my Roon Server. I then spent hours trying to make the ‘docker’ solution work, but I couldn’t make it work since I do not have the backup files required (or what is described in the walkthru) for docker but only the original files from the server. I might also not be experienced enough.

I see some workarounds here - do they work? I went through the posts but I could not distill a clear strategy. Thanks.

@Jan_Michael - I’m sorry to hear that you weren’t able to get the Docker-based solution working. If you truly don’t have either a backup or your previous “data” folder, then you’re probably going to need to do a clean install, which is unfortunate. If that’s the case, you should be able to get docker working, no?

Just seeking clarification of what the downside is of doing a regular Roon install on DSM 7. I have it working, but it seems I need to repeat the sign-in when the server reboots. No big deal given that reboots are infrequent events. I also got the Docker version working, but for the moment do not see a critical need to use Docker, but perhaps I’m missing something?

Hi @ACvitus,
I am planning to release an update to the RoonServer DSM7 beta installation today / tomorrow.
Main differences:

  • The reauthentication after reboot will be solved
  • USB storage devices can be chosen to store the database
  • ffmpeg can be manually added in a dedicated bin folder in the parent database folder.
  • Roon Server’s database folders (RoonServer, RAATServer, RoonGoer) will be grouped in a new parent folder “RoonOnNAS” (which also contains the mentioned “bin” folder for ffmpeg).

I am currently in testing phase and it seems to work well so far.

6 Likes

sounds encouraging. I had just started doing some library re-building on the DSM 7 install, sounds like I should wait to do a clean install with the new installer?