Roon Server installation on to ReadyNAS 524X


(Duncan McDonald) #1

Hi there - newbie to Roon and loving it so far.

Could someone talk me through a Roon Server install on to a ReadyNAS 524X - it’s got a Dual Core 2.2Ghz proc and 4Gb memory so hoping it’s enough?

I’ve read on the community references to “RoonServer_linuxx64.tar.bz2” which I’m guessing is the installer - but as for how you get to that stage I wouldn’t have a clue!

If there are some relatively straightforward instructions I’d appreciate the help - I’m a Windows guy of 20 years but alas only just starting to look at Linux so am in the dark about what to do.

Cheers!

Duncan


(Daniel Beyer) #2

I would not use a Dual Core, the recommended minumum is and i3. Also, even in NAS, Roon recommends that you attach an SSD drive to act as a cache drive for Roon’s database. While this seems possible in QNAPs, I have not found that option on my ReadyNAS.


(Duncan McDonald) #3

Thanks Daniel, appreciate the feedback. What kind of issues am I likely to come across trying on a dual core? I have a pretty basic setup, with an iTunes library of music (hey, we all have to start somewhere!) and a couple of Sonos 1 players.

The NAS supports SSDs in combination with sata drives so I’d certainly look to give that a go.

Duncan


#4

The i3 is also a dual core. There are many versions of the i3. Comparisons can be made here:

http://www.cpu-world.com/Compare/514/Intel_Core_i3_i3-2100T_vs_Intel_Pentium_D1508.html

The CPU in the 524X may be enough to run Roon if up-sampling and DSP is avoided. I think the bigger problem would be to get Roon installed on the 524X, but it is certainly worth a try. The Qnap TS251+ is a quad core Celeron that can handle the same, and even some DSP duties…


(Henry) #5

We have examples of successful installs on Qnap and Synology but not Netgear ReadyNAS hardware. If you can get onto the Linux console and get root access you may be able to do it. @crieke is the man who would best be able to give you pointers if it is possible.


(Duncan McDonald) #6

Well an update for you all after having a tinker…and it’s working :smile:

Basically I created an SSH connection to the NAS, got to root, ran the Roon Server installer from http://kb.roonlabs.com/LinuxInstall (although I had to also install the dependencies and the bzip2 package first) - and it installed fine.
I then fired up Roon on my PC and low and behold it found a new Server instance on my NAS - it even allowed me to choose the media folder and browse the contents etc.

In any case; appreciate I may come across performance issues but as I said previously, my setup is pretty basic; for now I’m delighted I can access everything on the NAS, playback from my Sonos speakers in any room and do all of this from my PC or mobile - it’s even found my Sky Q AirPlay devices :slight_smile:

Thanks for all your replies

Duncan


#7

That is fabulous! Good job!
Is this with Roon’s data base on a SSD?


(Duncan McDonald) #8

Hi there,

Not yet no - just wanted to prove it works initially. I’ve only got about 900 albums so not huge but it indexed it all very quickly. The slow bit seems to be track analysis, but I’m content to wait for that to complete.

Next thing I’ll try is a more customised installation and specify an SSD for the DB location.

Duncan


#9

I’ve got even fewer albums, only 575. I disabled both audio analysis options as I don’t need them, but use convolution for room correction.
Would be interesting to know how much CPU Roon uses on playback. Clicking the little star by the track title when playing shows signal path and processing speed. If speed is not shown the processing is more than 100 times faster than playback. Also issuing the ‘top’ command logged in as root will show CPU usage. On my i5 NUC I see a speed of around 12 on a 24/192 track with convolution (a 131k taps filter). Without convolution processing speed is over 100 so not shown.


(Daniel Beyer) #10

Sadly, older ReadyNAS do not seem to work. I got as afar as BINARY Failure during the install.


(Duncan McDonald) #11

Ok - sounds like an incompatible install version. I’m running readynas version 6.9.0 and the x64 install packages worked for me.

What version have you tried and what NAS do you have?


(Henry) #12

The older ReadyNAS models had Marvell processors so were incompatible with Roon. A quick look at the D1508 spec shows it is a Pentium and roughly equivalent with some older i3 processors but with a modern thermal profile.


(Daniel Beyer) #13

Pioneer Pro 6 bay with an e7600 core 2 duo processor. runs the previous version of readynas


(Philip Stillman) #14

I have a Netgear 516 NAS, i3 3.3ghz dual core processor. Could you please post a step by step method of how you got it installed, i.e., what package, what “dependencies” are you referring to, etc. I will use a USB flash drive as an SSD. How do I direct the DB to be stored on the flash drive?


(Daniel Beyer) #15

That is not an SSD and you really shouldn’t use it as such. Flash Drives have no error recovery system built in and are generally much slower than an SSD.

Somthing like this would be better, imho:

You would have to edit the install files to direct the install program to use the external drive.

There is no install file for the ReadyNAS like there is for Qnap or Synology in their respective app stores. For the ReadyNAS, you need to SSH into the NAS and install the linux version of Roon.

Editted: @Philip_Stillman

I have an old ReadyNAS which I’ve just loaded OS 6 on and will be attempting to set it up. This is a unit which I’m am only using for testing purposes because there is the possibility of messing up the NAS. I will be documenting what I do and if I get it going I will be happy to share. For the first time, I am not going to try and use an SSD, I’m just going to use the existing drives. If I get that working then I’ll uninstall and try it again with an SSD with the knowledge that it can actually work.


(Philip Stillman) #16

So I have to purchase a standalone SSD drive to hook up to the NAS? How about some instructions on simply installing the Roon Server on the NAS? Honestly, if I am paying $120 a year, I would think that someone from Roon would actually explain precisely what I need to do get everything running, rather than the one cryptic answer that I have received, which provide me with zero assistance. Thanks for the reference to the SSD that would be required, though.


(Philip Stillman) #17

THANKS! That would be great. Do I need to actually SSH in or can I use the NetGear ReadyNAS console?


(Daniel Beyer) #18

SSH. There is no install package for ReadyNAS. Roon only supports QNAP and Synology with install packages and are the only NAS’s Roon officially supports at the moment.

So, you have to use the Linux install. Given that NAS’s don’t run a standard Linux there may be issues. I am doing this just as a side hobby project to see if I could re-use some equipment or if I had to budget a new NAS.

I do not have any timeline on when I"ll get this finished. I am just another user like you. So please be patient.

That being said, have you any experience with Linux? You will need an SSH program to run on your computer, I use Putty. You might get prepped by downloading Putty, turning on SSH on the ReadyNAS and see if you can get logged in. I believe you will use the admin account and it’s password to putty into the NAS.


(Philip Stillman) #19

So just using the RoonServer linux version installs everything that I need onto the NAS? “You would have to edit the install files to direct the install program to use the external drive.”
OK, so I need to do something once its installed to point to the SSD? How am I supposed to edit the install files?


(Philip Stillman) #20

Thanks. I have Putty installed on my NAS and have used SSH before. Its just been a long time!

Alternatively, I could install RoonServer on a PC that I have networked, but when I install roon from there, it installs on my iMac Windows VM instead, and I can’t get a a keyboard/monitor to work to access the PC directly without using the iMac