Roon Server on Mac Can't Find Squeezebox Duet

Roon on my Mac mini server refuses to recognize a squeezebox duet. I tried putting Roon on a Mac laptop and it couldn’t find the Squeezebox either. I put Roon on a Win 7 laptop and it found the duet in seconds. So I know the Duet works. But there’s something about Roon on a Mac. I turned off the AV and firewalls on both Macs, but it didn’t make a difference. I tried rebooting the Duet multiple time with the macs and it didn’t make a difference. Manually entering the IP address into the Duet of the Mac running Roon didn’t work either. Anyone have any ideas?

Is anyone at Roon going to respond to this? I posted over a week ago and have heard nothing but crickets.

How did you try to connect to Roon - did you use your Controller? Are you sure LMS is g running elsewhere on your network?

I’m not sure I understand your question. I was able to get the squeezebox to connect to Roon server when I ran roon server on a separate windows machine. I tried two mac machines with roon server running and neither was able to see the squeezebox. It’s pretty clear this is a Mac vs PC issue as a PC running roon server finds the squeezebox with no problems and multiple Macs cannot. As an experiment I also fired up LMS on the same Mac running roon server (roon turned off) and it was able to find the squeezebox. So it’s pretty clear there are no firewall/network issues with finding the squeezebox on a mac machine. I am absolutely positive this is NOT a LMS running in parallel with roon issue as I never had LMS running at the beginning of this whole excellent adventure. I only installed it on a mac to verify that the squeezebox was in fact working

To get the receiver to connect to the Roon server (which the receiver will believe is an instance of LMS) you need to use the Controller to make the connection and you need to be sure there’s no LMS running anywhere else on the network. As you installed LMS on the Mac what have you done to ensure it doesn’t fire up on startup?

  1. LMS was not installed when I first tried to connect the Mac Roon server to the Squeezebox and has no connection to this problem I’m having. I only installed LMS on the Mac running Roon server to verify the Squeezebox Duet was working fine, and there were no network, firewall, etc. problems on the Mac. The squeezebox connected with LMS and I was able to play music. I then completely uninstalled LMS using AppDelete.
  2. Roon server running on a PC was able to find the Squeezebox WITHOUT having to do anything on handheld controller.
  3. I also tried to connect the squeezebox to Roon server running on the Mac by inputting the IP address of the machine Roon server was running on and it was still not able to connect
  4. All the other suggestions in this forum such as multiple reboots of the server, squeezebox, etc. didn’t solve the connection problem

This appears to be a bug in Roon server on the mac (tried two different macs with same results) that is not on the PC version. While I appreciate the suggestions, if you’re not from Roon, you’re not going to be able to help me.

Does anyone know how to get in touch with Roon? They seem to make it hard to get technical support.

  1. For a starter post in the support subforum.
  2. I had to use my controller to get the receiver to connect to Roon on Windows, and it was the same on a fresh LMS install
  3. You’re not the only person that’s connected a receiver to Roon running on a Mac
  4. I’ll refrain from attempting offering any further assistance, please accept my humblest apologies.