Roon Server on Synology DSM 7 Situation

Progress but… so I did a restore from a backup but then end up on the roon login screen. If I try to log into my account, I get this.

Update - I hit Unauthorize and it’s working! I can connect from my mac and ios apps.

The only thing that’s strange is that the web app still returns ERR_CONNECTION_REFUSED when I go to:

@Bill_Wolf - I’m not remotely an expert - using Roon just for a few months - but it doesn’t surprise me that you’re new installed and configured core has a different unique id than the previous installation. I’ve played with using Roon in two physical locations. The Unauthorize operation simply removes your license grant from an instance of Core. You’ll need to do that to shift it be able to associate with the new instance.

Did you uninstall the old version before installing the beta package? I think doing so is the safest route but the question is academic in your case.

As far as I know, Roon Core running on a NAS does not have a web GUI. In my current DSM setup, there is no link to the GUI, so I can’t click on anything that produces the error you’re seeing. If I create an equivalent link and try to access port 8888 on my NAS via http, I see a similar error since nothing is listening on that port.

I believe @crieke commented on this earlier. The actual issue is that the link you’re clicking on is being displayed at all, not that Roon isn’t responding on 8888. I think you can ignore the link and expect that, in the future, it will disappear.

upgrade DSM 7 this morning.
The roon server stoped.
Hope the roon update won’t be too long to wait.

I found this in another thread:
I was just able to start the sever manually with the following command via SSH:

sudo /var/packages/RoonServer/scripts/start-stop-status start

Server is up and running.It’s not showing in the UI that it’s running but Roon finds my core again. So at least there seems to be a workaround.

see here: Roon Server on Synology DSM 7.0 Preview - #2 by Jonathan_Fallows

Hope it works for you too

1 Like


is there a workaround for not being able to have a Roon database on USB shared folder (other than moving it to HDD volume)?

I found a workaround that I believe it will do the trick until it gets officially solved.


  • installed RoonServer to a HDD share
  • ssh on Synology
  • sudo bash
  • went into RoonServer folder (/volume1/<share_name> at my place)
  • removed RAATServer, RoonGoer and RoonServer folders that were made on first start of RoonServer
  • made symbolic links to Roon folders on USB disk; at my place:
    ln -s /volumeUSB2/usbshare2-2/RoonServer
    ln -s /volumeUSB2/usbshare2-2/RoonGoer
    ln -s /volumeUSB2/usbshare2-2/RAATServer

It worked right away. And it seems to be working after the Synology restart.


Chistopher, Thank you for creating the beta install of Roon Server for DSM 7.0. After watching your video and moving my database off the USB SDD drive back onto the Diskstation, everything works as it should.

Importantly, either Disk Station Manager 7.0, or the new install from has resolved ongoing nagging issues with Roon on Synology.

First, since Roon 1.7, I was experiencing a roughly seven second delay from the end of one track of a playlist to the start of the next song. The delay was just long enough to be noticeable but not so long that it was worth submitting a ticket. This issue is now gone. Next songs start immediately.

Second, my NAD C368 had an ongoing issue that started with a Roon upgrade about a year ago where at first start-up sound would not start until I adjusted the volume either up or down. Every time I would fire up the NAD, nothing would play until I clicked on the volume button. Again an annoyance but nothing worth submitting a ticket on. With DSM 7.0, the new Server Install, and perhaps moving the database off the USB drive, somewhere in those changes something occurred and the NAD starts playing songs without me having to adjust the volume.

Last, as improbable as it may seem, Roon sounds better than ever! A halo effect for sure but I’ll take it!!

If you were running a usb flash drive and not a real SATA SSD then I might expect this.

The SSD I was using is listed below.

I might agree with you except my issues with slow starting of tracks and the NAD not starting as normal used to not happen at all while I was using this SSD. It was during updates to Roon that these issues crept in.

All I was doing was following Roon’s suggestions to kept the database on a SSD to improve performance. Now I realize the opposite might be true, at least based on my experience.

I suggest you double check the primary dns ip set for your nas.

I have updated the DSM7 beta installer. Full details here:

I’ve installed the new Roon Server. Unfortunately, my issues still exist. The MQA playback is stuttering to the point you can’t listen to music. I have to restart the server to fix -sometimes and for a little while- the issue. There’s have to be something with Roon+IFi ZEN Dac v2, because everything else is playing just fine. And I have to mention that I think it’s not happening with all MQA files / albums.

For what it matters, I’m also running Plex Media Server on my Synology and I’m able to stream 4k movies without a single pause to buffer, so I don’t think it’s a network or a NAS hardware issue.

In any way, thank you for your big effort @crieke :heart:

Hi CvK,
It is hard for me to debug this specific issue, due to the fact that I don’t have that device here.
I was wondering, have you tried adding ffmpeg to the /bin folder?
It is located at your specified Roon database location at <YourDatabaseSharedFolder>/RoonOnNAS/bin.

If this makes no difference, have you checked the resource monitor when this issue occurs to check on CPU and RAM usage?

Sure @crieke, I understand this. And I don’t think that’s an issue with your packages because the issue was not there from the beginning. On DSM 7 Beta everything was perfect. Either the Synology DSM 7 RC version or a Roon update caused it, I guess.

And yes, I’ve tried to debug it. I already did what you are suggesting. I’m tracing the logs at the timestamps when the hiccups happen but I can’t see anything valuable. If you have the time and you want to check my logs I can share them with you. And the CPU/RAM usage is normal.
I also did a couple of firmware upgrades for the iFi DAC that I’ve missed without luck as it seems.

I haven’t tried the custom ffmpeg bin yet. Are there any executables I can try or I have to compile it myself for my specific NAS? I also see there is a package from Synology Community. Maybe I’ll try that too.

Btw, is there any way to disable all Roon logging? I see it’s pretty verbose. Could this affect the read/writes of Roon? (I guess you can see how desperate I am at this point :joy:).

And, as I said, I understand this is a pretty niche bug, tied to Roon + iFi. I don’t expect from you to debug it and fix it magically :slight_smile:

you may find the OS-supplied version of ffmpeg in /usr/bin (ssh in and you can see).

If you add the SynoCommunity package source to Package Center you can install an independent version of ffmpeg , which on my system has landed in /volume1/@appstore/ffmpeg/bin

Thanks for the info.
Currently, I’m evaluating Roon with custom ffmpeg provided by JohnVanSickle as @crieke suggested. So far so good. I’ll report back when I’ll be a bit more sure for the results :slightly_smiling_face:

Hello Christopher,
I also made the mistake to install DSM7 without checking the forum first. Roon no longer worked. Installed the beta version as suggested via the website. Now Roon is running with one minor flaw. It shows all the music end-points but does not allow to play anything as it says, no audio device found. Bluesound Node 2i is running, so are a few others, but Roon is not able to connect. Is this to do with the Beta version?

Totally lost at the moment with all the settings and options on the Synology (which has caused a lot of other problems lately with changing a faulty disk, but that is something else).

Hope it is a simple setting I need to click on.

Regards, Michael

Michael, this worked for me. The docker solution as explained here