Roon Server UDP 1900

Is it possible to disable roon server using port 1900? I am running roon server on a QNAP and Emby as well. I have enabled DLNA server in Emby, can’t bind because in use by roon server.


Roon doesn’t use this port. RAAT hasn’t used UDP for a long time.

Any idea what the following could be:

lsof -i:1900
RoonAppli 5308 admin 75u IPv4 2520993 0t0 UDP
RoonAppli 5308 admin 84u IPv4 2535906 0t0 UDP *:1900
RoonAppli 5308 admin 86u IPv4 2535908 0t0 UDP *:1900
RoonAppli 5308 admin 88u IPv4 2535910 0t0 UDP *:1900
RoonAppli 5308 admin 90u IPv4 2535912 0t0 UDP *:1900

What version of Roon Server are you using?

These are the ports currently in use …

Edit: UDP 1900 is used for UPnP discovery.

No, there isn’t a way to disable it. We use it to discover some devices that use SSDP.

It’s possible for multiple applications to use the same multicast address. We open the port in a way that should allow for this. Maybe Emby is not doing the same? That is the real solution–not an “off” switch.

You can change the main ports Emby uses in the admin interface. But it uses 1900 for UPnP discovery.

Looking around under “Manage Server” and can’t find where to do that, would you mind pointing me in the correct direction please?


You cant change the 1900 one its fixed in code as its used for discovery, its only the main port for http/s you can change, Maybe the NAS is the issue are you running in dockers or just native apps ?

I use plex on my NAS but my core is on another computer and it uses the same port for UPnP discovery but I get no issues.

I think this is an Emby issue related to .net core, from Emby forums:

The problem is most likely due to another DLNA service running on your NAS device.
** Normally co-existence wouldn’t be a problem, a you’ve seen with Emby 3.3.**
**But there’s been a regression in the .net core framework since .net core version 2.1 and it persists in version 2.2. **
Emby 3.3 used .net core 2.0 (or maybe MONO) where this problem didn’t exist.
Unfortunately there’s nothing we can do about it. MS has already fixed this for .net core 3.0, but it’s not yet released.

Your only option at this time is to disable the other DLNA service on your device.

Yes, Plex works fine, I have moved on from Plex to Emby.

As @CrystalGipsy says, UDP 1900 if for UPnP discovery and is broadcast by all devices on your network that want to discover UPnP devices. Plex and Roon play nicely on my server.

Maybe you could revert to Emby 3.3 until they resolve this? However, before trying that, have you shutdown Roon and successfully had Emby running?

Emby is targeting March to address this issue, so I am fine waiting until March. I moved on from Plex and prefer Emby now. Yes, Plex and Roon works fine for me as well, but moving on from Plex. Thanks for all the feedback!

1 Like