Roon sets Hegel 590 volume to 100 on startup

Roon Core - Innuos Zenith Mark 3
Shunyata Venom USB
Hegel H590
Paradigm Persona 3 speakers

I have two issues with this setup the first one is that I always have to turn on the H590 amp and switch it to USB first otherwise the Innuos doesn’t show as an audio zone, this is no big deal as I can use Harmony remote to sort of automate that.

The main problem is that every time I start Roon, the Hegel volume is set to 100 and a few times if I’m distracted I end blasting music and I’m afraid my speakers might get damaged overtime.

I’ve had this issue since I got the Innuos configured as a Roon Core, previously I had the Roon core running on my QNAP and don’t remember having this issue.

I might be hitting a bug with Roon running on Innuos and might have to go the Support route but first I wanted to check if anybody else has run into this issue.


p.s. I have followed the instructions on how to set the USB volume on the H590 and I’m able to control the volume with Roon, the problem happens on Roon startup only

I can’t help with this particular problem. But you can stay a bit safer by limiting the maximum volume of your amp. There is a description of how to do it in the manual:

You can also, as a second step, setup Roon to have max and safe volumes.

Remind that if you have set a max volume for the amp itself, the volume shown in Roon will be a percentage of this maximum. So if your H590 cannot go higher than 50 on its display, a volume in Roon’s control app of 33, will mean 33 percent of 50. So the amp will show 17 on the display.

1 Like

Thanks @Arlen for the suggestion. I have tried those settings and they help as a workaround. I decided not to use Safety Limits because of the behavior you mentioned above and because occasionally I like to crank it up a little loud.

I’ll try setting the Comfort Limit again but as I recall the same behavior applies to this limit as well. I can’t remember why I didn’t like it.

The problem/bug is still on how Roon resets the volume at startup: let’s say the H590 is ON and at 45 volume level. When I start Roon and it detects that audio zone it’ll automatically set it to 100, despite the amp still showing 45. If I hit play it’ll play at 100.

Is anybody from @support or @Innuos looking at these threads? Or do I need to copy this thread to the support channel?

As an FYI, I tried the Comfort Limits and it still sets the initial volume to 100, the only difference is that the Roon UI now shows a red slider starting at 45 (preset I selected) on the volume control.

@Innuos and @support can someone please help debug this issue?

It’s likely the Hegel H590 is set to get the volume from the USB connection, which means it’s getting that info from the mixer. We set the mixer automatically to 100% so that it’s a bit-perfect output. You should be able to disable this behaviour on the Hegel H590 - Check page 17 of the Hegel User Manual:

Hope this helps!



1 Like

Thanks Nuno @Innuos I’ll try that again but my understanding is that the USB Volume = ON setting is required to be able to control the Hegel volume from Roon and if I disable that it defeats the purpose as I won’t be able control it.

See for details.

Based on your comment, it sounds like this is controlled from the “mixer”, is that an Innuos or a Roon setting? Is there instead a way to configure this mixer to start at 50% or a predefined setting?

In order the directly control the Hegel volume yes, that is correct. The most usual case is for users to use the remote on the preamp to control their volume and leave the mixer volume at 100%. The mixer volume we are talking about is on the Linux system itself (ALSA). We can configure it for you so that it’s set at 50% or something similar but I believe this will be detrimental to the sound quality. Alternatively, you can set Roon to enable the software volume instead which, again, can have a detrimental effect on sound quality but would still enable you to control volume with Roon (USB setting on Hegel would need to be off).

You can reach us directly on our support email and we can book a remote session to try out some options if you like.



Thanks again Nuno, I forwarded this thread to the and will try to schedule a call with you.

Do you guys think Hegel’s Roon certification (if it ever sees the light of day) will help with this issue?

The reason I ask is because I don’t have a pre-amp in my config so I can’t set it up the way you recommend. OTOH, I was planning on adding a Lumin T2 streamer to the mix to see if it helps resolve the volume issues. Do you think that would help?

If you’re using the analog output from the T2 then this issue wouldn’t arise as T2 is Roon Ready and wouldn’t be connecting via USB - you could either use the Leedh volume on the T2 (via Roon) or leave it set to full and use the volume on the H590. As to the USB output on the T2, will defer to @wklie.

1 Like

If the issue is related to mixer over a USB connection, then a Roon Ready (not Roon Tested) RAAT connection may help because it’s over network, not over USB.

We do have a number of users with a Lumin analog output direct to amp configuration and using Lumin Leedh Processing Volume here without the kind of volume issue discussed here.

We also have a Maximum Volume % setting that is hidden from Roon. At Roon volume 100, a Lumin Max Volume % of 80% will yield volume 80, about -10dB from max 6V rms for analog output.

With a Lumin T2, the connection should be Innuos Streamer Port → Lumin T2 XLR → Hegel 590 configured as Home Theater input. This way you can control the volume in Roon / Tidal app / Spotify app / Lumin app, etc.

1 Like

With a Lumin T2, the connection should be Innuos Streamer Port → Lumin T2 XLR → Hegel 590 configured as Home Theater input. This way you can control the volume in Roon / Tidal app / Spotify app / Lumin app, etc.

Thanks for the insight @wklie , just one clarification: the Innuos Streamer port (ethernet) is not connected to anything right now, only the Network port is connected to my switch. I though I’d have to connect the Innuos DAC output (USB) to the Lumin T2 USB input (to also take advantage of the Lumin DAC), but did I get this wrong? Are you saying I should connect the streamer port to the T2 (directly through ethernet cable)?

I believe an Innuos has a built-in switch. The streamer port will connect your streamer (Lumin) to your network and send music to it. But the signal through this port is cleaner, without noise that can have a negative impact on the streamer.

My own server (not an Innuos) also has an extra streamer network connection.

1 Like

Thanks @Arlen, that’s interesting but I wonder if that config would still take advantage of the T2 DAC which I’m not sure how it compares to the H590 DAC but I’ve read it sounds great.

The other question this brings to mind is: would it make sense to connect the Innuos Streamer port to the H590 network port instead of USB? how would this affect SQ and overall functionality?

Yes - it’s the same as connecting the T2 to a normal network switch (although allegedly ‘cleaner’).

This won’t work via Roon, any more than connecting it to a normal network switch would, as it’s not Roon Ready. Although you could use Airplay from Roon via this, if you’re willing to accept the hit in maximum resolution.

This does not work because Lumin T2 only has a USB output (to act as a streamer to another external DAC if you really want to), not input. (The only Lumin that has a USB audio input port is P1.)

Yes, with an unshielded CAT-6 network cable.

To use the T2 internal DAC, you will have to use the T2 network port. There does not exist another way, because T2 does not have any inputs other than the network port (excluding USB storage media).

Only after the H590 becomes Roon Ready. This is exactly what Roon Ready means at a user level - use the network port instead of other inputs like USB / coax.

After the H590 becomes Roon Ready, try both and post your findings.


Thanks so much for the detailed answers @wklie !!