Roon signal path not showing Filter

Thought I’d ask here…

I don’t have a screenshot of my roon signal path (not at home right now), but unlike the one below, which shows the filters applied in the “HQPlayer” section, mine just says “defalut, default” and then shows the bitrate.

Am I missing a setting?

When I get back home to my audio system I’ll add a screenshot from my Roon signal path window.

Not sure who had that Signal Path, but it looks like the only DSP in Roon is Headroom Management. Personally I just send Roon unaltered to HQ Player and manage headroom in HQP.

Screenshots of the HQP front page and Settings also will help answer your question.

ok, so here’s mine. Is “default, default” the norm?

I think that may happen if “default” is selected for filter and mod on the front page, or if there are no filter and mod selected in Settings. Can you upload screens of those ?

or are you also looking for the sample rate conversion window?

Hmm, can’t see anything wrong immediately. I’ll compare with mine at home, but will be about a day before I can post. Someone else might assist in the meantime. Are you connecting to the X-SPDIF via USB from your Core ?

@Christopher_Boone try changing the ‘output mode’ to either SDM or PCM on the main HQP screen.

1 Like

USB to X-SPDIF from the Bridge, where HQP is installed. (But it said “default, default” even before I had the X-SPDIF unit.)

I’ll check that main window. As you can see, behind the “settings” window, there are some dropdowns with “default” grayed out. I’ll have to see if I can activate those by changing something else!

It’s the right hand drop down, currently marked “Auto”, that is the Output menu.

Duh that was it. Thanks.

I had been selecting these settings from the inner preferences window. I wonder what the difference is, or why the need to select them in two places…

The ones in Preferences are default values that are selected when the application is started. The effective ones are the ones shown in main window. Output mode selection is not in Preferences on version 3 at all. Version 4 has it though.