Roon stopping without warning - Nothing Playing

Roon Core Machine

Apple Studio M1 pro, MacOS Ventura 13.3.01

Networking Gear & Setup Details

Ethernet connected to latest BT Smarthub router.

Connected Audio Devices

Chord Mojo connected to computer by usb, all other endpoints (Naim ND5 XS2, Naim Miso) connected by ethernet.

Number of Tracks in Library


Description of Issue

Recently each time I use Roon at some point the music stops playing and I can see the Roon message “Nothing Playing” - I do not get any indication of a lost connection. If I close the app (either on the computer or iPad and then reopen the app the track is back and I can start play again. This has happened each time I have used Roon recently and on different endpoints and with both iPad and mac as control apps. The most recent was last night at just after 2300 hrs UK time according to the Roon logs. Is there an issue with Mac M1 and Ventura? Let me know id you need any further info.

Cheers, Ian

“Nothing playing”, rather than an error usually means there’s nothing in the active queue to play.

When the issue happens, has the active zone disappeared?

I have intermittently experienced this same issue and it happened again two days ago. I always use Roon with Radio Radio turned on. My library has 12,000 tracks along with Tidal and Qobuz. My genre is usually blues and the music just stops at the end of a song with ‘Nothing playing’ displayed, my Node 2i is still active and present and the queue is empty. I have never tried closing the app and restarting it, I just enter a song, click play and then Roon is back to normal again. I think I remember seeing ‘Go find something to play’.

My Roon Core/library is on a QNAP TVS-672XT NAS. The NAS, Node 2i and router are all connected with Ethernet.

Same thing here: Playback stops abruptly, can’t be resumed for up to a minute - #2 by anthonynelzin As support seems to be overwhelmed/understaffed, I’m currently trying to find the cause(s) of the issue. One seems to be a nasty memory leak — throttling audio analysis seems to prevent Roon Server going nuts and locking up playback. Another one seems to be related to IPv6 — since I’ve disabled it on my core, I’ve not experienced interruptions, fingers crossed!

I think this is a different issue - and one that will get addressed in your separate thread.

The OP’s issue here is that he is getting a “Nothing playing” message, which means that the queue has become empty.

But I wonder if it’s actually the same. When the core seizes up, the music stops and the “Nothing playing” message appears. Relaunching the client like Ian does, or waiting a minute like I do, seems to sort of revert the queue. It’s a weird little thing.

Oh, are you saying that you get the “Nothing playing” message when the music stops in the middle of a track?

You didn’t say that in your thread. Please add this fact to your thread - the more information Support have, the better they are able to diagnose…

Yup. I’ll add the info to my thread, thanks!

My music stops at the end of the current track and I find my queue empty. My music is never cut-off during a song.

In my case the music stops abruptly during a track and shows Nothing Playing. When I restart the app the track reappears at exactly the point it stopped and the Play icon is showing so I can click it to resume play. I never use playlists so the queue is always whatever tracks remain on the album after the track I am playing. As I said in my OP I checked the log and can see the interruption of last night but I don’t know enough to identify what caused it.

Cheers, Ian

This behaviour seems to suggest that the endpoint was unavailable for some reason. It would be helpful if you could confirm with a screenshot of the Now Playing screen next time this occurs.

Good afternoon Martin. Roon Radio just did it again, from the time it happened to when I could get a screenshot was about five minutes. I checked and verified my Node 2i was still visible. I closed the app like others have, reopened it, but nothing continued, the second screenshot is reopening the Roon app.


I’m afraid my issue is getting worse. I am playing an extended playlist regularly to my Mac System Audio at low volume even when I am not listening to any endpoint to see if I could get the error to recur and obtain a screenshot. Now I have the following issue occurring more than once - the extended playlist stops unexpectedly at some point and when I open up Roon on my computer it is available to start play again at that point. On looking at the logs, it appears that Roon stops suddenly to search for a different endpoint, namely my Naim ND5 XS2. According to the log, I started the playlist at 0853 this morning with endpoint System Output. At 0904 Roon tried to access my ND5 XS2 then resumed play to System Output at 0905. At 0907 it lost connection to the Mac. The log then has a huge amount of ‘bad track’ type text and other gobbledygook until 0945. At 0946 I was back to the computer and restarted the playlist which started. It lost device again at 0952. I returned at 1115 and resumed the playlist but it stopped again at 1138. Each time I open up the client on my Mac the zone is showing clearly and I can play from where I left off. One other strange thing - when I looked at the queue just now it has a lot in it but bears no resemblance to the playlist currently running. My playlist running is of Mahler symphonies but the queue is of a whole list of piano concertos from another playlist. I include a screen shot of the queue. Please can you help! I have the logs.

Cheers, Ian

I’m experiencing the exact same issue during the last couple of days.
I need to quit Roon on my Mac Book Air (I have a similar setup as yours, a Mac as a Roon Core and a Mojo 2 + Poly) and then start it again and I can resume what was playing.

In my case it does not happen in the middle of the song but usually when I change album.

Same “Nothing playing” message.


Anybody looking at my issues. In addition to the ‘Nothing Playing’ and frequent connection interruption bugs, I also find when I play Roon for an extended period with the app minimised on my Mac and I then click on the Roon icon to do something the app is unresponsive and I have to force quit and restart. I’ve not had any response to my help request since I submitted it 10 days ago despite showing the requested screenshot. Some help would be appreciated.

Cheers, Ian

Hey @Timberwolf,

Ben with the support team here, I’m sorry for the long delay in reaching your thread! I appreciate your patience thus far, let’s dig right in.

The first thing I’m curious to see is how your core runs on a fresh database - make sure you have a recent backup saved first. Steps to follow below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Let me know how things run before restoring from a backup - if you could test just logging into Qobuz and streaming audio on the fresh database.

I’ll be on standby for your reply. Thanks! :+1:


Thx for getting back to me. I have followed your instructions. When I logged in to a fresh download of Roon, it found lots of music on my Mac to put in my Music Library so I disabled it and have just started a long Qobuz playlist running on two zones and will check if they are still running in a few hours. I assume that when I restore from Backup my library and settings including Arc will all be as before? I will let you know the status after I finish this test.

Cheers, Ian

Hi Ben,

I have now tested Qobuz playlists with a new install of Roon. Incidentally after the new install of the Roon core I had to delete Roon remote from my iPhone and reinstall it so it could find the Core. Here are my findings which point to two issues. Between 17:18 and 22:45 on 17 June I played Qobuz playlists to various endpoints, namely my Naim ND5XS2, my Mojo and my Mac System Audio. Play stopped on several occasions, mostly on the Mojo and Mac System Audio and I had to restart using the PLAY button, connection to the core was not lost. At 23:18 I started a long playlist on the Naim ND5XS2 which was still running ok when I tried to open Roon again at 10:18 on 18th June. Unfortunately the Roon client on my Mac was unresponsive, i.e. ‘hung’ so I had to force quit Roon and start it again. So the two issues are:

  1. music stopping unexpectedly at various endpoints without loss of Core connection
  2. Roon client on Mac not responding when I open it after a long period of inactivity

I have the logs (log.01 and log.02) covering the test period if that would help.

Let me know when I can restore my database from backup, and exactly what I need to do to get things back to where they were. For example, will restore get my own music and all settings back or will I have anything else to do?

I hope you can get to the bottom of these issues. Let me know if you need anything else.

Cheers, Ian

Hey @Timberwolf,

Thanks for the update - we were able to pull a fresh diagnostic report from your core and will take a closer look.

You can restore from a backup at any point now. Although there is one last test I’d be curious to see - and that’s temporarily running RoonServer on your Mac core device, rather than the full Roon all-in-one you are currently running.

With Roon Server, you would navigate around Roon using a separate remote, since Roon Server is headless. Here is more information:

Let me know your thoughts on the above, and in the meantime, our team will investigate things further. Thanks!

Hi Ben,

Thx for getting back to me. I read the link you sent me and it may be worth trying since issue no. 2 where the Roon app on the Mac ‘hangs’ seems to be because it won’t communicate with the Core. I noticed that if I used Roon remote on my iPhone or iPad that I could control Roon even when it was ‘hung’ on the Mac; indeed while the Mac app ‘hung’ and showed the track timing was static I could see with the iPad or iPhone that the music was still playing. It may not help with issue no. 1 though that mostly affected play with Mac System Output or Chord Mojo connected by usb to the Mac. Today I ran a long playlist without problems on my Naim ND5XS2 using Roon Remote on iPad and it did not stop or lose connection.

So while I am willing to try RoonServer, I am not sure I fully understand exactly what to do - could you provide me with an idiot step-by step set of instructions? I especially don’t quite understand the warning about a fresh install since I just did that as you requested. I understand the bit about renaming the Roon folder to Roon Server, but then do I have to install Roon after that? Two other queries:

  1. can I restore my Roon database before or after I did a migration?
  2. if I migrate to Roon Server (following your detailed instructions as requested above) will Roon Arc continue to operate as before or will I need to do something else?

It is almost 10pm here in the UK, so look for your replay tomorrow morning.

Many thanks for your help. Cheers, Ian