Roon stops playback randomly [Solved - Networking Issues]

Hi @Timmy_Chen ----- Thank you for the report and sharing your feedback with us!

Moving forward, we can definitely enable diagnostics on your account to have a closer look into this behavior but before we do so may I very kindly as you for the following:

  • Please reproduce the issue and note the…

    • Time when it occurred.
    • The track that was playing at the time of the error.
    • A screenshot of the signal path just before playback pauses.
  • Additionally, if you have any other audio zones active in your setup do they display the same behavior OR does this only happen with the mentioned Linn zone? Are noticing any actions or behaviors that seem to trigger this issue in Roon?

Once we have the above time frames and information we will go ahead and enable diagnostics. Thanks!

-Eric

It happened once just now. I was playing from Tidal and Roon just paused playback automatically. Before that, it has played continuously for several hours. I added a network switch between the Roon server and the router today, and the problem occurs less frequently.

Linn is the only zone configured in Roon, no other zones.

Thanks for getting in touch @Timmy_Chen!

Just to be clear, the error occur while you were playing the mentioned album in your most recent post (i.e “Piano Trio No. 2 in G major…”), correct?

-Eric

Yes, correct

1 Like

Thank you for confirming that information for me @Timmy_Chen!

I have now enabled the mentioned diagnostics on your account and what this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers. Once the report comes in we’ll be sure to follow up so you know that we have it.

Thanks!
-Eric

Hello @Timmy_Chen,

I can confirm that we have received the mentioned diagnostics info from your machine. Upon an initial look at the diagnostics info, it seems that there may be an issue in the network setup, can you please let me know what model Router you are using and your average download/upload speeds for you connection? You can check the speed on fast.com or speedtest.net and see what it reports. Can you please also let me know if you have any firewalls active in this setup that could be preventing a connection to Roon Core?

I have also gone ahead and started a case for you with our QA team who will be able to take a closer look at that diagnostic info and possibly recommend some other next steps forwards. I appreciate your patience while that happens but if you could let me know more about your network setup in the meantime that would be very beneficial towards getting some next steps forward here.

Thanks,
Noris

I use Ethernet cables to connect the Roon server and Nas to a Buffalo BS-2016/A switch which then connect to a Netear Orbi wireless router satellite working in Access Point mode. The Orbi base router is connected to a Asus AC86U router which is connected to a modem provided by the ISP. There’s no firewall enabled. I can click the play button immediately to resume playback.

My internet connection might not be stable, as I use OpenVPN to route the traffic to Tidal, I just checked the speed with speed.com and it showed 7 mb/s.

The problem occurs when playing local files in the Nas.

————

I also tried another setup. I connected the Nas and the Linn directly to the Waversa Roon Core which has four LAN plugs and can act as a network switch. Then I connected it to the Orbi wireless satellite. This setup can reproduce the problem more frequently, even when playing files in the Nas.

Hello @Timmy_Chen,

Thank you for providing that additional information. I remember there being a similar case with another user who had a Netgear Orbi router, and IGMP Proxying was creating an issue with his playback as well. I would take a look in the settings and see if you can disable that option to improve stability. The thread I am referring to can be found here:

Please give that suggestion a try and let me know if you are still experiencing playback issues. You might also want to try and disable the DSP function on Roon temporarily to see if that has any affect in increasing stability. Please let me know your findings when possible.

Thanks,
Noris

Hi @noris,

Thanks for providing the possible solution. I did looked into the settings for the Netgear Orbi, but the IGMP Proxying in the WAN settings is not available in Access Point mode. In fact the whole WAN settings is not available, which makes sense since the AP just sends traffics back and force between the router and the clients. Then I checked the related settings in the router, and the IGMP Proxying function is never enabled, nor is the Jumbo Frame enabled.

In my case, I can always connect to the Roon server. And when the problem occurs, I can see from the Roon remote that the Linn audio zone is still available. I can click the play button immediately. It didn’t look like the Roon server was disconnected from the network.

Hello @Timmy_Chen,

Thanks for confirming those settings for me. There are a few things I’m curious about:

  • You mentioned that you use OpenVPN in your setup, can you please describe how exactly you are using it here? Am I correct in assuming that it is running on your Core all the time but it is still part of the local network?
  • Would it be possible to temporarily disable OpenVPN and see if the playback stops randomly using just local content?
  • What happens when you disable the DSP engine? Does the playback still randomly stop after doing so?

Please let me know when possible.

Thanks,
Noris

Hi @noris,

I run OpenVPN at the Asus router, which selectively route some traffic through vpn based on the geo location of the destination ip addresses. The Roon Core doesn’t know anything about it. It only has one local ip address, which is given by the DHCP at the router. The Nas and the Linn also have the ip addresses in the same local network. The vpn is pretty stable. If not, only Tidal playback shall be affected.

I disabled the DSP engine in the past two days, and the problem still exists even when playing local music files in the Nas.

I also asked the Waversa dealer to send me another brand new Core machine, and all the same. The problem still happens more frequently when I plug everything in the Waversa Core, and less frequently with the additional network switch.

Without the vpn, my connection to Tidal would be much more unstable. I suspect the problem would be much worse without it. I think I should focus on the situation when playing local files in the Nas.

In the log files, did the Roon thought it’s disconnected from the network? Like it received a notification from the kernel that it lost its ip address and suddenly got it back immediately? Or it’s just because Roon didn’t get enough data in time and just paused without waiting for more data?

Hello @Timmy_Chen,

While you mention that the OpenVPN should theoretically not cause issues here, I have a gut feeling that it may and this is because we use Multicast packets to communicate with devices inside of the Roon ecosystem. Routing them to another location based on OpenVPN policy might be enough to hinder this multicast packet, but I cannot say with 100% certainly.

What I can tell you is that the logs report that your iPhone X is having trouble communicating over the RAAT protocol on the network at times. There are a few lines in the logs that read as follows:

07/02 00:04:55 Trace: [raatserver] [RaatServer TPhoneX] lost client connection. Retrying
07/02 00:04:55 Trace: [raatserver] [RaatServer TPhoneX] connecting (attempt 1)
07/02 00:04:55 Warn: [rnet/RnetJsonClient] failed to connect Connection refused
07/02 00:04:55 Info: [brokerserver] Client disconnected
07/02 00:04:59 Trace: [raatserver] [RaatServer TPhoneX] client connection failed. Giving up

Which makes me believe that there is a networking factor at play here. My follow up questions for this case would be:

  • What happens if we temporarily disable the OpenVPN, does the playback still randomly stop?
  • Are all your devices on the same subnet and using the same IP address range?
  • What happens if we temporarily remove the Orbi from the equation, does the playback stop?
  • If we temporarily try to use another computer as the Core, does playback still stop?

These questions should give us more information regarding what could be happening here, and I hope that you’ll agree with me. Please let me know if you manage to test any of the above and let me know your findings.

Thanks,
Noris

Hi Chen,

I experienced the very symptom and guess what. I use a Waversa switch. It has two banks of battery and when a switch over occurs (on my unit I can tell the switching moment by a tiny relay click sound), network connection is momentarily lost and in turn this makes non-resilient connection(like multicast) lose packets. I confirmed this fact with Waversa guys. I think Waversa be doing a bit more engineering in this regard. Perhaps another power buffer stage. To be certain you should listen for the relay click sound or do away with the Waversa unit.

Thanks for this response, the log snapshot & comments prompted me have another look at “random interruptions to playback.” I found a couple of problems which may have resolved my issues.

Maybe further snapshots, of common logfile error messages with a brief description of common problems that might cause them, would be helpful to many users (I haven’t spotted anything like this in other forums, yet).

Thanks.

Having seen comments here regarding logfile errors, I have spent a couple of hours going through logfiles which prompted both “technical and practical” solutions.

Playback has been dropping & stuttering unpredictably for sometime, so my first approach was a review of my Netgear ADSL Router. I checked signal strength in my all of my rooms all of which were around 80% of maximum, so in theory no major issues.

At this point I noticed that a fixed IP address had the incorrect device associated with it but the mac address was correct? I then found other network devices had similar issues device name, IP address & mac address inconsistencies. I was amazed that anything was working. After a couple of hours of correcting these discrepancies connections appear to have stabilised & connection error reports in the Roon logfile disappeared.

Further inspection of the logfile revealed numerous messages like:-

07/08 11:16:23 Trace: [airplay/client] server lost 1 packets starting at seq 20705
07/08 11:16:23 Trace: [airplay/client] resent packet to 192.168.1.3:1279 with seq 20705

My first thought was a possible Wi-fi issue, so, as my router was in the corner of my room, I moved it away from the corner by 1 metre. Rechecking the logfile showed, amazingly, ZERO lost packets.

The last of these changes was only two hours ago, but so far there have be no connection issues, dropped connections or lost packets. I can’t believe it was so simple…:zipper_mouth_face:

Hello @PixelPopper,

Glad to hear that you’ve been able to get these networking issues resolved!

While the fixes you applied seem like they should be obvious, sometimes it takes a fair bit of sleuthing to see what exactly is going wrong in a network and how it should be set up to maintain a stable connection, glad you have been able to do both of those steps.

Do let us know if you run into any other issues with your setup and we would be happy to take another look!

Thanks,
Noirs

I agree that router location is fairly obvious & while audio dropouts were rare I should have moved it sooner.
In the case the IP addresses & Mac addresses getting mixed up, it’s the first time i’ve ever experienced it, I assume from your comment that it’s quite common?

Hello @PixelPopper,

I can’t say that I have seen Mac Addresses and IP addresses getting mixed up ever before but in the case of playback stopping randomly, it can sometimes be attributed to the way a network is set up.

The obvious steps I was referring to was moving the access point a bit to prevent interference, checking signal strength levels, connecting devices through Ethernet instead of WiFi, making sure all devices are on the same subnet, ect. which you have done to troubleshoot the initial issue.

It does require a certain level of technical know-how which I am glad that you possess.

Thanks,
Noris

1 Like

Hi @noris

Although the problem is not solved by me, I think it’s ok the close the case.

I tried to disable OpenVPN, but the problem still occurred. Then I switched to the iMac as the Roon Core and it just played continuously for the whole day. I guess the problem is not on the Roon side.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.