ROON update stuck at “Downloading”

Hi, once in a while I run into problems updating ROON core. Thought I recap the steps that worked and therefore my feature suggestion.

I have ROCK so my ROON is headless. Part of the issue is due to misunderstanding of information presented on the ROON remote app on my iPhone.

I started up ROCK from cold. I then open ROON app on my iPhone. I did not receive the usual dashboard where I can start playing some music, instead the app took me to brand new screen requiring me to update ROON core (guess is the new “feature” of the latest app build 1.8.00880, I maybe wrong).

Unfortunately the page shows an exclamation icon in red next to my core and indicates that it is downloading. It has no indication if downloading is really in progress or stuck. The red icon did give me the impression that something went wrong. With my past experience on updating, I assumed it should take no more than a few minutes. Nothing seemed to happen after a few minutes. All research on Google say restart / reinstall with the web UI. I took the advice but that lead to the same experience.

I happened to switch to ROON remote of older version on iPad, there I can see the dashboard and everything. I was surprised that I received different experience than the app on iPhone. I took the opportunity to look at settings->about. Bingo! There I can see the download progress bar, and it was stuck, probably due to service/NUC restart. I did reinstall with the web UI one more time, and return back to the remote on iPad and see that it was able to complete the download after 10 min or so, and the upgrade was completed successfully.

I think the key in this update experience was the Remote app requires proper progress indicator so that you have good idea what the system is actually doing for the update.