Roon -> wireguard + opnsense [SOLVED]

Anybody using Opnsense and knows “UDP Broadcast relay” and how to configure it and how it works? Thisway to get Roon working on iPhone as endpoint while being away from home. E.g. works like “udp-proxy-2020” ?

I would like to use ROON when I am away on my iPhone as endpoint using Wireguard.
By default I get Roon to work over wireguard and it sees all local endpoints, but no longer the iPhone. The iPhone is seen while being on the local network. This is being fixed with this udp-proxy-2020 tool I read here on the forums. Opnsense comes with the plugin UDP broadcast relay, so I wonder if somebody has managed to get this to work?

Or maybe udp-proxy-2020 can be used on opnsense? There is an pfsense version: FreeBSD/Intel x86_64: freebsd-amd64 (works with pfSense on x86)

Kind regards

somebody with Opnsense and Roon?

1 Like

I do but not using wireguard (yet). If you figure it out please post. You could try a Fiverr gig?

1 Like

Did you try udp-proxy-2020? OpnSense is based FreeBSD like pfSense right? So the pfSense directions might work?

No I have not yet tried running udp-proxy-2020 on the opnsense box myself. I was hoping for somebody else with experience had tried it. Opnsense comes from pfsense years ago, but is developed further on its on, so I am a bit worried it may break things or does not work. And since I’m no programmer, I do not know on forehand what will happen when I install it “out of the blue” on the opnsense system…

Well I can say with a fair bit of certainty, that it won’t “break things”. And if it did, you could always take notes of what you do and reverse the steps. I don’t recommend deleting any files or anything like that.

Of course if you don’t feel comfortable trying, then this probably isn’t for you.

Good luck.

Ok, I will give it a try :slight_smile:

little dump question to make sure I understand it correctly:

in your setup script guide, point 4 it states:
Copy the correct udp-proxy-2020 binary for your system to /usr/local/bin/udp-proxy-2020

should I run fetch in the directory /usr/local/bin/ and rename the file to
udp-proxy-2020 ?

or should I run the fetch in a new directory /usr/local/bin/udp-proxy-2020/ and leave the file name “udp-proxy-2020-0.0.11-freebsd-amd64” as it is?

yes. that worked for me.
just logged in via ssh on my firewall and followed the pfsense instructions on my opnsense box.


You have to rename the file.

1 Like

I can confirm it works on opnsense also, running:
OPNsense 22.1.7_1-amd64
and over Wireguard to iPhone endpoint.

1 Like

1 item left to do. On opnsense UDP-Proxy-2020 does not survive a reboot and need to be manually started by me from shell.

I tried putting udp_proxy_2020_enable=YES in the /etc/rc.conf.local
as in /etc/rc.conf.d/udp_proxy_2020

as in adding it to the default file /etc/rc.conf
All did not work for me…

@Oliver_Gassner1 did you manage to get udp_proxy_2020 auto start on reboot of opnsense?

Just tried a reboot.
service is running

root@OPNsense:~ # service udp-proxy-2020 status
udp-proxy-2020 is running (6908)

did you make the startupscript executable (not only the binary itself in /usr/local/bin)?

root@OPNsense:/usr/local/etc/rc.d # ls -l udp-proxy-2020
-rwxr-xr-x  1 root  wheel  1196 May 10 21:54 udp-proxy-2020

thanks for testing and strange.
executable rights:
/usr/local/bin # ls -l udp-proxy-2020
-rwxr-xr-x 1 root wheel 6364632 Apr 14 17:44 udp-proxy-2020

/usr/local/etc/rc.d # ls -l udp-proxy-2020
-rwxr-xr-x 1 root wheel 1196 May 12 08:25 udp-proxy-2020

it is fixed. I did some extra testing and found that it had to do with my checking it to soon while after reboot. When I just waited an extra minute and tested again the status was changed to running :slight_smile:

All good. thnx for the help!