Roon with Vivaldi - Start of tracks cut when switching selection

I recently had Roon installed on my QNAP server . Works great but for a small quirk - - the first couple of notes of a new selection ,i.e. , first song on an album or when switching between cuts , do not play . FTI , QNAP 8 bay Thunderbolt server with all SSDs ,through " enterprise-level " ethernet switches to dCS Vivaldi Upconverter .

This actually isn’t an issue with the QNAP and has to do with how the Vivaldi re-syncs the clock on a sample rate change. In essence the upsampler outputs no signal which mutes the DAC. When the upsampler starts playing the DAC sees that and un-mutes and then syncs to the incoming signal. If there’s a change in base clock frequency this results in a second round of mutes while the DAC switches over. Meanwhile the upsampler is playing, but the DAC isn’t quite there yet.

You have a couple of options.

  1. In Roon under Audio Setup scroll down to the Vivaldi and click the gear icon. Select settings. Change the resync delay to 2000ms and see if that helps. Depending on how your upsampler is set to output (DSD or DSDx2 doesn’t need as much time) you may need to set this as high as 5000ms.

  2. In the DAC configuration turn on buffering. I haven’t tried this with Roon, but it did help with UPnP streaming and USB playback. At times I felt that it had a negative impact on sound quality, but that was so minor that I’m not sure I was hearing it or not.

Ultimately, this is just a side-effect of the Vivaldi architecture and it’s present with Roon, UPnP and USB. I’ve submitted a couple of requests to dCS with ideas on how to minimize this behavior.

1 Like

Thanks a bunch ! Much appreciated , I’ll also pass on to dCS .